Welcome, Guest. Please login or register.
Did you miss your activation email?

Recent Posts

Pages: 1 ... 7 8 [9] 10
81
Upgrade Warnings (DE / EN) / Re: pipewire seems to be activated
« Last post by unklarer on 2021/11/21, 19:15:56 »
Yes.
It is also in the changelog:
Code: [Select]
pipewire (0.3.39-4) unstable; urgency=medium
...
...
  * Re-add pipewire-media-session as an alternative to Wireplumber,
      it is now back in the archive as a separate source package.
82
Bis vor Kurzem war das auch noch so, das es nicht aktiviert war. Ich vermute, das hat sich geändert, als pipewire-media-session rausflog und man wireplumber installiert werden musste. Ich habe aber auch keine Verlautbarung von Debian dazu mitbekommen. Inzwischen ist pipewire-media-session wieder im repo. Ich würde trotzdem zu wireplumber raten.
83
Upgrade Warnings (DE / EN) / Re: pipewire seems to be activated
« Last post by Geier0815 on 2021/11/21, 18:13:40 »
You saw that pipewire-media-session is back and recomended over wireplumber if you want use bluetooth?

However, pipewire-media-session is still available as an alternative to wireplumber. If you are interested in automatic bluetooth profile switching (e.g. switching from A2DP to HSP/HFP when an application needs microphone access) then it's best to stay with pipewire-media-session as wireplumber doesn't support it yet.
84
Upgrade Warnings (DE / EN) / Re: pipewire seems to be activated
« Last post by unklarer on 2021/11/21, 17:08:25 »
^Yes, thanks for mentioning that again.
It is not "anything" but the change from pipewire-media-session to wireplumber.

https://metadata.ftp-master.debian.org/changelogs//main/p/pipewire/pipewire_0.3.40-1_changelog

This was also described here already in 2 pages (and bluetooth) is at the end.   :D

------------------------------------
Ja, danke dass du das nochmal erwähnst.
Es ist nicht "irgendetwas" sondern der Wechsel von pipewire-media-session auf wireplumber.

Das wurde auch hier bereits in 2 Seiten beschrieben (und bluetooth) steht am Schluß.
85
Ich kann mich erinnern, dass ich nach dem Lesen von
https://linuxnews.de/2021/11/wireplumber-session-manager-fuer-pipewire/
wireplumber auf meinem Rechner installiert habe. Sound funktionierte weiterhin problemlos.

Auf dem Rechner meiner Frau habe ich das nicht getan und nach einem DU traten die Probleme auf. Auf meinem Rechner war pipewire mit wireplumber aktiviert, bei meiner Frau nicht.
Code: [Select]
LANG=C pactl info | grep '^Server Name' gab bei mir 
Code: [Select]
Server Name: PulseAudio (on PipeWire 0.3.40) aus, bei ihr nur
Code: [Select]
Server Name: PulseAudio Das habe ich alles erst heute festgestellt. Das simple Nachinstallieren von wireplumber hat es dann gebracht.

Ich zitiere dann mal den Teufel mit seinem letzten Satz aus dem oben verlinkten Artikel
Quote
Mit der rasanten Entwicklung von PipeWire und dem neuen Session-Manager WirePlumber sehen wir, wie ich finde, spannenden Zeiten im Bereich Audio/Video entgegen
und habe dem nichts hinzuzufügen.

oduffo

86
Software-Support (DE) / Erfahrungen mit PipeWire
« Last post by Geier0815 on 2021/11/21, 16:54:10 »
Moin Moin,

da das Thema nun doch für mehr User interessant wird, möchte ich hier einen Thread starten wo jeder so seine Erfahrungen und evtl. Tipps und Tricks posten kann die evtl. auch für andere interessant sein können.

Ich selber habe mich auch erst die letzten 14 Tage mit PipeWire beschäftigt, nachdem ich in den Linuxnews über das Thema gestolpert bin (Danke devil)
Ich spiele derzeit ein wenig mit Sachen wie musescore, ardour etc herum und fand die Trennung jack und pulseaudio ziemlich nervig. Hast Du zB ardour auf, kannst Du keine Youtube-Videos mit Tutorials laufen lassen, weil ardour jack verwendet, firefox hingegen pulseaudio. Von daher klang pipewire vielversprechend.
PipeWire im Debian-Wiki ist die erste Stelle die man anlaufen sollte wenn man sich mit dem Thema beschäftigt.
Mein erster Versuch endete erst einmal mit einem System ohne Sound. Es fehlte ein mediensession-manager. Hier kann man dann wireplumber verwenden oder auch pipewire-media-session, welches wieder neu in den Repos zu finden ist. Damit funktionierte dann auch der Sound.
Seit der 40er Version von pipewire funktioniert bei mir auch qjackctl wieder so wie es soll und tatsächlich auch für MIDI und pulseaudio.

Womit ich allerdings derzeit Probleme habe, ist fehlender Sound nach dem Aufwecken aus dem suspend. Hier hilft dann ein
Code: [Select]
systemctl --user restart pipewire-pulse.
Ansonsten bin ich soweit schon mal zufrieden. Selbst Soundausgabe per Bluetooth klappt, allerdings mußte ich das Koppeln meines HMDX-Lautsprechers erst einmal als root per Konsole durchführen, das hat per network-manager-plugin als User nicht funktioniert.
87
Upgrade Warnings (DE / EN) / pipewire seems to be activated
« Last post by Geier0815 on 2021/11/21, 16:22:37 »
For seeing 3 users with problems with sound, soundhardware incl. bluetooth, it seems to me that something is activating pipewire as soundsystem.
If you have problems related with sound, please check if pipewire is activated at your system:
Code: [Select]
LANG=C pactl info | grep '^Server Name' If the result is similar to
Quote
PulseAudio (On PipeWire 0.3.xx)
than have a closer look at the pipewiresction at the debian wiki

Da jetzt schon 3 User Probleme mit Sound, Soundhardware incl Bluetooth hatten, sieht es für mich so aus als würde derzeit irgendetwas pipewire als Soundsystem aktivieren.
Wenn ihr also Probleme irgendeiner Art mit dem Sound habt, prüft bitte ob pipewire auf eurem System aktiv ist.
Code: [Select]
LANG=C pactl info | grep '^Server Name' Wenn das Ergebnis in der Art:
Quote
PulseAudio (On PipeWire 0.3.xx)
aussieht, solltet ihr einen Blick in den PipeWire-Abschnitt des debian wikis werfen
88
Quote
Bisher hieß es nämlich immer das pipewire zwar installiert wird aber nicht aktiviert, zumindest hatte ich es so verstanden

Hatte ich auch so verstanden. Und was halt noch besonders doof ist, ist dass das nicht zu Stande kommen der Bluetooth Verbindung mit der Fehlermeldung "Protokoll nicht vorhanden" erst mal nicht in diese Richtung weisst, wenigstens nicht für den einfachen user.
89
Was ich bei dem Ganzen so erschreckend finde ist, das ihr nicht die ersten seid bei denen ohne eigenes Zutun pipewire aktiv war/ist. Also nicht nur installiert sondern tatsächlich aktiv.
Bisher hieß es nämlich immer das pipewire zwar installiert wird aber nicht aktiviert, zumindest hatte ich es so verstanden.

@oduffo,

da pipewire die Funktion von pulseaudio "übernimmt" bzw eine weitere Schicht dazwischen zieht, könnte ich mir vorstellen das es dann auch die Steuerung des pulseaudio-bluetooth-stacks "übernimmt". Wenn bei dir pipewire aktiv ist, solltest Du mal gucken ob Du das bluetooth-modul nicht lieber von pipewire verwendest. Andererseits: Wenn es läuft... Mußt Du dann nur im Hinterkopf behalten falls es irgendwann mal nicht mehr funktioniert.
90
Quote
"Aber das muss ich im Moment nicht verstehen"
sagt
oduffo

 ;D okay, ich auch nicht
Pages: 1 ... 7 8 [9] 10