Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: Error compiling 5.13 kernels with nvidia legacy 340  (Read 432 times)

Offline ajavibp

  • User
  • Posts: 110
    • The website of the association where I collaborate.
Hi, I currently use the official Debian kernel because it has not compiled the siduction kernel for a long time. Now that I have a bit of free time and I have started to see what happens. The error that appears is:
Quote
make NV_MODULE_SUFFIX= KERNEL_SOURCES=/lib/modules/5.13.8-1-siduction-amd64/build KERNEL_OUTPUT=/lib/modules/5.13.8-1-siduction-amd64/build KBUILD_VERBOSE=1 -C /lib/modules/5.13.8-1-siduction-amd64/build M=/var/lib/dkms/nvidia-legacy-340xx/340.108/build ARCH=x86_64 modules
make[2]: go into '/usr/src/linux-headers-5.13.8-1-siduction-amd64'
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (      \
echo >&2;                     \
echo >&2 "  ERROR: Kernel configuration is invalid.";      \
echo >&2 "         include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 "         Run 'make oldconfig && make prepare' on kernel src to fix it.";   \
echo >&2 ;                     \
/bin/false)
I go to /usr/src/linux-headers-5.13.8-1-siduction-amd64 directory and run 'make oldconfig && make prepare', but I get a new error that I don't know how to correct:
Quote
lib/Kconfig.debug:2604: can't open file "Documentation/Kconfig"
make[1]: *** [scripts/kconfig/Makefile:77: oldconfig] Error 1
make: *** [Makefile:621: oldconfig] Error 2
Do you have any idea how to solve this? I have searched the internet but I have not seen anything clear.
Thanks a lot!

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.538
Re: Error compiling 5.13 kernels with nvidia legacy 340
« Reply #1 on: 2021/08/04, 19:43:33 »
1. You have not pasted the whole output! What you have pasted will always show.
2. If that is the only error, you don't have the kernel-headers installed on your system.
3. That driver will need patched for working with recent kernels.

You really should think about new graphics card, with suck old hardware you will not get lucky in soon time.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline ajavibp

  • User
  • Posts: 110
    • The website of the association where I collaborate.
Re: Error compiling 5.13 kernels with nvidia legacy 340
« Reply #2 on: 2021/08/04, 20:08:09 »
Thanks Towo.
Quote
1. You have not pasted the whole output! What you have pasted will always show.
Sorry, I thought the mistake would be enough. Here is the full compilation output: https://pastebin.com/79vTkPDp
Quote
2. If that is the only error, you don't have the kernel-headers installed on your system.
Yes, I have  :-\
Code: [Select]
aptitude search ~ilinux-headers
idA linux-headers-5.10.0-7-amd64    - Header files for Linux 5.10.0-7-amd64     
idA linux-headers-5.10.0-7-common   - Common header files for Linux 5.10.0-7   
i A linux-headers-5.10.0-8-amd64    - Header files for Linux 5.10.0-8-amd64     
i A linux-headers-5.10.0-8-common   - Common header files for Linux 5.10.0-8   
i A linux-headers-5.10.20-towo.1-si - Header files for Linux 5.10.20-towo.1-sidu
idA linux-headers-5.13.7-2-siductio - Header files for Linux 5.13.7-2-siduction-
i A linux-headers-5.13.8-1-siductio - Header files for Linux 5.13.8-1-siduction-
i   linux-headers-amd64             - Header files for Linux amd64 configuration
i   linux-headers-siduction-amd64   - Linux headers for siduction on 64-bit PCs

Quote
3. That driver will need patched for working with recent kernels.
Many patches are applied automatically on installation, but that's probably the problem. I've been searching without much luck, I'll keep looking to see if I find something.

Quote
You really should think about new graphics card, with suck old hardware you will not get lucky in soon time.
Of course, I am aware of it, but it is a laptop that still works very well (Toshiba Satellite A660-1EQ with i7 processor and 8GB of RAM)

Thank you very much for your interest

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.538
Re: Error compiling 5.13 kernels with nvidia legacy 340
« Reply #3 on: 2021/08/04, 20:46:47 »
I have only found a patch for 5.11  https://paste.debian.net/1206581/
No clue, if it is enought for 5.12/5.13 or another patch is needed.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline ajavibp

  • User
  • Posts: 110
    • The website of the association where I collaborate.
Re: Error compiling 5.13 kernels with nvidia legacy 340
« Reply #4 on: 2021/08/11, 19:20:13 »
The link leads to "Entry not found".
Sorry for the delay in answering. The forum post got spammed.