Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: no modul-build with nvidia-driver 495.44-0~siduction.3  (Read 505 times)

Offline michaa7

  • User
  • Posts: 2.165
After d-u and updating form nvidia-driver  470.74-1 to  495.44-0~siduction.3 there was no nvidia modul built observable. On reboot, obviously the modul failed to load ... no X.

Matters were complicated further by the fact that now nvidia-driver  470.74-1 is not installable anymore. Trying to resolve dependencies manually endet to no avail. Not evan purging nvidia comletely allowed a reinstall of v 470.74-1 afterwards.

Now the computer runs with nouveau driver:
Quote
# inxi -G
Graphics:  Device-1: NVIDIA GK208B [GeForce GT 710] driver: nouveau v: kernel
           Display: server: X.org 1.20.11 driver: loaded: modesetting unloaded: fbdev,vesa tty: 126x29
           Message: Advanced graphics data unavailable in console for root.

For further investigation I would like to know what output I should generate with (broken) nvidia installed?
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.577
Re: no modul-build with nvidia-driver 495.44-0~siduction.3
« Reply #1 on: 2021/10/31, 16:31:03 »
Kepler is not supported anymore in the 495 series drivers.
So purge all installed nvidia packages and install nvidia-legacy-390xx-driver.
In i don't see any reason, why the 470 series driver should not install.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline michaa7

  • User
  • Posts: 2.165
Re: no modul-build with nvidia-driver 495.44-0~siduction.3
« Reply #2 on: 2021/10/31, 16:50:17 »
Kepler is not supported anymore in the 495 series drivers.

Thanks for this info. Didn't know.

So purge all installed nvidia packages and install nvidia-legacy-390xx-driver.
In i don't see any reason, why the 470 series driver should not install.

I'd prefer 470 over 390, but ...
Quote
# apt install nvidia-driver=470.74-1 -s
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
Statusinformationen werden eingelesen… Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 nvidia-driver : Hängt ab von: nvidia-driver-libs (= 470.74-1) aber 495.44-0~siduction.3 soll installiert werden
                 Hängt ab von: nvidia-driver-bin (= 470.74-1) aber 495.44-0~siduction.3 soll installiert werden
                 Hängt ab von: xserver-xorg-video-nvidia (= 470.74-1) aber 495.44-0~siduction.3 soll installiert werden
                 Hängt ab von: nvidia-vdpau-driver (= 470.74-1) aber 495.44-0~siduction.3 soll installiert werden
                 Hängt ab von: nvidia-alternative (= 470.74-1)
                 Hängt ab von: nvidia-kernel-dkms (= 470.74-1) aber 495.44-0~siduction.3 soll installiert werden oder
                                nvidia-kernel-470.74
                 Empfiehlt: nvidia-settings (>= 470) soll aber nicht installiert werden
                 Empfiehlt: libnvidia-cfg1 (= 470.74-1) soll aber nicht installiert werden
                 Empfiehlt: nvidia-persistenced
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

Quote
# apt install nvidia-driver=470.74-1 nvidia-driver-libs=470.74-1 nvidia-driver-bin=470.74-1 xserver-xorg-video-nvidia=470.74-1  nvidia-vdpau-driver=470.74-1 nvidia-alternative=470.74-1 nvidia-kernel-dkms=470.74-1 nvidia-kernel-dkms=470.74-1 libgl1-nvidia-glvnd-glx=470.74-1 nvidia-egl-icd=470.74-1  libglx-nvidia0=470.74-1  libnvidia-eglcore=470.74-1  libnvidia-glcore=470.74-1 libegl-nvidia0=470.74-1  nvidia-kernel-support--v1  nvidia-kernel-support=470.74-1  nvidia-alternative:i386=470.74-1  nvidia-alternative=470.74-1
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
Statusinformationen werden eingelesen… Fertig
Hinweis: »nvidia-kernel-support« wird an Stelle von »nvidia-kernel-support--v1« gewählt.
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 nvidia-alternative : Kollidiert mit: nvidia-alternative:i386
 nvidia-alternative:i386 : Kollidiert mit: nvidia-alternative
 nvidia-kernel-support : Hängt ab von: nvidia-alternative (= 495.44-0~siduction.3)
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

BTW: Is there a way to tell apt to append all dependencies, whatever a package needs. Or do I have to do it really manually?
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.577
Re: no modul-build with nvidia-driver 495.44-0~siduction.3
« Reply #3 on: 2021/10/31, 17:04:11 »
I dont't see your problem!
Temoprary disable our fixes repo, make sure, all nvidia related packages are purged

apt update
apt install nvidia-driver
put it on hold or pin the relevant nvidia packages.
Reenable the fixes repo.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline michaa7

  • User
  • Posts: 2.165
Re: no modul-build with nvidia-driver 495.44-0~siduction.3
« Reply #4 on: 2021/10/31, 17:55:13 »
Erstaml danke für die Hilfe.

Ich musste ncha dem purge noch ein apt autoremove durchführen damit alles weg war, warum auch immer. fixes repo auskommentiert, konnte nvidia-driver=470xy installieren. X wieder mit nvidia.

ABER:

Nach wiederaktivieren des fixes repo kann ich kein d-u mehr machen (nvidia-driver ist per "apt-mark hold nvidia-driver" gepinnt).
Quote
# apt-mark showhold
apt-cacher-ng
nvidia-driver
Quote
# apt update && apt dist-upgrade -d
OK:1 http://neutower:3142/deb.debian.org/debian unstable InRelease
Ign:2 http://repo.vivaldi.com/snapshot/deb stable InRelease           
OK:3 http://neutower:3142/deb.debian.org/debian experimental InRelease   
OK:4 https://repo.skype.com/deb stable InRelease                         
OK:5 http://neutower:3142/deb.debian.org/debian stable InRelease         
OK:6 http://neutower:3142/ftp.halifax.rwth-aachen.de/siduction/extra unstable InRelease         
OK:7 https://dl.jami.net/nightly/debian_10 ring InRelease                                       
OK:8 http://neutower:3142/ftp.halifax.rwth-aachen.de/siduction/fixes unstable InRelease         
Ign:9 http://repo.vivaldi.com/stable/deb stable InRelease
OK:10 http://repo.vivaldi.com/snapshot/deb stable Release
OK:11 http://repo.vivaldi.com/stable/deb stable Release
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
Statusinformationen werden eingelesen… Fertig
Aktualisierung für 54 Pakete verfügbar. Führen Sie »apt list --upgradable« aus, um sie anzuzeigen.
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
Statusinformationen werden eingelesen… Fertig
Paketaktualisierung (Upgrade) wird berechnet… Fehler!
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 nvidia-driver : Hängt ab von: nvidia-driver-libs (= 470.74-1) soll aber nicht installiert werden
                 Hängt ab von: xserver-xorg-video-nvidia (= 470.74-1) soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

Muss ich tatsächlich jedes einzelne nvidia paket manuel auf hold setzen?

Es schein mir fehlerhaft, das nvidia-driver aus dem siduction repo in der liste der »apt list --upgradable« auftaucht, wenn es auf hold sitzt.
« Last Edit: 2021/10/31, 17:58:38 by michaa7 »
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline michaa7

  • User
  • Posts: 2.165
Re: no modul-build with nvidia-driver 495.44-0~siduction.3
« Reply #5 on: 2021/10/31, 18:04:29 »
sorry
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline michaa7

  • User
  • Posts: 2.165
Re: no modul-build with nvidia-driver 495.44-0~siduction.3
« Reply #6 on: 2021/10/31, 18:13:02 »
Ok, da ich meine eigenen Forenbeiträge nicht editieren kann (es wir nicht abgespeichert, sooft ich auch versuche) hier die lösung für das d-u problem:

Code: [Select]
apt-mark hold nvidia*
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline sotnik

  • User
  • Posts: 76
Re: no modul-build with nvidia-driver 495.44-0~siduction.3
« Reply #7 on: 2021/11/06, 01:40:43 »
I had the same problem
I purged all nvidia packages and I enabled nouveau in order to login into X

I disabled all siduction repos and refresh the package data base (apt update), however when I tried to install nvidia-driver I got the following errors

Code: [Select]
apt install nvidia-driver
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libegl-nvidia0 : Depends: libnvidia-eglcore (= 470.82.00-1) but 495.44-0~siduction.3 is to be installed
 libglx-nvidia0 : Depends: libnvidia-eglcore (= 470.82.00-1) but 495.44-0~siduction.3 is to be installed
                  Depends: libnvidia-glcore (= 470.82.00-1) but 495.44-0~siduction.3 is to be installed
 xserver-xorg-video-nvidia : Depends: libnvidia-glcore (= 470.82.00-1) but 495.44-0~siduction.3 is to be installed
                             Recommends: nvidia-settings (>= 470) but it is not installable
E: Unable to correct problems, you have held broken packages.


Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.172
    • Land of the Buckeye
Re: no modul-build with nvidia-driver 495.44-0~siduction.3
« Reply #8 on: 2021/11/06, 11:06:18 »
Quote from: sotnik
...I enabled nouveau in order to login into X.
That was probably a mistake. You could download needed Nvidia driver packages while in X, but you can't install a different video driver while running the X server. You can only do it in the console.

So (not knowing your hardware), the general instruction is to remove --purge nouveau, and follow towo's instruction above to install an older Nvidia driver, if that's what you need.
System76 Oryx Pro, Intel Core i7-11800H, SSD 970 EVO Plus;  Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO

Offline michaa7

  • User
  • Posts: 2.165
Re: no modul-build with nvidia-driver 495.44-0~siduction.3
« Reply #9 on: 2021/11/06, 11:36:39 »
Alt-Strg-F1
apt purge nvidia*
apt autoremove (that's important, because "apt purge nvidia*" didn't remove all relevant packages ... for whatever reaseon)

and if you then install a new nvidia driver make sure to set it on hold. I did "apt-mark hold nvidia*". I think one could omitt this step by installing a legacy driver instead ot the current one.
Ok, you can't code, but you still might be able to write a bug report for Debian's sake