Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: grub-install findet Windows nicht  (Read 439 times)

Offline charlyheinz

  • User
  • Posts: 34
grub-install findet Windows nicht
« on: 2021/09/10, 09:54:34 »
Hello everybody
I run into trouble while installing the actual Farwell release on a laptop with NVMe device. Actual I don't know it depends on the drive or it is a problem with os-prober or anything else.
Grub-install and update-grub do not find the windows-installation which is present.
Before this installation of Farewell I have had c-blues Siduction-release already running with the same problem that the W$ installation was not found by grub and with a lot of tries I've had got it running fine, really I don't know how.
Before installing Farewell I have made no changes to the bios, let it all the same.
I've used a usb-device to start a chroot- surrounding and have mounted all necessary partitions to install grub and have used update-grub to find out which systems will be found- everything but no W$.

Is anyone out there to give a hind? I have no idea anymore.

Offline unklarer

  • User
  • Posts: 618
Re: grub-install findet Windows nicht
« Reply #1 on: 2021/09/10, 10:39:59 »
^Why make it hard for yourself when it's easy? Since when do you chroot into the system during installation to install the bootloader and see if it does it right?

Please use calamares to install Farewell. That already shows you your M$.

Offline charlyheinz

  • User
  • Posts: 34
Re: grub-install findet Windows nicht
« Reply #2 on: 2021/09/10, 12:02:22 »
Puh, I've got it.
What I have done:
1. booted the Live-USB-Stick
2. mounted the boot/efi partition and deleted the old siduction entries / folders
3. As I had done it before used the Calamaris-installer to reinstall the Farewell-System
4. Setup the chroot environment as it is described in https://forum.siduction.org/index.php?topic=6065.msg49947#msg49947
5. used update-grub to check if W$ is recognized

yep- everything is configured and nice again



What is about adding entries through grub.d/*40_custom to manually add and configure a W$- entry.
I would not like to reinstall Siduction if anything corrupt the system again.


@unklarer thanks for your reply and have a nice weekend  ;)


Offline unklarer

  • User
  • Posts: 618
Re: grub-install findet Windows nicht
« Reply #3 on: 2021/09/10, 16:45:31 »
 ;D  Hmm, ich sehe gerade, du hast den Faden in der deutschen Sektion eröffnet und englisch geschrieben...  und, ich mach' das mit.   :P

Meinst du wirklich, dass nach 5 1/2 Jahren (so alt ist der von dir verlinkte Thread)  in calamares nichts passiert ist und ein chrooten immer noch nötig ist, um das mit Grub zu richten? 

----------------------------

 ;D Hmm, I just see you opened the thread in the German section and wrote in English....  And, I'll go with that.   :P

Do you really think that after 5 1/2 years (that's how old the thread you linked is) nothing has happened in calamares and a chroot is still needed to fix it with grub?

Wünsche dir auch ein schönes WE, Danke.   8)

Offline charlyheinz

  • User
  • Posts: 34
Re: grub-install findet Windows nicht
« Reply #4 on: 2021/09/10, 17:21:08 »
Ja so ist das wenn man nicht der große Community- Schreiber ist. Irgendwie tue ich mich da immer noch schwer ;)

But by the way- actually I don't know if a chroot- surrounding is still necessary to repair this Grub adjustments.
Do you have any idea what's this all about with grub.d/*40_custom. I've tried to fix all this Grub-stuff with this method but it did not work. Actually I don't know why I could repair this issue like the way I've done it with mounting and chroot?!
But I'm happy about the fresh and running dualboot- machine now.

Scherz beiseite. Genau weiß ich das auch nicht ob heutzutage dieser chroot Umweg nötig ist um zu prüfen ob os-prober/install-grub während einer Neuinstallation den boot manager richtig eingerichtet haben. Ich hatte das so verstanden und entsprechend gemacht und freue mich sehr über das neue frische Dual-boot- System auf meiner neuen Errungenschaft. Ich habe den Lenovo Convertibel für Dünnes bei "all den guten Dingen" online gegriffen weil ich schon lange für meine Arbeit nach so etwas Ausschau gehalten habe. So ein neuer Schleppi ist schon richtig fix. Musste einige Dinge im Bios umstellen (iRST / AHCI, Secureboot) was den Systemstart auch etwas verlangsamt hat - aber nur marginal. Aber die Kiste rennt auf der NVMe PCIe- Platte wirklich wie die Hölle.
Falls dir zu dem Thema "grub.d/*40_custom" sonst noch etwas einfällt würde ich mich über einen post freuen. Ansonsten wünsche ich ein gemütliches WE.

Offline unklarer

  • User
  • Posts: 618
Re: grub-install findet Windows nicht
« Reply #5 on: 2021/09/10, 19:45:49 »
^^ Hoffentlich kommen wir da noch zum WE, wenn das so weitergeht....   :P  ;D

Erst einmal Glückwunsch zu deiner neuen Errungenschaft.  Das ist wirklich  8)
Ich alter Mann habe nur alte Maschinen, die die Efi nie gesehen haben. Deshalb bin ich mir nicht sicher, ob das hier deine Frage bezüglich 40_custom umfänglich beantwortet.

Sollte mir irgendwann so eine "Efi-Maschine" in die Finger kommen, dann käme Grub nicht mehr zum Zug. Ich würde voll auf bootctl setzen.

Übrigens würde ich annehmen, dass das Team hier unter "Installationshinweise und bekannte Probleme" mehr noch zu calamares geschrieben hätte.   :)

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.150
    • Land of the Buckeye
Re: grub-install findet Windows nicht
« Reply #6 on: 2021/09/10, 21:06:01 »
re: NVMe device ...

In my experience, I learned that every kind of SSD is not necessarily recognized as a bootable device by every BIOS. If you have a kind of SSD (like PCI-e) that is not seen as a bootable device by the BIOS, then the Linux installer will also not see that it is a place for grub to be installed.

Entschuldigung sie für Englisch, bitte.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD2003FZEX in BTRFS

Offline charlyheinz

  • User
  • Posts: 34
Re: grub-install findet Windows nicht
« Reply #7 on: 2021/09/11, 12:30:28 »
@dibl
Yes your right! NVMe at PCIe is not as easy to configure as a boot-device as a SATA-SSD. But actually it depends on the uefi- Bios of the motherboard itself. And also Intel iRST vs. AHCI is to check out, especially when installing as a dualboot- system.

With my productive system I am using a NVMe- Interface card which is not able to boot from because of the UEFI- Version <2.0.
I think on this machine it is only possible to mount /boot on a SSD- Partition and / (root) on a NVMe, but I haven't tried out yet.
My son has a little bit newer motherboard  as mine with a UEFI- Version >2.0 and the same controller card connected where the same NVMe- PCIe drive is running as a boot-device perfectly! (booting in around 5 seconds)

On my new bought Lenove- convertible (Ideapad c340) I had to figure out how to configure iRST, AHACI, Fastboot and the corresponding W$ registry entries for using AHCI instead of iRST to enable a Dual-Boot- system. But it is not that difficult!! And what you will get is really fast system.

When I first started the Convertible I was shocked how fast it was booting. But that configuration was not able to run at a dual-boot-system because of the iRST configuration and the fast-boot mechanism. Siduction could not find any partition and also no boot-partition.
I don't know if there will be support for iRST in Linux-kernels in the future but it doesn't matter. I like NVMe.

So, thanks for the interesting conversation and take care.

Offline charlyheinz

  • User
  • Posts: 34
Re: grub-install findet Windows nicht
« Reply #8 on: 2021/09/11, 12:35:04 »
@unklarer

Grüße- könnte bootctl einen komfortableren Ersatz für den alt hergebrachten grub darstellen? Ist mit bis dato völlig unbekannt.
Werde mich mal schlau machen wie der anzuwenden ist.

Danke für die Info!

Offline unklarer

  • User
  • Posts: 618
Re: grub-install findet Windows nicht
« Reply #9 on: 2021/09/11, 13:25:36 »
@unklarer

Grüße- könnte bootctl einen komfortableren Ersatz für den alt hergebrachten grub darstellen? Ist mit bis dato völlig unbekannt.
Werde mich mal schlau machen wie der anzuwenden ist.

Danke für die Info!

Moin, moin!

Das kann ich für dich "abkürzen", denn hier war Einer fleißig und hat seine Vorgehensweise auf pastebin öffentlich gemacht.

Du mußt das aber nicht mehr dieses WE tun...   ;D  ;)   Hahaha, bin nur neugierig auf ein paar Worte von dir im Forum. 

Offline charlyheinz

  • User
  • Posts: 34
Re: grub-install findet Windows nicht
« Reply #10 on: 2021/09/11, 14:44:19 »
@unklarer
Na das ließt sich ja spannend. Ich habe parallel im I-Net recherchiert um eine Idee von der Vorgehensweise zu bekommen.
Die Konfigurationsmöglichkeiten scheinen ja ziemlich grenzenlos zu sein. Da muss ich mich erst einmal richtig einlesen.

Die Technik EFI /systemd zum booten zu benutzen erscheint plausibel. Obwohl ich nach wie vor einfach ein bisschen Unbehagen bei dem ganzen UEFI Möglichkeiten habe, (network-stack, unkontrolierbare Internet- Verbindung, etc.) Wenn man bedenkt das ein Win 3.11 seiner Zeit auf 7x1.44 MB Disketten passte und jetzt ein onboard UEFI  unkontrollierbar Speicher zur Verfügung stellt, in den faktisch ein gesamtes Betriebssystem Platz findet. uaahh :(

Man wird es nicht beeinflussen können was die Großen (In.. , M$) uns so aufbürden. Ich kann mich noch an ein Telefonat mit der CT- Redaktion zu Zeiten der UEFI- Einführung erinnern, in dem der Redakteur auf meine Bedenken nur die Antwort hatte: Na- wenn sie Angst vor dem Netzwerkstack haben dann müssen sie eben das LAN- Kabel abziehen. Aufschlussreich, oder?

So, leider habe ich kein WE und muss jetzt ein bisschen schaffen.

Haltet die Ohren steif!