seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2017/03/28, 19:44:46


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Somewhat risky experiment: apt autoremove  (Read 404 times)

0 Members and 1 Guest are viewing this topic.

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.559
    • http://landofthebuckeye.net/
Somewhat risky experiment: apt autoremove
« on: 2017/02/02, 19:17:45 »

For Debian and Debian derivative stable systems, "autoremove" is the recommended apt command to remove packages that are obsolete or orphaned, and no longer needed by the system.  But "autoremove" has never, to my recollection, been recommended for use on sid, due to the rolling nature of package introductions and transitions.



Since sid is at this moment pretty stable due to the upcoming Stretch freeze, I thought it might be worth an experiment to see if I could clean up a couple of my systems without damage.  Both of these systems are a couple of years old and came through the plasma 5 transition last year, so I guessed there was quite a bit of cruft laying around in them.


On this system:


Code: [Select]
System:    Host: Hibiscus Kernel: 4.9.7-towo.1-siduction-amd64 x86_64 (64 bit gcc: 6.3.0)
           Desktop: KDE Plasma 5.8.4 (Qt 5.7.1)
           Distro: siduction 13.2.1 December - kde - (201401272125)
Machine:   Device: desktop System: ASUS product: All Series
           Mobo: ASUSTeK model: Z87-WS v: Rev 1.xx BIOS: American Megatrends v: 2004 date: 06/05/2014
CPU:       Quad core Intel Core i7-4770 (-HT-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 28020
           clock speeds: max: 3900 MHz 1: 799 MHz 2: 1900 MHz 3: 868 MHz 4: 981 MHz 5: 890 MHz
           6: 914 MHz 7: 3403 MHz 8: 808 MHz
Graphics:  Card: NVIDIA GM107 [GeForce GTX 750 Ti] bus-ID: 04:00.0
           Display Server: X.Org 1.19.1 driver: nvidia
           Resolution: 1920x1200@59.88hz, 1920x1080@60.00hz
           GLX Renderer: GeForce GTX 750 Ti/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 375.26 Direct Rendering: Yes
Network:   Card-1: Intel I210 Gigabit Network Connection
           driver: igb v: 5.4.0-k port: c000 bus-ID: 06:00.0
           IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: e0:3f:49:e6:85:c3
           Card-2: Intel I210 Gigabit Network Connection
           driver: igb v: 5.4.0-k port: 9000 bus-ID: 09:00.0
           IF: enp9s0 state: down mac: e0:3f:49:e6:85:c4
Drives:    HDD Total Size: 3120.6GB (29.8% used)
           ID-1: model: WDC_WD1001FALS
           ID-2: model: WDC_WD1000DHTZ
           ID-3: model: OCZ_VERTEX
           ID-4: model: WDC_WD1000DHTZ
Info:      Processes: 278 Uptime: 6:51 Memory: 1870.0/32119.5MB
           Init: systemd runlevel: 5 Gcc sys: 6.3.0 Client: Shell (bash 4.4.111) inxi: 2.3.5




I ran apt autoremove this morning, and the result looked like this (from /var/log/apt/history.log):




Code: [Select]
Start-Date: 2017-02-02  09:33:54
Commandline: apt autoremove
Remove: libboost-locale1.55.0:amd64 (1.55.0+dfsg-4), libfreerdp-codec1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), libboost-atomic1.58.0:amd64 (1.58.0+dfsg-5.1), libisccfg-export90:amd64 (1:9.9.5.dfsg-12.1), plasma-containments-addons:amd64 (4:4.14.3-siduction1), liblightdm-qt-3-0:amd64 (1.18.3-1), libgcj17:amd64 (6.3.0-5), libdns-export100:amd64 (1:9.9.5.dfsg-12.1), libefivar0:amd64 (0.23-2), python-pypdf2:amd64 (1.26.0-2), libteamdctl0:amd64 (1.26-1), libwinpr-environment0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), libavformat55:amd64 (6:10.4-1), libavformat56:amd64 (6:11.4-2), libavdevice-ffmpeg56:amd64 (7:2.8.6-1+b2), libfollowupreminder4:amd64 (4:4.14.10-2), python-ufw:amd64 (0.35-4), libqt4-xmlpatterns:i386 (4:4.8.7+dfsg-11), libboost-program-options1.58.0:amd64 (1.58.0+dfsg-5.1), libsctp1:amd64 (1.0.17+dfsg-1), libboost-locale1.58.0:amd64 (1.58.0+dfsg-5.1), linux-headers-4.8.0-1-amd64:amd64 (4.8.7-1), libapt-pkg4.16:amd64 (1.0.10.2), libboost-filesystem1.55.0:amd64 (1.55.0+dfsg-4), libosinfo-db:amd64 (0.3.1-5), libopencolorio1v5:amd64 (1.0.9~dfsg0-6), libapt-inst1.7:amd64 (1.0.10.2), libpcre3-dev:amd64 (2:8.39-2), python3-olefile:amd64 (0.44-1), libavutil-ffmpeg54:amd64 (7:2.8.6-1+b2), libwinpr-library0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), libxcb-xfixes0:i386 (1.12-1), libctemplate3:amd64 (2.3-3), liblensfun1:amd64 (0.3.2-3), libxml++2.6-2v5:amd64 (2.40.1-1), libspeechd2:amd64 (0.8.6-2), libkf5modemmanagerqt6:amd64 (5.28.0-1), libwinpr-rpc0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), libavahi-client-dev:amd64 (0.6.32-2), libkf5pty-dev:amd64 (5.28.0-1), libsuitesparseconfig4.4.5:amd64 (1:4.4.5-2), libsuitesparseconfig4.4.6:amd64 (1:4.4.6-1), libilmbase6v5:amd64 (1.0.1-6.2), libqtwebkit4:i386 (2.3.4.dfsg-9.1), libvncclient1:amd64 (0.9.11+dfsg-1), libwinpr-synch0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), chromium-inspector:amd64 (42.0.2311.90-1), liblog4cplus-1.1-9:amd64 (1.1.2-3.2), linux-headers-4.9.4-towo.1-siduction-amd64:amd64 (4.9-8), g++-4.9:amd64 (4.9.4-2), libavahi-common-dev:amd64 (0.6.32-2), liblcms2-2:i386 (2.8-4), libfreerdp-locale1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), libboost-filesystem1.58.0:amd64 (1.58.0+dfsg-5.1), libmsn0.3v5:amd64 (4.2.1+dfsg-1.1), libgrantlee-gui0:amd64 (0.4.0-4), libkf5idletime-dev:amd64 (5.28.0-1), libpgm-5.1-0:amd64 (5.1.118-1~dfsg-2), libfreerdp-gdi1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), libbaloocore4:amd64 (4:4.14.3-siduction1), libavfilter-ffmpeg5:amd64 (7:2.8.6-1+b2), libopenjpeg5:i386 (1:1.5.2-3.1), linux-headers-4.8.0-2-amd64:amd64 (4.8.15-2), libxcb-present0:i386 (1.12-1), libstoken1:amd64 (0.91-1), liblouis9:amd64 (2.6.4-2+b1), libtommath0:amd64 (0.42.0-1.2), libtommath1:amd64 (1.0-4), libboost-thread1.55.0:amd64 (1.55.0+dfsg-4), libzmq3:amd64 (4.0.5+dfsg-3+b1), linux-image-4.9.1-towo.1-siduction-amd64:amd64 (4.9-4), libfreerdp-crypto1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), libboost-serialization1.55.0:amd64 (1.55.0+dfsg-4), libglapi-mesa:i386 (13.0.4-1), linux-image-4.9.6-towo.1-siduction-amd64:amd64 (4.9-11), libpsl0:amd64 (0.11.0-2+b1), libpixman-1-0:i386 (0.34.0-1), libkf5crash-dev:amd64 (5.28.0-1), libwinpr-handle0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), libumfpack5.6.2:amd64 (1:4.2.1-3), libqpdf13v5:amd64 (5.2.0-2), libsqlite3-0:i386 (3.16.2-2), liborc-0.4-0:i386 (1:0.4.26-2), libxrender1:i386 (1:0.9.10-1), libbz2-1.0:i386 (1.0.6-8.1), libicu55:amd64 (55.1-7), libcamd2.3.1:amd64 (1:4.2.1-3), libkfilemetadata4:amd64 (4:4.14.3-1), libogg0:i386 (1.3.2-1), libasprintf0v5:amd64 (0.19.8.1-2), libboost-system1.55.0:amd64 (1.55.0+dfsg-4), libccolamd2.8.0:amd64 (1:4.2.1-3), liblouis10:amd64 (2.6.5-1), libboost-date-time1.58.0:amd64 (1.58.0+dfsg-5.1), libsane-bin:amd64 (1.0.25-2+b1), libwinpr-registry0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), libswresample-ffmpeg1:amd64 (7:2.8.6-1+b2), libqmi-glib1:amd64 (1.12.6-1), libboost-thread1.58.0:amd64 (1.58.0+dfsg-5.1), libqt5webkit5-dev:amd64 (5.7.1+dfsg-1), libboost-serialization1.58.0:amd64 (1.58.0+dfsg-5.1), perl-modules-5.22:amd64 (5.22.2-5), grub-
theme-siduction-december:amd64 (2014.07.26), libpython2.7:i386 (2.7.13-2), libopenconnect5:amd64 (7.08-1), libmp3lame0:i386 (3.99.5+repack1-9+b1), libkalarmcal2:amd64 (4:4.14.10-7), libacme-damn-perl:amd64 (0.08-1), linux-headers-4.9.3-towo.1-siduction-amd64:amd64 (4.9-7), libnuma1:i386 (2.0.11-2.1), libwinpr-interlocked0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), libpython3.4:amd64 (3.4.4-3), libwinpr-crt0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), libqtcurve-utils1:amd64 (1.8.18+git20140721-siduction1.7), libboost-system1.58.0:amd64 (1.58.0+dfsg-5.1), python3.4:amd64 (3.4.4-3), blender-data:amd64 (2.78.a+dfsg0-4), libqtcore4:i386 (4:4.8.7+dfsg-11), libsys-sigaction-perl:amd64 (0.23-1), linux-image-4.9.2-towo.2-siduction-amd64:amd64 (4.9-6), libkgeomap-data:amd64 (4:15.04.3-siduction1.0.1), libopenvdb3.1:amd64 (3.1.0-4+b1), libopenvdb3.2:amd64 (3.2.0-2.1), libwinpr-sysinfo0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), libxcb-shm0:i386 (1.12-1), libnm0:amd64 (1.6.0-1), libkf5wallet-dev:amd64 (5.28.0-3), libpcre32-3:amd64 (2:8.39-2), python3.4-minimal:amd64 (3.4.4-3), libxcb-randr0:i386 (1.12-1), libxcb-render0:i386 (1.12-1), linux-image-4.9.5-towo.1-siduction-amd64:amd64 (4.9-9), libkf5unitconversion-dev:amd64 (5.28.0-1), konsole4-kpart:amd64 (4:4.14.3-0siduction1.2), kinit-dev:amd64 (5.28.0-1), libkf5solid-bin:amd64 (5.28.0-2), libkf5plotting5:amd64 (5.28.0-1), libkscreen1:amd64 (1.0.5-1), libncursesw5:i386 (6.0+20161126-1), libkf5kjs-dev:amd64 (5.28.0-1), kdoctools-dev:amd64 (5.28.0-1), libprocps4:amd64 (2:3.3.10-4+b1), libprocps5:amd64 (2:3.3.11-3), libwildmidi1:amd64 (0.3.8-2), libieee1284-3-dev:amd64 (0.2.11-13), libopus0:i386 (1.2~alpha2-1), libelfg0:amd64 (0.8.13-5), libgexiv2-2:amd64 (0.10.4-1), libisl13:amd64 (0.14-2), gstreamer1.0-clutter:amd64 (2.0.18-1), libexpat1:i386 (2.2.0-2), libkf5kipi-bin:amd64 (4:16.08.2-1), libudev1:i386 (232-15), libboost-iostreams1.61.0:amd64 (1.61.0+dfsg-3+b1), libvpx1:i386 (1.3.0-3), libvpx2:amd64 (1.4.0-4), libvpx2:i386 (1.4.0-4), libvpx3:amd64 (1.5.0-4), libwinpr-file0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), libkdgantt2-0:amd64 (4:4.14.10-7), libokularcore5:amd64 (4:4.14.3-siduction1), libokularcore6:amd64 (4:15.08.3-1), libcolamd2.8.0:amd64 (1:4.2.1-3), libturbojpeg1:amd64 (1:1.3.1-12), libboost-chrono1.61.0:amd64 (1.61.0+dfsg-3+b1), libfreerdp-common1.1.0:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), libgnutls-deb0-28:i386 (3.3.20-1), libxshmfence1:i386 (1.2-1), libkf5threadweaver-dev:amd64 (5.28.0-1), libbabl-dev:amd64 (0.1.18-1), libwinpr-sspi0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), libkf5khtml-dev:amd64 (5.28.0-1), libcolamd2.9.1:amd64 (1:4.4.6-1), libllvm3.7:amd64 (1:3.7.1-3), libllvm3.8:amd64 (1:3.8.1-17), libqtgui4:i386 (4:4.8.7+dfsg-11), libsm6:i386 (2:1.2.2-1+b1), libkmanagesieve4:amd64 (4:4.14.10-2), libvirglrenderer0:amd64 (0.5.0-2), linux-headers-4.9.5-towo.2-siduction-amd64:amd64 (4.9-10), libical1a:amd64 (1.0.1-0.1), libpython3.4-stdlib:amd64 (3.4.4-3), libjim0.75:amd64 (0.75-1), libndp0:amd64 (1.6-1), libperl5.22:amd64 (5.22.2-5), libwebkitgtk-1.0-0:amd64 (2.4.11-3), libopenraw1:amd64 (0.0.9-3.5+b2), libkgapi2-2:amd64 (2.2.0-2), libboost-regex1.61.0:amd64 (1.61.0+dfsg-3+b1), liblegacytaskmanager5:amd64 (4:5.7.4-1), libkf5activitiesexperimentalstats1:amd64 (4:5.6.5-1), libtiff5:i386 (4.0.7-5), libmimic0:amd64 (1.0.4-2.3), libkf5webkit-dev:amd64 (5.28.0-1), libstdc++-5-dev:amd64 (5.4.1-4), libva1:i386 (1.7.3-2), python-olefile:amd64 (0.44-1), linux-image-4.9.4-towo.1-siduction-amd64:amd64 (4.9-8), libx264-142:i386 (2:0.142.2431+gita5831aa-1+b2), libx264-146:amd64 (2:0.146.2555+git0c21480-1), libx264-146:i386 (2:0.146.2555+git0c21480-1), libcholmod2.1.2:amd64 (1:4.2.1-3), libpulse0:i386 (10.0-1), libx265-43:i386 (1.5-1), libx265-43:amd64 (1.5-1), libx265-51:i386 (1.6-1), libx265-51:amd64 (1.6-1), libx265-59:amd64 (1.7-4), libx265-59:i386 (1.7-4), libx265-68:amd64 (1.8-6), libstdc++-4.9-dev:amd64 (4.9.4-2), libx265-79:amd64 (1.9-3), libx265-87:amd64 (2.0-4), libpostproc-ffmpeg53:amd64 (7:2.8.6-1+b2), g++-5:amd64 (5.4.1-4), libxvidcore4:
i386 (2:1.3.4-1), libkwinglutils6:amd64 (4:5.4.3-1.1), libkwinglutils8:amd64 (4:5.7.4-1), libxtst6:i386 (2:1.2.3-1), kross-dev:amd64 (5.28.0-1), libblosc1:amd64 (1.11.1+ds2-1), libxi6:i386 (2:1.7.9-1), libastro1:amd64 (4:16.08.3-1), libxt6:i386 (1:1.1.5-1), liblouisutdml6:amd64 (2.5.0-3+b1), libxv1:i386 (2:1.0.11-1), libamd2.3.1:amd64 (1:4.2.1-3), libvorbisenc2:i386 (1.3.5-4), libcap2:i386 (1:2.25-1), kio-mtp:amd64 (0.75+git20140304-2), libfreerdp-core1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), libboost-atomic1.61.0:amd64 (1.61.0+dfsg-3+b1), linux-headers-4.8.14-towo.1-siduction-amd64:amd64 (4.8-24), libspeex1:i386 (1.2~rc1.2-1), libwinpr-utils0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), kgendesignerplugin:amd64 (5.28.0-1), libqtgstreamerui-1.0-0:amd64 (1.2.0-4), libqtgstreamer-1.0-0:amd64 (1.2.0-4), libqca-qt5-2:amd64 (2.1.1-4), libkontactinterface4a:amd64 (4:4.14.10-7), libsoundtouch0:amd64 (1.9.1-1), libclutter-gst-2.0-0:amd64 (2.0.18-1), liblensfun-data-v1:amd64 (0.3.2-3), libjack-jackd2-0:i386 (1.9.10+20150825git1ed50c92~dfsg-4+b1), libavcodec55:amd64 (6:10.4-1), libavcodec56:amd64 (6:11.4-2), libavcodec56:i386 (6:11.4-2), libglib2.0-bin:amd64 (2.50.2-2), libqtdbus4:i386 (4:4.8.7+dfsg-11), libwinpr-dsparse0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), libboost-locale1.61.0:amd64 (1.61.0+dfsg-3+b1), libkwinglesutils1:amd64 (4:4.11.22-3), libjs-jquery-ui:amd64 (1.12.1+dfsg-3), libgstreamer-plugins-base1.0-0:i386 (1.10.3-1), libavutil54:amd64 (6:11.4-2), libavutil54:i386 (6:11.4-2), libtheora0:i386 (1.1.1+dfsg.1-14), libsndfile1:i386 (1.0.27-1), libkf5prison1:amd64 (1.2~git20150223-0r1), libdrm2:i386 (2.4.74-1), libqtgstreamerutils-1.0-0:amd64 (1.2.0-4), libxcb-shape0:i386 (1.12-1), libwinpr-input0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), linux-image-4.9.5-towo.2-siduction-amd64:amd64 (4.9-10), libglib2.0-dev:amd64 (2.50.2-2), linux-headers-4.9.2-towo.1-siduction-amd64:amd64 (4.9-5), linux-kbuild-4.8:amd64 (4.8.15-2), libakonadi-notes4:amd64 (4:4.14.10-7), libavdevice55:amd64 (6:11.4-2), libinput5:amd64 (0.6.0+dfsg-2), libkf5notifyconfig-dev:amd64 (5.28.0-1), linux-headers-4.8.0-1-common:amd64 (4.8.7-1), libefiboot27:amd64 (27-1), libkf5style-dev:amd64 (5.28.0-1), libkf5plotting-dev:amd64 (5.28.0-1), linux-image-4.9.3-towo.1-siduction-amd64:amd64 (4.9-7), libxfixes3:i386 (1:5.0.3-1), libfreerdp-utils1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), libwinpr-heap0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), libfontconfig1:i386 (2.11.0-6.7), libtinyxml2.6.2v5:amd64 (2.6.2-4), libasyncns0:i386 (0.8-6), libswscale3:amd64 (6:11.4-2), libwebrtc-audio-processing-0:amd64 (0.1-3), libv4l2rds0:amd64 (1.12.2-2), libreadline7:i386 (7.0-2), libboost-filesystem1.61.0:amd64 (1.61.0+dfsg-3+b1), libspeexdsp1:i386 (1.2~rc1.2-1), libxen-4.6:amd64 (4.6.0-1+nmu2), libdb5.3:i386 (5.3.28-12+b1), libsodium13:amd64 (1.0.3-1), libv4l-dev:amd64 (1.12.2-2), python-trml2pdf:amd64 (1.2-3), libmagickcore-6.q16-2:amd64 (8:6.9.6.6+dfsg-1), libswscale-ffmpeg3:amd64 (7:2.8.6-1+b2), libasound2:i386 (1.1.3-4), libssl1.0-dev:amd64 (1.0.2k-1), libfreerdp-cache1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), lua-lpeg:amd64 (1.0.0-1), libwinpr-path0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), libxxf86vm1:i386 (1:1.1.4-1), libavresample-ffmpeg2:amd64 (7:2.8.6-1+b2), libxdamage1:i386 (1:1.1.4-2+b1), libkf5dnssd-dev:amd64 (5.28.0-1), pdftk:amd64 (2.02-4+b1), libglew1.13:amd64 (1.13.0-2), libgl1-mesa-glx:i386 (13.0.4-1), libjbig0:i386 (2.1-3.1), libmusicbrainz5-1:amd64 (5.1.0-3), libavcodec-ffmpeg56:amd64 (7:2.8.6-1+b2), libkwinxrenderutils6:amd64 (4:5.4.3-1.1), libkwinxrenderutils8:amd64 (4:5.7.4-1), libopenexr6v5:amd64 (1.6.1-8.1+b2), libcomposereditorng4:amd64 (4:4.14.10-2), libflac8:i386 (1.3.2-1), libfreerdp-rail1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), lightspark-common:amd64 (0.7.2+git20150512-2.1+b4), libpython2.7-minimal:i386 (2.7.13-2), libbalooqueryparser4:amd64 (4:4.14.3-siduction1), libboost-iostreams1.55.0:amd64 (1.55.0+dfsg-4), libfreetype6:i386 (2.6.3-3+b1), libkf5newstuff-dev:amd64 (5.28.0-1), libboost-date-
time1.61.0:amd64 (1.61.0+dfsg-3+b1), libgsm1:i386 (1.0.13-4), libopenimageio1.6:amd64 (1.6.17~dfsg0-1+b2), libboost-chrono1.55.0:amd64 (1.55.0+dfsg-4), libkf5su-dev:amd64 (5.28.0-2), kdesignerplugin-data:amd64 (5.28.0-1), liblivemedia50:amd64 (2016.02.09-1), liblivemedia52:amd64 (2016.08.27-1), linux-headers-4.9.1-towo.1-siduction-amd64:amd64 (4.9-4), libzstd1:amd64 (1.1.2-1), linux-headers-4.9.6-towo.1-siduction-amd64:amd64 (4.9-11), libqt4-xml:i386 (4:4.8.7+dfsg-11), libboost-thread1.61.0:amd64 (1.61.0+dfsg-3+b1), libavformat-ffmpeg56:amd64 (7:2.8.6-1+b2), libboost-serialization1.61.0:amd64 (1.61.0+dfsg-3+b1), linux-image-4.9.2-towo.1-siduction-amd64:amd64 (4.9-5), libvorbis0a:i386 (1.3.5-4), liborcus-0.10-0v5:amd64 (0.9.2-4), libssl1.1:i386 (1.1.0d-2), libwinpr-thread0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), libboost-iostreams1.58.0:amd64 (1.58.0+dfsg-5.1), libisc-export95:amd64 (1:9.9.5.dfsg-12.1), libqt4-dbus:i386 (4:4.8.7+dfsg-11), linux-headers-4.8.0-2-common:amd64 (4.8.15-2), libboost-regex1.55.0:amd64 (1.55.0+dfsg-4), libboost-system1.61.0:amd64 (1.61.0+dfsg-3+b1), libpcrecpp0v5:amd64 (2:8.39-2), libgrantlee-core0:amd64 (0.4.0-4), libjson-c2:i386 (0.11-4), libjson-c3:amd64 (0.12.1-1.1), libjson-c3:i386 (0.12.1-1.1), libboost-chrono1.58.0:amd64 (1.58.0+dfsg-5.1), libtomcrypt0:amd64 (1.17-9), libval14:amd64 (2.0-4), libice6:i386 (2:1.0.9-1+b1), libcairo2:i386 (1.14.8-1), libyaml-cpp0.3v5:amd64 (0.3.0-1.2), libsendlater4:amd64 (4:4.14.10-7), libpython2.7-stdlib:i386 (2.7.13-2), libgcj-common:amd64 (1:6.3-1), libkf5gpgmepp5:amd64 (16.04.3-2), linux-compiler-gcc-5-x86:amd64 (4.8.15-2), libpoppler46:amd64 (0.26.5-4), libpoppler57:amd64 (0.38.0-3), python-wicd:amd64 (1.7.4+tb2-3), libpoppler61:amd64 (0.44.0-3), libkf5jsapi5:amd64 (5.28.0-1), libstdc++6:i386 (6.3.0-5), libxcb-glx0:i386 (1.12-1), libxss1:i386 (1:1.2.2-1), libspnav0:amd64 (0.2.3-1), librlog5v5:amd64 (1.4-4), libxcb-dri2-0:i386 (1.12-1), libfreerdp-client1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), libxcb-xtest0:amd64 (1.12-1), libllvm3.5v5:amd64 (1:3.5.2-5), libkf5doctools-dev:amd64 (5.28.0-1), libxapian22v5:amd64 (1.2.23-1), libgit2-22:amd64 (0.22.2-2), libgit2-23:amd64 (0.23.1-1.1), libgstreamer1.0-0:i386 (1.10.3-1), libkmbox4:amd64 (4:4.14.10-7), libboost-regex1.58.0:amd64 (1.58.0+dfsg-5.1), libsamplerate0:i386 (0.1.8-8), libxcb-dri3-0:i386 (1.12-1), libpng12-0:i386 (1.2.54-6), libglib2.0-0:i386 (2.50.2-2), linux-headers-4.9.2-towo.2-siduction-amd64:amd64 (4.9-6), libpython3.4-minimal:amd64 (3.4.4-3), libjpeg62-turbo:i386 (1:1.5.1-2), libwinpr-pool0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), linux-image-4.8.14-towo.1-siduction-amd64:amd64 (4.8-24), libqt4-opengl:i386 (4:4.8.7+dfsg-11), libaudio2:i386 (1.9.4-5), libavresample2:amd64 (6:11.4-2), libavresample2:i386 (6:11.4-2), libkwineffects6:amd64 (4:5.4.3-1.1), libkwineffects8:amd64 (4:5.7.4-1), libwinpr-crypto0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), libmng1:i386 (1.0.10+dfsg-3.1+b3), libx11-xcb1:i386 (2:1.6.4-3), libjavascriptcoregtk-1.0-0:amd64 (2.4.11-3), libadns1:amd64 (1.5.0~rc1-1), libxcb-sync1:i386 (1.12-1), nodejs-legacy:amd64 (4.7.2~dfsg-1), libefivar27:amd64 (27-1), libschroedinger-1.0-0:i386 (1.0.11-2.1), linux-headers-4.9.5-towo.1-siduction-amd64:amd64 (4.9-9), libssl1.0.0:i386 (1.0.2d-1), libtrio2:amd64 (1.16+dfsg1-3), libirs-export91:amd64 (1:9.9.5.dfsg-12.1), libfreerdp-primitives1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-13), libboost-program-options1.55.0:amd64 (1.55.0+dfsg-4), libpng16-16:i386 (1.6.28-1), libqt4-network:i386 (4:4.8.7+dfsg-11)
End-Date: 2017-02-02  09:37:44




As far as I can see after a couple hours of my normal operations, nothing on the desktop or in the system was adversely affected by this huge dump of cruft.  I usually keep more than two kernels but it's no problem this time.  There was a message that two of the old linux headers directories were not empty so they were not removed -- I will hunt them down manually.


Before I did this to my desktop rig, I did the same thing on my laptop which is an HP/Intel platform, and there were no issues on that one either.


So, bearing in mind this is not recommended by anyone, I found it a useful experiment.
Asus Z87-WS, Core i7-4770, Nvidia GTX-750 Ti, OCZ Vertex Plus, 2@WD1000DHTZ in BTRFS

Offline Lanzi

  • User
  • Posts: 1.510
    • Preiswerter Urlaub (Zimmer und Ferienwohnungen) im Harz?
Re: Somewhat risky experiment: apt autoremove
« Reply #1 on: 2017/02/02, 23:25:15 »
i didn't knew that it is not recomended on sid-Systems. So I used autoremove from time to time. Maybe 3-4 times a year. I cannot say it for sure, but I think I never got problmes that came after autoremove.
but you can never be sure afterwards.

I will be more carefull in the future.

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.559
    • http://landofthebuckeye.net/
Re: Somewhat risky experiment: apt autoremove
« Reply #2 on: 2017/02/02, 23:47:58 »
autoremove had never been run on any of my three sid systems.  If you look at my output, I did lose some old desktop themes and other user configuration items, but nothing important.  None of my customization items, including desktop and panel configuration, and conky and such, were affected at all.
Asus Z87-WS, Core i7-4770, Nvidia GTX-750 Ti, OCZ Vertex Plus, 2@WD1000DHTZ in BTRFS

Offline tmhind2

  • User
  • Posts: 60
Re: Somewhat risky experiment: apt autoremove
« Reply #3 on: 2017/02/03, 09:45:45 »
I've also run autoremove on my siduction systems and cannot say I have experienced any problems either.  :)

Regards,
Tom

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 3.889
Re: Somewhat risky experiment: apt autoremove
« Reply #4 on: 2017/02/03, 10:38:25 »
One rule to go by  with autoremove is the same as with apt: never hit enter without reading the output!

Offline tmhind2

  • User
  • Posts: 60
Re: Somewhat risky experiment: apt autoremove
« Reply #5 on: 2017/02/03, 11:03:12 »
Yes, been there done that and got the Tee-shirt. Thanks Devil for reminding me, but I took it for granted that others would read what is being done as you say before hitting enter!

Tom

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 3.889
Re: Somewhat risky experiment: apt autoremove
« Reply #6 on: 2017/02/03, 11:37:36 »
Even though it would make total sense to read what your computer tells you in critical situations, our experience in IRC tells us, that common sense does not always apply here. We even have candidates that repeatadly hit enter removing hundreds of packages to a point where it has become almost a running joke to place bets, when soandso will turn up with a broken system on such days.


So no, you cannot expect sane behaviour.  :o

detipco

  • Guest
Re: Somewhat risky experiment: apt autoremove
« Reply #7 on: 2017/02/03, 14:15:43 »
Hi,
I prefer "debfoster". ;)

cheers
« Last Edit: 2017/02/03, 14:27:46 by detipco »

Offline musca

  • Global Moderator
  • User
  • *****
  • Posts: 687
  • sid, fly high!
Re: Somewhat risky experiment: apt autoremove
« Reply #8 on: 2017/02/03, 21:57:49 »
Hello dibl,
I'm a friend of apt-get autoremove, but I use it often to keep the list of removable packages really short.

Any breakage caused by autoremove is worth a bug report.

greetings
musca
„Es irrt der Mensch, solang er strebt.“  (Goethe, Faust)