Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [Solved] failed to get i915 symbols, graphics turbo disabled  (Read 13429 times)

Offline delta9

  • User
  • Posts: 20
Hello,

during system boot i get this message:

Code: [Select]
failed to get i915 symbols, graphics turbo disabled

System boots fine though and graphics card works (i guess).

Some useful info:
Code: [Select]
$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 12)
01:00.0 VGA compatible controller: ATI Technologies Inc Madison [Mobility Radeon HD 5000 Series]


The other thing id like to ask is since i have two graphics cards and im only using the integrated (intel) one in siduction, if its possible to shutdown the ATI (for power saving reasons)

Thanks a lot in advance
d9

Offline GoinEasy9

  • User
  • Posts: 487
RE: failed to get i915 symbols, graphics turbo disabled
« Reply #1 on: 2012/02/04, 22:29:06 »
I have a laptop with dual Nvidia cards, and I'm also looking for switching solutions.  I've looked at Bumblebee, but still haven't had time to experiment with it.  Here are some links you may be interested in:

http://linux-hybrid-graphics.blogspot.com/
https://wiki.debian.org/Bumblebee

I'm still using Fedora on that laptop, so, it'll be a while yet till I get to do some experimenting.
Linux Counter number 348347

Offline Ajen

  • User
  • Posts: 6
[Solved] failed to get i915 symbols, graphics turbo disabled
« Reply #2 on: 2012/02/08, 17:21:32 »
I do not have hybrid-graphics but I can point you to a solution concerning your error message: This occurs if you do not load the i915 module during bootstrap as outlined here: https://wiki.archlinux.org/index.php/Intel#KMS_.28Kernel_Mode_Setting.29

I had this issue too, I put i915 into /etc/initramfs-tools/modules and then did update-initramfs and the problem was gone, as it loads the module during bootstrap then.

Hope this helps

Ajen

Offline delta9

  • User
  • Posts: 20
[Solved] failed to get i915 symbols, graphics turbo disabled
« Reply #3 on: 2012/02/09, 16:06:53 »
Thanks for your reply Ajen. Followed your advice and problem with i915 module solved.

Now, for the switchable graphics cards i found this http://www.thinkwiki.org/wiki/Auto_detect_drivers_for_switchable_graphics
which should work on my system.
The workaround that is described on the above link relies on switching cards through BIOS. Sad thing is that my BIOS has the options Switchable/Discrete (which would be intel-ATI/ATI). So i guess the best thing i can do for now is to choose Discrete on my BIOS and use only the ATI card.

Cheers,
d9