Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] nepomukindexer hogging resources  (Read 4328 times)

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.364
    • Land of the Buckeye
[EN] nepomukindexer hogging resources
« on: 2012/01/29, 16:53:23 »
In the past few days I have noticed nepomukindexer running up to 13% of CPU resources.  On my i7-950 this is a lot -- I would hate to see what happens on my netbook.  My system is fully updated and has been up for over 2 days (this one was "cross-graded" from aptosid), so I think everything was indexed long ago!

Code: [Select]
Host/Kernel/OS  "imerabox" running Linux 3.2-2.towo.1-siduction-amd64 x86_64 [ aptosid 2011-02 Ἡμέρα - kde-lite - (201107131633) ]
CPU Info        8x Intel Core i7 950 @ 8192 KB cache flags( sse3 ht nx lm vmx ) clocked at [ 2000.000 MHz ]
Videocard       nVidia GF100 [GeForce GTX 480]  X.Org 1.11.3.901  [ 1920x1200@50.0hz ]
Network cards   Marvell 88E8056 PCI-E Gigabit Ethernet Controller, at port: d800
Processes 296 | Uptime 2days | Memory 1493.7/5966.5MB | HDD OCZ-REVODRIVE,OCZ-REVODRIVE,KINGSTON SS100S2,WDC WD1002FAEX-0,WDC WD1002FAEX-0 Size 2136GB (2%used) | GLX Renderer GeForce GTX 480/PCI/SSE2 | GLX Version 4.2.0 NVIDIA 290.10 | Client Shell | Infobash v3.37


KDE 4.7.2

Does anyone else see this?
System76 Oryx Pro, Intel Core i7-11800H, SSD 970 EVO Plus;  Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO

Offline cryptosteve

  • User
  • Posts: 675
nepomukindexer hogging resources
« Reply #1 on: 2012/01/30, 19:51:56 »
First solution for this is to exclude mp3-files from indexing.

http://www.google.de/search?q=nepomukindexer+mp3
- born to create drama -
CS Virtual Travel Bug: VF6G5D

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.364
    • Land of the Buckeye
RE: nepomukindexer hogging resources
« Reply #2 on: 2012/01/31, 00:18:14 »
That makes sense -- 12.5% would be one of the 8 threads in my i7-950.  And this system is where I have my music files -- many, many mp3 files among them.  I simply disabled nepomuk and virtuoso, as I have no issue with finding things on this one.

Thank you!
System76 Oryx Pro, Intel Core i7-11800H, SSD 970 EVO Plus;  Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO

Offline DeepDayze

  • User
  • Posts: 458
Re: nepomukindexer hogging resources
« Reply #3 on: 2012/01/31, 01:43:53 »
Quote from: "cryptosteve"
First solution for this is to exclude mp3-files from indexing.

http://www.google.de/search?q=nepomukindexer+mp3


Also index just the files in your home directory nothing else. Stuff that's relatively static shouldn't need reindexing unless they get moved or deleted

mylo

  • Guest
Re: nepomukindexer hogging resources
« Reply #4 on: 2012/01/31, 10:32:56 »
Quote from: "dibl"
...Does anyone else see this?


Yes, I observed that too. I will check the hints.

mylo

  • Guest
Re: nepomukindexer hogging resources
« Reply #5 on: 2012/01/31, 10:37:46 »
for me it is not mp3, as they are on a seperate partition. I excluded the photos "*.jpg", selected "weekly" and gave now just 200 MB instead of 500.

luckyb

  • Guest
RE: Re: nepomukindexer hogging resources
« Reply #6 on: 2012/01/31, 22:12:41 »
same here,

I disabled the file indexing completely
My cpu was drained and thought it's preferable to have a well running system than be able to search through files metadata

mylo

  • Guest
RE: Re: nepomukindexer hogging resources
« Reply #7 on: 2012/02/03, 23:22:52 »
Hi luckyb,

yes, why not disabling,if you don't need it respectively benefit from it. Otherwise I am happy that it works now (was announced more than a couple of months).

Offline ralul

  • User
  • Posts: 1.814
RE: Re: nepomukindexer hogging resources
« Reply #8 on: 2012/02/04, 14:34:28 »
Recoll seems to be the better search-indexing tool! What about tracker, which is used also by gnome?
experiencing siduction runs better than my gentoo makes me know I know nothing