Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] [solved] kdenlive install failed  (Read 6037 times)

Offline orinoco

  • User
  • Posts: 248
  • Bullshit artist
[EN] [solved] kdenlive install failed
« on: 2012/03/22, 16:13:24 »
I've tried to install kdenlive without success. Any ideas whay?

Code: [Select]
root@jake:~# apt-get install kdenlive
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kdenlive : Depends: libmlt4 but it is not going to be installed
E: Broken packages
root@jake:~# dpkg-query -s libmlt4
Package: libmlt4
Status: install ok installed
Priority: optional
Section: libs
Installed-Size: 1512
Maintainer: Fathi Boudra <fabo>
Architecture: amd64
Source: mlt
Version: 0.7.8-2
Replaces: libmlt0.2, libmlt0.2.5, libmlt1, libmlt2, libmlt3
Depends: libasound2 (>= 1.0.16), libavcodec53 (>= 4:0.8-1~) | libavcodec-extra-53 (>= 4:0.8-1~), libavdevice53 (>= 4:0.8-1~) | libavdevice-extra-53 (>= 4:0.8-1~), libavformat53 (>= 4:0.8-1~) | libavformat-extra-53 (>= 4:0.8-1~), libavutil51 (>= 4:0.8-1~) | libavutil-extra-51 (>= 4:0.8-1~), libc6 (>= 2.11), libdv4, libgcc1 (>= 1:4.1.1), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.24.0), libgtk2.0-0 (>= 2.24.0), libjack-jackd2-0 (>= 1.9.5~dfsg-14) | libjack-0.116, libpango1.0-0 (>= 1.14.0), libqt4-svg (>= 4:4.5.3), libqt4-xml (>= 4:4.5.3), libqtcore4 (>= 4:4.7.0~beta1), libqtgui4 (>= 4:4.6.2), libquicktime2 (>= 2:1.2.2), libsamplerate0 (>= 0.1.7), libsdl1.2debian (>= 1.2.11), libsox1b (>= 14.3.1), libstdc++6 (>= 4.4.0), libswscale2 (>= 4:0.8-1~) | libswscale-extra-2 (>= 4:0.8-1~), libvorbisfile3 (>= 1.1.2), libx11-6, libxml2 (>= 2.7.4)
Recommends: libmlt-data (>= 0.7.8-2)
Conflicts: libmlt0.2, libmlt0.2.5, libmlt1, libmlt2, libmlt3
Description: multimedia framework (runtime)
 MLT is an open source multimedia framework, designed and developed for
 television broadcasting. It provides a toolkit for broadcasters, video
 editors, media players, transcoders, web streamers and many more types of
 applications. The functionality of the system is provided via an assortment
 of ready to use tools, xml authoring components, and an extendible plug-in
 based API.
 .
 This package contains the files necessary for running applications that
 use the MLT multimedia framework.
Homepage: http://www.mltframework.org
root@jake:~#


The second try was to install kdenlive-data first:

Code: [Select]
root@jake:~# apt-get install kdenlive-data
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libcdio-paranoia0 libquicktime2 libavdevice53 libcdio-cdda0 libsox1b libmlt-data
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  swh-plugins
Recommended packages:
  kdenlive
The following packages will be REMOVED:
  libmlt4
The following NEW packages will be installed:
  kdenlive-data swh-plugins
0 upgraded, 2 newly installed, 1 to remove and 1 not upgraded.
Need to get 4,810 kB of archives.
After this operation, 13.4 MB of additional disk space will be used.
Do you want to continue [Y/n]?
Get:1 http://ftp.de.debian.org/debian/ unstable/main kdenlive-data all 0.8.2.1-2 [4,156 kB]
Get:2 http://ftp.de.debian.org/debian/ unstable/main swh-plugins amd64 0.4.15+1-6 [654 kB]
Fetched 4,810 kB in 1s (3,435 kB/s)  
Retrieving bug reports... Done
Parsing Found/Fixed information... Done
(Reading database ... 209538 files and directories currently installed.)
Removing libmlt4 ...
Selecting previously unselected package kdenlive-data.
(Reading database ... 209505 files and directories currently installed.)
Unpacking kdenlive-data (from .../kdenlive-data_0.8.2.1-2_all.deb) ...
Selecting previously unselected package swh-plugins.
Unpacking swh-plugins (from .../swh-plugins_0.4.15+1-6_amd64.deb) ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for shared-mime-info ...
update-mime-database.real: error while loading shared libraries: libpcre.so.3: cannot open shared object file: No such file or directory
dpkg: error processing shared-mime-info (--unpack):
 subprocess installed post-installation script returned error exit status 127
configured to not write apport reports
                                      Processing triggers for doc-base ...
Processing 1 added doc-base file...
Registering documents with scrollkeeper...
Errors were encountered while processing:
 shared-mime-info
E: Sub-process /usr/bin/dpkg returned an error code (1)

Offline DeepDayze

  • User
  • Posts: 458
RE: kdenlive install failed
« Reply #1 on: 2012/03/22, 16:35:36 »
Could be that you got bitten by the pcre3 bug:

See here: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=664983

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.846
RE: kdenlive install failed
« Reply #2 on: 2012/03/22, 18:49:55 »
Dist-Upgrade before installing kdenlive again please.

greetz
devil

Offline orinoco

  • User
  • Posts: 248
  • Bullshit artist
[solved] kdenlive install failed
« Reply #3 on: 2012/03/22, 22:26:29 »
After dist-upgrade no success:

Code: [Select]
root@jake:~# LANG=en_US.UTF-8 apt-get install kdenlive
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kdenlive : Depends: libmlt4 but it is not going to be installed
E: Broken packages

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.846
[solved] kdenlive install failed
« Reply #4 on: 2012/03/22, 22:39:44 »
well, that is adifferent problem, as the error states:
Quote

kdenlive : Depends: libmlt4 but it is not going to be installed

try installing libmlt4 first.

greetz
devil

Offline orinoco

  • User
  • Posts: 248
  • Bullshit artist
[solved] kdenlive install failed
« Reply #5 on: 2012/03/22, 22:50:59 »
It's installed:

Code: [Select]
orinoco@jake:~$ dpkg-query -s libmlt4
Package: libmlt4
Status: install ok installed
Priority: optional
Section: libs
Installed-Size: 1512
Maintainer: Fathi Boudra <fabo>
Architecture: amd64
Source: mlt
Version: 0.7.8-2
Replaces: libmlt0.2, libmlt0.2.5, libmlt1, libmlt2, libmlt3
Depends: libasound2 (>= 1.0.16), libavcodec53 (>= 4:0.8-1~) | libavcodec-extra-53 (>= 4:0.8-1~), libavdevice53 (>= 4:0.8-1~) | libavdevice-extra-53 (>= 4:0.8-1~), libavformat53 (>= 4:0.8-1~) | libavformat-extra-53 (>= 4:0.8-1~), libavutil51 (>= 4:0.8-1~) | libavutil-extra-51 (>= 4:0.8-1~), libc6 (>= 2.11), libdv4, libgcc1 (>= 1:4.1.1), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.24.0), libgtk2.0-0 (>= 2.24.0), libjack-jackd2-0 (>= 1.9.5~dfsg-14) | libjack-0.116, libpango1.0-0 (>= 1.14.0), libqt4-svg (>= 4:4.5.3), libqt4-xml (>= 4:4.5.3), libqtcore4 (>= 4:4.7.0~beta1), libqtgui4 (>= 4:4.6.2), libquicktime2 (>= 2:1.2.2), libsamplerate0 (>= 0.1.7), libsdl1.2debian (>= 1.2.11), libsox1b (>= 14.3.1), libstdc++6 (>= 4.4.0), libswscale2 (>= 4:0.8-1~) | libswscale-extra-2 (>= 4:0.8-1~), libvorbisfile3 (>= 1.1.2), libx11-6, libxml2 (>= 2.7.4)
Recommends: libmlt-data (>= 0.7.8-2)
Conflicts: libmlt0.2, libmlt0.2.5, libmlt1, libmlt2, libmlt3
Description: multimedia framework (runtime)
 MLT is an open source multimedia framework, designed and developed for
 television broadcasting. It provides a toolkit for broadcasters, video
 editors, media players, transcoders, web streamers and many more types of
 applications. The functionality of the system is provided via an assortment
 of ready to use tools, xml authoring components, and an extendible plug-in
 based API.
 .
 This package contains the files necessary for running applications that
 use the MLT multimedia framework.
Homepage: http://www.mltframework.org


I can apt-get install kdenlive-data but not kdenlive itself. The error message stays the same.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.846
[solved] kdenlive install failed
« Reply #6 on: 2012/03/22, 23:02:50 »
The error still is
Quote

The following packages have unmet dependencies:
 kdenlive : Depends: libmlt4 but it is not going to be installed
E: Broken packages
?

greetz
devil

Offline orinoco

  • User
  • Posts: 248
  • Bullshit artist
[solved] kdenlive install failed
« Reply #7 on: 2012/03/22, 23:31:26 »
Yes, sir.

Offline Geier0815

  • User
  • Posts: 590
[solved] kdenlive install failed
« Reply #8 on: 2012/03/23, 09:46:32 »
You did a dpkg-query to check the state but what says "apt-cache policy libmlt4"? Next steps I would try: "apt-get install --reinstall libmtp4" and then "apt-get install kdenlive"
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

Offline orinoco

  • User
  • Posts: 248
  • Bullshit artist
[solved] kdenlive install failed
« Reply #9 on: 2012/03/24, 12:16:11 »
Hello Geier0815,

thank you for your support. But I can't see any progress.

Code: [Select]
root@jake:~# LANG=en_US.UTF-8 apt-cache policy libmlt4
libmlt4:
  Installed: 0.7.8-2
  Candidate: 0.7.8-2
  Version table:
 *** 0.7.8-2 0
        500 http://ftp.de.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status
Code: [Select]
root@jake:~# LANG=en_US.UTF-8 apt-get install --reinstall libmtp4
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Code: [Select]
root@jake:~# LANG=en_US.UTF-8 apt-get install kdenlive
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kdenlive : Depends: libmlt4 but it is not going to be installed
E: Broken packages

Offline DeepDayze

  • User
  • Posts: 458
[solved] kdenlive install failed
« Reply #10 on: 2012/03/24, 18:37:48 »
what does it say when you try to install libmlt4 itself?

Offline orinoco

  • User
  • Posts: 248
  • Bullshit artist
[solved] kdenlive install failed
« Reply #11 on: 2012/03/25, 17:24:23 »
voila

Code: [Select]
root@jake:~# LANG=en_US.UTF-8 apt-get -V purge libmlt4
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following packages were automatically installed and are no longer required:
   libcdio-paranoia0 (0.81-5)
   libquicktime2 (1.2.3-4+b3)
   libavdevice53 (0.8.1-1)
   libcdio-cdda0 (0.81-5)
   libsox1b (14.3.2-3)
   libmlt-data (0.6.2-0.0)
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
   libmlt4* (0.7.8-2)
0 upgraded, 0 newly installed, 1 to remove and 1 not upgraded.
After this operation, 1,548 kB disk space will be freed.
Do you want to continue [Y/n]?
(Reading database ... 224457 files and directories currently installed.)
Removing libmlt4 ...


and

Code: [Select]
root@jake:~# LANG=en_US.UTF-8 apt-get -V autoremove
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following packages will be REMOVED:
   libavdevice53 (0.8.1-1)
   libcdio-cdda0 (0.81-5)
   libcdio-paranoia0 (0.81-5)
   libmlt-data (0.6.2-0.0)
   libquicktime2 (1.2.3-4+b3)
   libsox1b (14.3.2-3)
0 upgraded, 0 newly installed, 6 to remove and 1 not upgraded.
After this operation, 3,092 kB disk space will be freed.
Do you want to continue [Y/n]?
(Reading database ... 224422 files and directories currently installed.)
Removing libavdevice53:amd64 ...
Removing libcdio-paranoia0 ...
Removing libcdio-cdda0 ...
Removing libmlt-data ...
Removing libquicktime2 ...
Removing libsox1b ...


finally

Code: [Select]
root@jake:~# LANG=en_US.UTF-8 apt-get -V install kdenlive
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kdenlive : Depends: libmlt4 but it is not going to be installed
E: Broken packages

Offline orinoco

  • User
  • Posts: 248
  • Bullshit artist
[solved] kdenlive install failed
« Reply #12 on: 2012/03/26, 20:27:16 »
I disabled debian-multimedia repository and the installtion was successful. Maybe a stupid question, but it is recomended to add this repository? If not, what is the alternative?

Offline michaaa62

  • User
  • Posts: 299
[solved] kdenlive install failed
« Reply #13 on: 2012/03/26, 20:56:30 »
My experience with debian-multimedia sums up like this:

Just use the repo to install, what ever you need...
BUT always read carefully, what apt-get puts out about removals or dependencies, because those applications are often compiled to work with versions of libs different from those in Debian Sid.
Never dist-upgrade with the repo enabled for the same reasons.