Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] [SOLVED]Can't install packages with synaptic and/or aptitude  (Read 5232 times)

tapp

  • Guest
Hi!

I've just installed siduction (KDE version), and I can't install any package from synaptic and/or aptitude. The system is a fresh install, and is up to date.

When I select a package and try to install it, the package is downloaded, and then I receive the following message:

Quote
E: Internal error: APT::pkgPackageManager::MaxLoopCount reached in SmartConfigure for libwxbase2.8-0:amd64, aborting


However, I can install with apt-get

Any suggestions?

Best regards.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.842
Can
« Reply #1 on: 2012/04/17, 15:49:40 »
It is a bug in the latest versio nof apt. should be fixed in a 2 hours with next mirror-sync. Please dist-upgrade the system.

greetz
devil

tapp

  • Guest
RE: Can
« Reply #2 on: 2012/04/17, 18:59:22 »
Hi!

Thanks for your answer. I've upgraded apt and apt-utils, and tried to dist-upgrade or upgrade the system, but I still have the same problem.

I've realised that I have the same problem with the apt-get upgrade or dist-upgrade command.

However, I can install any package with the apt-get install command :-m

Best regards.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.842
RE: Can
« Reply #3 on: 2012/04/17, 21:14:25 »
the bug responsible for that is http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=669060

Due to the breakage in apt itself you might need to fetch apt0.9.1 manualy from http://packages.debian.org/sid/apt and install it with dpkg -i.

greetz
devil

tapp

  • Guest
RE: Can
« Reply #4 on: 2012/04/17, 22:24:40 »
I updated apt, and now, I can install from synaptic, but I can't upgrade or dist-upgrade from command-line or update-manager.

I think I'm in trouble... :-s

Thanks for your attention.

Best regards.

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.358
    • Land of the Buckeye
RE: Can
« Reply #5 on: 2012/04/17, 23:18:52 »
I also downloaded and installed apt0.9.1 with dpkg, as devil says, and then I still had a problem. Here is what fixed it:

Code: [Select]
apt-get install --reinstall libapt-pkg4.12
System76 Oryx Pro, Intel Core i7-11800H, SSD 970 EVO Plus;  Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO

tapp

  • Guest
RE: Can
« Reply #6 on: 2012/04/17, 23:55:33 »
:-) It's working now!

Thanks devil and dibl!

craigevil

  • Guest
RE: Can
« Reply #7 on: 2012/04/19, 00:59:30 »
Hm I do d-u daily and didn't seem to run into this issue. Weird.

$ apt-cache policy libapt-pkg4.12
libapt-pkg4.12:
  Installed: 0.9.1
  Candidate: 0.9.1
  Version table:
 *** 0.9.1 0
        500 http://ftp.us.debian.org/debian/ unstable/main i386 Packages
        100 /var/lib/dpkg/status

$ apt-cache policy apt
apt:
  Installed: 0.9.1
  Candidate: 0.9.1
  Version table:
 *** 0.9.1 0
        500 http://ftp.us.debian.org/debian/ unstable/main i386 Packages
        100 /var/lib/dpkg/status