Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] Kaffeine dvb-t and Nvidia vdpau  (Read 3041 times)

Offline ralul

  • User
  • Posts: 1.814
[DE] Kaffeine dvb-t and Nvidia vdpau
« on: 2012/04/16, 14:53:26 »
Lastly I had to abandon me-tv application for to see my german Tv via my dvb-t usb-stick. This was du to a glib upgrade to glib-2.32.

As an alternative I found kaffeine.
Kaffeine I didnt use for a long time, because it uses xine-lib. (As I replaced xine by gstreamer for kde phonon backend. I wanted to get rid of all of xine.)

Kaffeine works well in an Kde-phonon-gestreamer environment despite of xine. But I made the observation that
X and kwin went up in processor time insanely! (*)
On my gentoo I just recompiled xine-lib with vdpau USE flag disabled. This solved my issue!

For my Debian siduction:
How can I disable vdpau use of xine-lib by Kaffeine?

(*) PS: Now for my Gentoo Kaffeine without vdpau lets Kwin and X go up one percent per start which stays on after close. If not beautiful but somehow acceptable ...
experiencing siduction runs better than my gentoo makes me know I know nothing

Offline ralul

  • User
  • Posts: 1.814
Kaffeine dvb-t and Nvidia vdpau
« Reply #1 on: 2012/04/17, 13:18:14 »
Finally I found the optimal proprietary Nvidia settings:

Nvidia-Settings:
OpenGL Setting
x Sync to VBlank
x Allow flipping

This doesn't increase cpu usage any more when running Kaffeine dvb!

@towo:
Also I purged the
v4l-dvb_fix-DVB-S-regression-caused-by-a-missing-initializat.patch
This patch was a fix for linux<3.3.2 and shouldn't be necessary any more!
experiencing siduction runs better than my gentoo makes me know I know nothing