Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] (gelöst) thunar/RK/terminal hier öffnen öffnet nicht hier  (Read 1815 times)

Offline michaa7

  • User
  • Posts: 2.298
Ich nutze unter Fluxbox "Konsole" als standart VT. Wenn ich nun in Thunar "rechtsklick/terminal hier öffnen" ausführe öffnet sich zwar konsole, jedoch nicht im gewünschen ausgangsverzeichnis (hier wo ich es ausgelöst habe in Thunar) sondern in meinem home.

Im konsole profil ist als standardordner gar nichts eingegeben und die checkbox "im gleichen unterfenster öffnen" angehakt. Hatte es jodoch auch scon ohne dieses häckchen versucht.

Jemand nen tipp wie man das hinbekommt wie es soll?
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline unklarer

  • User
  • Posts: 817
(gelöst) thunar/RK/terminal hier öffnen öffnet nicht hier
« Reply #1 on: 2012/06/04, 11:45:55 »
Habe hier Fluxbox und Thunar auf einer alten Maschine unter antiX laufen. Da funktioniert das Teil.

Thunar: >Bearbeiten>Benutzerdefinierte Aktionen...>Terminal hier öffnen>Bearbeiten unter "Allgemein" wird der Befehl
Code: [Select]
exo-open --working-directory %f --launch TerminalEmulatorausgeführt und unter "Dateizuordnung" ist das Dateimuster
Code: [Select]
*ausgewählt und ein Häkchen nur in "Ordner".

Hoffe, es hilft. :wink:

Offline michaa7

  • User
  • Posts: 2.298
(gelöst) thunar/RK/terminal hier öffnen öffnet nicht hier
« Reply #2 on: 2012/06/04, 14:30:02 »
leider nicht. Habe genau die gleichen einstellungen, doch es klappt nicht. Das legt die vermutung nahe, dass es ehr an den (profil-) einstellungen von "konsole" (mein Terminal Emulator) liegt ... oder nutzt du den auch?

Danke jedenfalls für deine antwort.
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline unklarer

  • User
  • Posts: 817
(gelöst) thunar/RK/terminal hier öffnen öffnet nicht hier
« Reply #3 on: 2012/06/04, 16:50:40 »
Sorry nein,
bei mir handelt es sich nicht um die 'Konsole' sondern um 'RoxTerm'.  :oops:

Im Zusammenhang des gleichen mit 'catfish' beobachteten Verhalten, wurde ich hier im Forum vor längerer Zeit fündig. Leider finde ich den Thread dazu nicht mehr, hatte mir aber den Text kopiert...
Quote
Falls jemand verwöhnt ist von Tabs und der Suchfunktion in z.B. Krusader, dann ist der "Thunar ab Werk" recht spartanisch.
Man kann Thunar mit benutzerdefinierten Aktionen (Menü->Bearbeiten) erweitern. Danach hat man unter der rechten Maustaste eine Funktion mehr.
Bei manchen Thunar-Versionen ist es ausreichend wenn als für Suchaktionen der Befehl eingegeben wird
     
Code:
catfish %f

Mit der Version (1.2.3-2) die mit siduction geliefert wird, reichte dies nicht. catfish fügt beim einfachen "%f" den Ordnernamen im Suchfeld ein (bug?) und nicht in das Ordner-Feld. Damit wird das suchen immer im Ordner "catfish" gestartet. Dies ist unerwünscht, es kann korrigiert werden mit einem erweiterten Befehl:
     
Code:
catfish --path=%f

Danach wird in dem Ordner gesucht den man mit der rechten Maustaste angeklickt hat.

Sollte man mehrere Dateimanager haben, kann außerdem die Nennung des Dateimanagers erforderlich sein.
     
Code:
catfish --fileman=thunar --path=%f

Ist das der Trick, den Du suchst?

Offline michaa7

  • User
  • Posts: 2.298
(gelöst) thunar/RK/terminal hier öffnen öffnet nicht hier
« Reply #4 on: 2012/06/04, 17:47:28 »
Quote from: "unklarer"
...
Ist das der Trick, den Du suchst?


Das war er zwar nicht. Und sämtliche variationen die ich versuchte waren ebenso wenig erfolgreich. Aber das fehlerbild verdeutlichte mir zumindest, dass es weniger an den settings in Thunar lag als vielmehr wie vermutet an den konsole profileinstellungen ... und da wurde ich nun fündig. Ein "." im feld "startordner" tut nun den trick, konsole öffnet sich von Thunar aus im gewünschten Ordner.

In soweit war der umweg über deinen voschlag schon hilfreich. Danke!
Ok, you can't code, but you still might be able to write a bug report for Debian's sake