Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] unerfüllte Abhängigkeiten durch eigene Schuld?  (Read 9804 times)

Offline Lanzi

  • User
  • Posts: 1.781
[DE] unerfüllte Abhängigkeiten durch eigene Schuld?
« on: 2012/06/16, 23:29:56 »
Habe gestern ein DU gestartet, was beim entpacken der Pakete durch eine volle root-partition abgebrochen wurde.

Als einzige Lösung sah ich ein apt-cache clean. Vielleicht nicht die schlauste Lösung im DU...

nun gehts nicht weiter, auch heute nicht:

Quote

root@siduction:~# apt-get dist-upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.      
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt-get -f install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 cpp-4.7 : Hängt ab von: gcc-4.7-base (= 4.7.0-13) aber 4.7.1-1 ist installiert
 g++-4.7 : Hängt ab von: libstdc++6-4.7-dev (= 4.7.1-1) aber 4.7.0-13 ist installiert
 gcc-4.7 : Hängt ab von: cpp-4.7 (= 4.7.1-1) aber 4.7.0-13 ist installiert
           Hängt ab von: libgomp1 (>= 4.7.1-1) aber 4.7.0-13 ist installiert
           Hängt ab von: libitm1 (>= 4.7.1-1) aber 4.7.0-13 ist installiert
           Hängt ab von: libquadmath0 (>= 4.7.1-1) aber 4.7.0-13 ist installiert
 lib32gcc1 : Hängt ab von: gcc-4.7-base (= 4.7.0-13) aber 4.7.1-1 ist installiert
 lib32stdc++6 : Hängt ab von: gcc-4.7-base (= 4.7.0-13) aber 4.7.1-1 ist installiert
 libgfortran3 : Hängt ab von: gcc-4.7-base (= 4.7.0-13) aber 4.7.1-1 ist installiert
 libgomp1 : Hängt ab von: gcc-4.7-base (= 4.7.0-13) aber 4.7.1-1 ist installiert
 libitm1 : Hängt ab von: gcc-4.7-base (= 4.7.0-13) aber 4.7.1-1 ist installiert
 libquadmath0 : Hängt ab von: gcc-4.7-base (= 4.7.0-13) aber 4.7.1-1 ist installiert
 libstdc++6-4.7-dev : Hängt ab von: gcc-4.7-base (= 4.7.0-13) aber 4.7.1-1 ist installiert
                      Hängt ab von: g++-4.7 (= 4.7.0-13) aber 4.7.1-1 ist installiert
E: Unerfüllte Abhängigkeiten. Versuchen Sie, -f zu benutzen.



Haben das gerade alle, oder nur ich, durch den Abbruch?

Offline Lanzi

  • User
  • Posts: 1.781
RE: unerfüllte Abhängigkeiten durch eigene Schuld?
« Reply #1 on: 2012/06/16, 23:34:44 »
Habe gerade mal statt apt-get -f install ein apt-get -f dist-upgrade gestartet... Jetzt lädet er zumindest die Packete neu.
Mal sehen, was passiert...

Offline Lanzi

  • User
  • Posts: 1.781
RE: unerfüllte Abhängigkeiten durch eigene Schuld?
« Reply #2 on: 2012/06/17, 00:10:49 »
Also apt-get -f dist-upgrade lief nicht durch.

die Fehlermeldung ist die längste, die ich je hatte...

Quote

root@siduction:~# apt-get dist-upgrade -f
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.      
Statusinformationen werden eingelesen.... Fertig
Abhängigkeiten werden korrigiert ... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden Pakete werden aktualisiert (Upgrade):
  cpp-4.7 lib32gcc1 lib32stdc++6 libgfortran3 libgomp1 libitm1 libquadmath0 libstdc++6-4.7-dev
8 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
36 nicht vollständig installiert oder entfernt.
Es müssen noch 0 B von 8.082 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 4.096 B Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren [J/n]? j
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libgomp1:amd64:
 libgomp1:amd64 hängt ab von gcc-4.7-base (= 4.7.0-13); aber:
  Version von gcc-4.7-base:amd64 auf dem System ist 4.7.1-1.
dpkg: Fehler beim Bearbeiten von libgomp1:amd64 (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libfftw3-3:amd64:
 libfftw3-3:amd64 hängt ab von libgomp1 (>= 4.2.1); aber:                                                                                                                                                                  
  Paket libgomp1:amd64 ist noch nicht konfiguriert.                                                                                                                                                                        
dpkg: Fehler beim Bearbeiten von libfftw3-3:amd64 (--configure):                                                                                                                                                          
 Abhängigkeitsprobleme - verbleibt unkonfiguriert                                                                                                                                                                          
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libquadmath0:amd64:                                                                                                                                              
 libquadmath0:amd64 hängt ab von gcc-4.7-base (= 4.7.0-13); aber:                                                                                                                                                          
  Version von gcc-4.7-base:amd64 auf dem System ist 4.7.1-1.                                                                                                                                                              
dpkg: Fehler beim Bearbeiten von libquadmath0:amd64 (--configure):                                                                                                                                                        
 Abhängigkeitsprobleme - verbleibt unkonfiguriert                                                                                                                                                                          
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libgfortran3:amd64:                                                                                                                                              
 libgfortran3:amd64 hängt ab von gcc-4.7-base (= 4.7.0-13); aber:                                                                                                                                                          
  Version von gcc-4.7-base:amd64 auf dem System ist 4.7.1-1.                                                                                                                                                              
 libgfortran3:amd64 hängt ab von libquadmath0 (>= 4.6); aber:                                                                                                                                                              
  Paket libquadmath0:amd64 ist noch nicht konfiguriert.                                                                                                                                                                    
dpkg: Fehler beim Bearbeiten von libgfortran3:amd64 (--configure):                                                                                                                                                        
 Abhängigkeitsprobleme - verbleibt unkonfiguriert                                                                                                                                                                          
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libitm1:amd64:                                                                                                                                                    
 libitm1:amd64 hängt ab von gcc-4.7-base (= 4.7.0-13); aber:                                                                                                                                                              
  Version von gcc-4.7-base:amd64 auf dem System ist 4.7.1-1.                                                                                                                                                              
dpkg: Fehler beim Bearbeiten von libitm1:amd64 (--configure):                                                                                                                                                              
 Abhängigkeitsprobleme - verbleibt unkonfiguriert                                                                                                                                                                          
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libmagickcore5:amd64:                                                                                                                                            
 libmagickcore5:amd64 hängt ab von libgomp1 (>= 4.2.1); aber:                                                                                                                                                              
  Paket libgomp1:amd64 ist noch nicht konfiguriert.                                                                                                                                                                        
dpkg: Fehler beim Bearbeiten von libmagickcore5:amd64 (--configure):                                                                                                                                                      
 Abhängigkeitsprobleme - verbleibt unkonfiguriert                                                                                                                                                                          
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libmagickwand5:amd64:                                                                                                                                            
 libmagickwand5:amd64 hängt ab von libgomp1 (>= 4.2.1); aber:                                                                                                                                                              
  Paket libgomp1:amd64 ist noch nicht konfiguriert.                                                                                                                                                                        
 libmagickwand5:amd64 hängt ab von libmagickcore5 (>= 8:6.7.7.2); aber:                                                                                                                                                    
  Paket libmagickcore5:amd64 ist noch nicht konfiguriert.                                                                                                                                                                  
dpkg: Fehler beim Bearbeiten von libmagickwand5:amd64 (--configure):                                                                                                                                                      
 Abhängigkeitsprobleme - verbleibt unkonfiguriert                                                                                                                                                                          
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libmagick++5:amd64:
 libmagick++5:amd64 hängt ab von libgomp1 (>= 4.2.1); aber:
  Paket libgomp1:amd64 ist noch nicht konfiguriert.
 libmagick++5:amd64 hängt ab von libmagickcore5 (>= 8:6.7.7.2); aber:
  Paket libmagickcore5:amd64 ist noch nicht konfiguriert.
 libmagick++5:amd64 hängt ab von libmagickwand5 (>= 8:6.7.7.2); aber:
  Paket libmagickwand5:amd64 ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von libmagick++5:amd64 (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von cpp-4.7:
 cpp-4.7 hängt ab von gcc-4.7-base (= 4.7.0-13); aber:
  Version von gcc-4.7-base:amd64 auf dem System ist 4.7.1-1.
dpkg: Fehler beim Bearbeiten von cpp-4.7 (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von darktable:
 darktable hängt ab von libgomp1 (>= 4.2.1); aber:
  Paket libgomp1:amd64 ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von darktable (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von imagemagick:
 imagemagick hängt ab von libgomp1 (>= 4.2.1); aber:
  Paket libgomp1:amd64 ist noch nicht konfiguriert.
 imagemagick hängt ab von libmagickcore5 (>= 8:6.7.7.2); aber:
  Paket libmagickcore5:amd64 ist noch nicht konfiguriert.
 imagemagick hängt ab von libmagickwand5 (>= 8:6.7.7.2); aber:
  Paket libmagickwand5:amd64 ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von imagemagick (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von devede:
 devede hängt ab von imagemagick; aber:
  Paket imagemagick ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von devede (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von gcc-4.7:
 gcc-4.7 hängt ab von cpp-4.7 (= 4.7.1-1); aber:
  Version von cpp-4.7 auf dem System ist 4.7.0-13.
 gcc-4.7 hängt ab von libgomp1 (>= 4.7.1-1); aber:
  Version von libgomp1:amd64 auf dem System ist 4.7.0-13.
 gcc-4.7 hängt ab von libitm1 (>= 4.7.1-1); aber:
  Version von libitm1:amd64 auf dem System ist 4.7.0-13.
 gcc-4.7 hängt ab von libquadmath0 (>= 4.7.1-1); aber:
  Version von libquadmath0:amd64 auf dem System ist 4.7.0-13.
dpkg: Fehler beim Bearbeiten von gcc-4.7 (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libstdc++6-4.7-dev:
 libstdc++6-4.7-dev hängt ab von gcc-4.7-base (= 4.7.0-13); aber:
  Version von gcc-4.7-base:amd64 auf dem System ist 4.7.1-1.
 libstdc++6-4.7-dev hängt ab von g++-4.7 (= 4.7.0-13); aber:
  Version von g++-4.7 auf dem System ist 4.7.1-1.
dpkg: Fehler beim Bearbeiten von libstdc++6-4.7-dev (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von g++-4.7:
 g++-4.7 hängt ab von gcc-4.7 (= 4.7.1-1); aber:
  Paket gcc-4.7 ist noch nicht konfiguriert.
 g++-4.7 hängt ab von libstdc++6-4.7-dev (= 4.7.1-1); aber:
  Version von libstdc++6-4.7-dev auf dem System ist 4.7.0-13.
dpkg: Fehler beim Bearbeiten von g++-4.7 (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von gettext:
 gettext hängt ab von libgomp1 (>= 4.2.1); aber:
  Paket libgomp1:amd64 ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von gettext (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libgraphicsmagick3:
 libgraphicsmagick3 hängt ab von libgomp1 (>= 4.2.1); aber:
  Paket libgomp1:amd64 ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von libgraphicsmagick3 (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libxine2-misc-plugins:
 libxine2-misc-plugins hängt ab von libgraphicsmagick3 (>= 1.3.5); aber:
  Paket libgraphicsmagick3 ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von libxine2-misc-plugins (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libxine2-plugins:
 libxine2-plugins hängt ab von libxine2-misc-plugins (>= 1.2.2-3); aber:
  Paket libxine2-misc-plugins ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von libxine2-plugins (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libxine2:
 libxine2 hängt ab von libxine2-plugins (= 1.2.2-3) | libxine2-misc-plugins (= 1.2.2-3); aber:
  Paket libxine2-plugins ist noch nicht konfiguriert.
  Paket libxine2-misc-plugins ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von libxine2 (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von gxine:
 gxine hängt ab von libxine2 (>= 1.2.0); aber:
  Paket libxine2 ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von gxine (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libblas3:
 libblas3 hängt ab von libgfortran3 (>= 4.3); aber:
  Paket libgfortran3:amd64 ist noch nicht konfiguriert.
 libblas3 hängt ab von libquadmath0 (>= 4.6); aber:
  Paket libquadmath0:amd64 ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von libblas3 (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libblas3gf:
 libblas3gf hängt ab von libblas3; aber:
  Paket libblas3 ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von libblas3gf (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von liblapack3:
 liblapack3 hängt ab von libblas3 | libblas.so.3 | libatlas3-base; aber:
  Paket libblas3 ist noch nicht konfiguriert.
  Paket libblas.so.3 ist nicht installiert.
  Paket libblas3, das libblas.so.3 bereitstellt, ist noch nicht konfiguriert.
  Paket libatlas3-base ist nicht installiert.
 liblapack3 hängt ab von libgfortran3 (>= 4.6); aber:
  Paket libgfortran3:amd64 ist noch nicht konfiguriert.
 liblapack3 hängt ab von libquadmath0 (>= 4.6); aber:
  Paket libquadmath0:amd64 ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von liblapack3 (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von liblapack3gf:
 liblapack3gf hängt ab von liblapack3; aber:
  Paket liblapack3 ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von liblapack3gf (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libxine1-misc-plugins:
 libxine1-misc-plugins hängt ab von libgraphicsmagick3 (>= 1.3.5); aber:
  Paket libgraphicsmagick3 ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von libxine1-misc-plugins (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libxine1-plugins:
 libxine1-plugins hängt ab von libxine1-misc-plugins (>= 1.1.21-1); aber:
  Paket libxine1-misc-plugins ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von libxine1-plugins (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libxine1:
 libxine1 hängt ab von libxine1-plugins (= 1.1.21-1) | libxine1-misc-plugins (= 1.1.21-1); aber:
  Paket libxine1-plugins ist noch nicht konfiguriert.
  Paket libxine1-misc-plugins ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von libxine1 (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von lintian:
 lintian hängt ab von gettext; aber:
  Paket gettext ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von lintian (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von linux-headers-3.4-2.towo.1-siduction-amd64:
 linux-headers-3.4-2.towo.1-siduction-amd64 hängt ab von gcc-4.7; aber:
  Paket gcc-4.7 ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von linux-headers-3.4-2.towo.1-siduction-amd64 (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von picard:
 picard hängt ab von libfftw3-3; aber:
  Paket libfftw3-3:amd64 ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von picard (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-numpy:
 python-numpy hängt ab von libblas3gf | libblas.so.3gf | libatlas3gf-base; aber:
  Paket libblas3gf ist noch nicht konfiguriert.
  Paket libblas3, das libblas3gf bereitstellt, ist noch nicht konfiguriert.
  Paket libblas.so.3gf ist nicht installiert.
  Paket libblas3, das libblas.so.3gf bereitstellt, ist noch nicht konfiguriert.
  Paket libatlas3gf-base ist nicht installiert.
 python-numpy hängt ab von libgfortran3 (>= 4.3); aber:
  Paket libgfortran3:amd64 ist noch nicht konfiguriert.
 python-numpy hängt ab von liblapack3gf | liblapack.so.3gf | libatlas3gf-base; aber:
  Paket liblapack3gf ist noch nicht konfiguriert.
  Paket liblapack3, das liblapack3gf bereitstellt, ist noch nicht konfiguriert.
  Paket liblapack.so.3gf ist nicht installiert.
  Paket liblapack3, das liblapack.so.3gf bereitstellt, ist noch nicht konfiguriert.
  Paket libatlas3gf-base ist nicht installiert.
 python-numpy hängt ab von libquadmath0 (>= 4.6); aber:
  Paket libquadmath0:amd64 ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-numpy (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von rawtherapee:
 rawtherapee hängt ab von libgomp1 (>= 4.4); aber:
  Paket libgomp1:amd64 ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von rawtherapee (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von lib32gcc1:
 lib32gcc1 hängt ab von gcc-4.7-base (= 4.7.0-13); aber:
  Version von gcc-4.7-base:amd64 auf dem System ist 4.7.1-1.
dpkg: Fehler beim Bearbeiten von lib32gcc1 (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von lib32stdc++6:
 lib32stdc++6 hängt ab von gcc-4.7-base (= 4.7.0-13); aber:
  Version von gcc-4.7-base:amd64 auf dem System ist 4.7.1-1.
 lib32stdc++6 hängt ab von lib32gcc1 (>= 1:4.1.1); aber:
  Paket lib32gcc1 ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von lib32stdc++6 (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von linux-headers-siduction-amd64:
 linux-headers-siduction-amd64 hängt ab von linux-headers-3.4-2.towo.1-siduction-amd64 (= 3.4-10); aber:
  Paket linux-headers-3.4-2.towo.1-siduction-amd64 ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von linux-headers-siduction-amd64 (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 libgomp1:amd64
 libfftw3-3:amd64
 libquadmath0:amd64
 libgfortran3:amd64
 libitm1:amd64
 libmagickcore5:amd64
 libmagickwand5:amd64
 libmagick++5:amd64
 cpp-4.7
 darktable
 imagemagick
 devede
 gcc-4.7
 libstdc++6-4.7-dev
 g++-4.7
 gettext
 libgraphicsmagick3
 libxine2-misc-plugins
 libxine2-plugins
 libxine2
 gxine
 libblas3
 libblas3gf
 liblapack3
 liblapack3gf
 libxine1-misc-plugins
 libxine1-plugins
 libxine1
 lintian
 linux-headers-3.4-2.towo.1-siduction-amd64
 picard
 python-numpy
 rawtherapee
 lib32gcc1
 lib32stdc++6
 linux-headers-siduction-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@siduction:~#



Ein normales apt-get dist-upgrade liefert die Fehlermeldung von vorhin.

Was nun?
bringt ein Deinstallieren von cpp-4.7, gcc-4.7, g++-4.7 was?

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.844
RE: unerfüllte Abhängigkeiten durch eigene Schuld?
« Reply #3 on: 2012/06/17, 01:03:14 »
Ich würde ja erst mal ein dpkg-configure --a versuchen.

greetz
devil

Offline Lanzi

  • User
  • Posts: 1.781
RE: unerfüllte Abhängigkeiten durch eigene Schuld?
« Reply #4 on: 2012/06/17, 01:24:33 »
Ein dpkg --configure -a
bringt die obengenannte (lange) Fehlermeldung.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.844
RE: unerfüllte Abhängigkeiten durch eigene Schuld?
« Reply #5 on: 2012/06/17, 01:33:06 »
Kannst du denn libgomp1 entfernen?
z.b. mit dpkg --purge libgomp
greetz
devil

Offline Lanzi

  • User
  • Posts: 1.781
RE: unerfüllte Abhängigkeiten durch eigene Schuld?
« Reply #6 on: 2012/06/17, 01:40:36 »
Quote

root@siduction:~# dpkg --purge libgomp
dpkg: Warnung: Die Anforderung, libgomp zu entfernen, wird ignoriert; es ist nicht installiert.

Offline michaa7

  • User
  • Posts: 2.302
RE: unerfüllte Abhängigkeiten durch eigene Schuld?
« Reply #7 on: 2012/06/17, 02:54:15 »
ich hatte ähnliche probleme in zusammenhang mit dem dir bekannten wine-problem:
http://forum.siduction.org/index.php?topic=2443

Es gab da ein nicht mehr durschschaubares (vielleicht sogar mit normalen mitteln nicht mehr auflösbares) abhängigkeitsproblem mit gcc-4.7 gcc-4.7-base cpp-4.7. Irgendwie waren die in einer art ringabhängigkeit miteinander verstrickt, so dass immer ein paket wegen abhängigkeit von einer besonderen version eines anderen der drei nicht installierbar war.

Nun ACHTUNG, möglicherweise bekomme ich wegen dieses tipps nun verbal haue, aber der knoten lies sich nur so durchschlagen:  Ich habe per (und nun wirklich voooooorrrsiiiicht, lies dir vorher erstmal die man dpkg durch, damit dir klar ist, was das bewirkt) "dpkg --force-breaks -i cpp-4.7 gcc-4.7" die pakete zwangsinstalliert, ohne rücksicht darauf, dass diese nicht wirklich zueinander passen. Ich weiß jedoch nicht mehr genau, ob ich dazu die ältern versionen, die neuesten oder die alten und neuen versionen im archiv hatte (ich hatte *irgendwann* die alten und neuen versionen per wget direkt von den mirrors geholt). Mir erschien dieses *temporäre* nicht zusammenpassen der pakete daher nicht soooo wild (einen kernel möchtes du damit bestimmt nicht kompilieren ... zu diesem zeitpunkt), weil ich wußte, dass es zueinander passende versionen gibt, die ich nach beseitigung der  d-u probleme installieren würde, womit dieser konflikt dann wieder aufgehoben würde. Und genau so passierte dies dann auch, mit "dpkg --configure -a" , d-u und "apt-get -f install" hangelte ich mich dann erfolgreich vorwärts, aber ob die passenden gcc und cpp pakete direkt durch das d-u oder händisch durch mich nachinstalliert wurden weiß ich nicht mehr.
Allerdings, und das ist die schlechte nachricht, hatte ich nicht einen derart langen rattenschwanz von abhängigkeitsproblemen wie das bei der der fall ist.

Viel glück.
« Last Edit: 2013/11/10, 05:06:21 by ayla »
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.844
RE: unerfüllte Abhängigkeiten durch eigene Schuld?
« Reply #8 on: 2012/06/17, 10:03:00 »
Lanzi,

sorry, muss natürlich
Code: [Select]
dpkg --purge libgomp1heissen. Mitdenken ist hier ausdrücklich erlaubt :)

greetz
devil

Offline Lanzi

  • User
  • Posts: 1.781
RE: unerfüllte Abhängigkeiten durch eigene Schuld?
« Reply #9 on: 2012/06/17, 10:52:42 »
Morgen zusammen :-)

@Devil: Entfernen geht nicht, da jede Menge Programme davon abhängen (digikam, usw)

@michaa7: Klingt nach nem hartem Weg... Bevor ich das tue, mag ich erstmal warten, was Devil noch so im Petto hat.

Allgemeine Frage... Brauche ich diese Programme momentan überhaupt? Das sind doch Programme zum compilieren, oder erinnere ich mich da falsch. Meine, dass ich die beim VDR mal vor Jahren brauchte.
Einem vorläufigen Deinstallieren dürfte doch nicht so viel i Wege stehen, oder?

Offline agaida

  • User
  • Posts: 1.760
    • http://g-com.eu
RE: unerfüllte Abhängigkeiten durch eigene Schuld?
« Reply #10 on: 2012/06/17, 11:14:16 »
Versuch doch einfach mal, den Teufel mit dem Beelzebub auszutreiben :twisted: Aptitude -f install wäre eine Idee, dann durch die angebotenen Möglichkeiten gehen und sich die schmerzfreiste Variante aussuchen, wenn nicht vollständig aufgelöst wird.

/me konnte sich das Wortspiel einfach nicht verkneifen
There's this special biologist word we use for "stable". It's "dead". ~ Jack Cohen

Offline Lanzi

  • User
  • Posts: 1.781
RE: unerfüllte Abhängigkeiten durch eigene Schuld?
« Reply #11 on: 2012/06/17, 14:05:22 »
@agaida:
Da scheine ich was schönes angerichtet zu haben...
Dein Vorschlag entfernt 150 Pakete inkl. kde...

Dein Wortspiel regt mich zu folgender sinnfreien Aussage an:
besser den Teufel im auf dem Dach, als die Axt im Zimmermann ;-)

Offline Lanzi

  • User
  • Posts: 1.781
RE: unerfüllte Abhängigkeiten durch eigene Schuld?
« Reply #12 on: 2012/06/17, 14:22:19 »
So, habe jetzt den zweiten Vorschlag probiert und er schlägt vor die Pakete zu deinstalieren, die ein :i386 tragen. Die sind mit dem Tipp Multiarch i386 im Zuge des DU wohl dazugekommen, weil wine die wohl braucht

Trotzdem konnte Aptitude den Knoten nicht auflösen.

Ich neige dazu schnell neu zu installieren. Das scheint mir die schnellere Variante zu sein..

Offline ralul

  • User
  • Posts: 1.814
RE: unerfüllte Abhängigkeiten durch eigene Schuld?
« Reply #13 on: 2012/06/17, 15:06:34 »
Auf kurze Sicht ist neu installieren fix. Über Jahre wäre es für mich unerträglich. Besser aptitude bedienen lernen, sind nur eine handvoll Kurzbefehle: _glmq+
experiencing siduction runs better than my gentoo makes me know I know nothing

Offline Lanzi

  • User
  • Posts: 1.781
RE: unerfüllte Abhängigkeiten durch eigene Schuld?
« Reply #14 on: 2012/06/17, 15:47:35 »
Ja, da magst DU recht haben. Wobei noch wichtiger wäre, zu verstehen, was zu dieser Situation geführt hat!

Ist es nun das Zufügen der i386 Architektur
(siehe http://forum.siduction.org/index.php?topic=2443) oder kam es durch den Abbruch des DU (wohlgemerkt, bevor auch nur ein Paket installiert war!).
« Last Edit: 2013/11/10, 04:42:29 by ayla »