Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: ktorrent wird entfernt  (Read 2382 times)

Offline phen

  • User
  • Posts: 85
ktorrent wird entfernt
« on: 2011/02/10, 08:37:25 »
Ist zwar schon seit einigen Tagen der Fall, hat sich aber noch immer nicht geändert: Bei einem d-u wird u.a. ktorrent entfernt.

EDIT:
Seh ich hier übrigens für sowohl 32bit als auch 64bit.

Offline Lanzi

  • User
  • Posts: 1.695
ktorrent wird entfernt
« Reply #1 on: 2011/02/10, 09:17:20 »
momentan kommen garnicht soviele Pakete rein, dafür wird echt einiges entfernt...

Offline hefee

  • User
  • Posts: 392
ktorrent wird entfernt
« Reply #2 on: 2011/02/10, 09:40:53 »
also bei mir bleibt ktorrent ganz brav installiert:
Code: [Select]

apt-cache policy ktorrent
ktorrent:
  Installiert: 4.0.5-3
  Kandidat:    4.0.5-3
  Versionstabelle:
 *** 4.0.5-3 0
        500 http://ftp.debian.org/debian/ sid/main i386 Packages
        100 /var/lib/dpkg/status
     4.0.2-1 0
        500 ftp://ftp5.gwdg.de/pub/linux/debian/debian/ testing/main i386 Packages

Offline phen

  • User
  • Posts: 85
ktorrent wird entfernt
« Reply #3 on: 2011/02/10, 09:48:43 »
Hm, offenbar kommt mein ktorrent noch aus experimental-snapshots:
Code: [Select]
#apt-cache policy ktorrent
ktorrent:
  Installiert: 4.0.2-1+b1
  Kandidat:    4.0.5-3
  Versionstabelle:
     4.0.5-3 0
        500 http://ftp.de.debian.org/debian/ sid/main amd64 Packages
 *** 4.0.2-1+b1 0
        100 http://qt-kde.debian.net/debian/ experimental-snapshots/main amd64 Packages
        100 /var/lib/dpkg/status

Einfach die sid Version installiern haut aber nicht hin:
Code: [Select]
#apt-get install ktorrent
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut      
Statusinformationen werden eingelesen... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 ktorrent : Hängt ab von: libsolidcontrol4 (>= 4:4.4) soll aber nicht installiert werden
E: Beschädigte Pakete

Den ganzen sukzessive auftauchenden Rattenschwanz mitinstalliern auch nicht wirklich:
Code: [Select]
#apt-get install ktorrent libsolidcontrol4 aptosid-art-kde-geras libsolidcontrolifaces4 aptosid-art-ksplash-geras kdebase-workspace-bin -d
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut      
Statusinformationen werden eingelesen... Fertig
kdebase-workspace-bin ist schon die neueste Version.
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libsolidcontrol4a : Kollidiert mit: libsolidcontrol4 aber 4:4.4.5-8 soll installiert werden
 libsolidcontrolifaces4a : Kollidiert mit: libsolidcontrolifaces4 aber 4:4.4.5-8 soll installiert werden
E: Beschädigte Pakete

Offline hefee

  • User
  • Posts: 392
ktorrent wird entfernt
« Reply #4 on: 2011/02/10, 09:59:43 »
strage, bei mir auf dem System gibt es kein Paket mit dem Namen libsolidcontrolifaces4a... Was sagt denn apt-cache policy zu diesem Paket?

ich würde ja vermuten das du noch einige andere Paketquellen hast, die nicht sauber gepinnt sind und er versucht über diese Quellen libsolidcontrol4,libsolidcontrolifaces4 etc. zu installieren. Oder du hast noch holds?

Offline phen

  • User
  • Posts: 85
ktorrent wird entfernt
« Reply #5 on: 2011/02/10, 10:13:44 »
Zunächst mal, keine Pakete auf hold:
Code: [Select]
#dpkg --get-selections | grep hold
Das libsolidcontrolifaces4a kommt ebenfalls aus experimental-snapshots, und gibts wohl auch nur dort:
Code: [Select]
#apt-cache policy libsolidcontrolifaces4a
libsolidcontrolifaces4a:
  Installiert: 4:4.5.1-0r2
  Kandidat:    4:4.5.1-0r2
  Versionstabelle:
 *** 4:4.5.1-0r2 0
        100 http://qt-kde.debian.net/debian/ experimental-snapshots/main amd64 Packages
        100 /var/lib/dpkg/status

Experimental-snapshots hab ich mal rausgenommen, ändert sich allerdings gar nichts (ausser natürlich dass policy nun keine Quelle für libsolidcontrol4 mehr anzeigt).
Dasselbe passiert übrigens auch wenn ich einfach versuche libsolidcontrolifaces4a zu deinstallieren:
Code: [Select]
#apt-get remove libsolidcontrolifaces4a -s
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut      
Statusinformationen werden eingelesen... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 aptosid-art-kde : Hängt ab von: aptosid-art-kde-geras soll aber nicht installiert werden oder
                                  aptosid-art-kde-theme
E: Beschädigte Pakete

Offline phen

  • User
  • Posts: 85
ktorrent wird entfernt
« Reply #6 on: 2011/02/10, 10:52:37 »
Code: [Select]
#apt-get remove libsolidcontrol4a libsolidcontrolifaces4a -s
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut      
Statusinformationen werden eingelesen... Fertig
Die folgenden Pakete werden ENTFERNT:
  aptosid-art-kde-keres aptosid-art-ksplash-keres kde-plasma-desktop kde-window-manager kdebase kdebase-workspace kdebase-workspace-bin kdebase-workspace-dev
  kdeplasma-addons libsolidcontrol4a libsolidcontrolifaces4a plasma-dataengines-workspace plasma-desktop plasma-widgets-addons plasma-widgets-workspace
0 aktualisiert, 0 neu installiert, 15 zu entfernen und 254 nicht aktualisiert.
Code: [Select]
#apt-cache policy kdebase-workspace
kdebase-workspace:
  Installiert: 4:4.5.1-0r2
  Kandidat:    4:4.5.1-0r2
  Versionstabelle:
 *** 4:4.5.1-0r2 0
        100 /var/lib/dpkg/status
     4:4.4.5-8 0
        500 http://ftp.de.debian.org/debian/ sid/main amd64 Packages
        500 http://ftp.de.debian.org/debian/ testing/main amd64 Packages
     4:4.4.5-7 0
        500 http://ftp.de.debian.org/debian/ stable/main amd64 Packages

Ich geh jetzt einfach mal von aus dass sich das Problem in Luft auflösen wird sobald kde in sid neuer sein wird als mein aus experimental-snapshots installiertes..  :lol: