Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] [SOLVED] kernel 3.5 towo produces filesystem errors  (Read 12240 times)

Offline clubex

  • User
  • Posts: 265
[EN] [SOLVED] kernel 3.5 towo produces filesystem errors
« Reply #30 on: 2012/07/31, 01:20:43 »
Devil + towo: HD was checked days ago as was the cable (changed). No high temps either. Still the same problems with towo 3.5 kernel.

I'm NOT arguing. I'd just like some support that makes sense and is of positive help.  

Telling me you don't have a problem with towo's 3.5 doesn't address the fact that I do!

First it's a controller problem then it's a cable problem. Both these responses do not explain why I only have a problem with towos 3.5 kernel? NOT with his earlier kernels NOR with slh's 3.5 kernel all using the SAME cable. Does this cable have some magical property which ONLY appears when used with towo's 3.5 kernel? That's patent nonsense.

Why does slh's kernel start and load the journal while towo's kernel causes DMA write errors and shuts it down. Why does this occur immediately after wmi: Mapper is loaded? Why when I go back to towo's 3.4-5 does the system have to clear up loads of /home file system errors caused by towo 3.5?

All these above questions are simple sensible questions. I have asked them throughout this thread if anyone bothers to read it. These are questions which, when answered, may help to get towo 3.5 kernel working properly on my machine. But none of them has been answered in a way which makes logical sense. Maybe it's because of language differences. I don't know.

OK I might have been wrong about an incompatibility with towo' 3.5 and EXT3 but I had to make a stab at solving the problem as no one else seemed to want to get involved.

towo: I shall certainly try this "recently uploaded kernel" (same config as slh?) when it arrives in the repos. I don't want, in the future, to go searching other distros looking for kernels which work on this machine.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.835
[SOLVED] kernel 3.5 towo produces filesystem errors
« Reply #31 on: 2012/07/31, 01:52:04 »
It is not language problems. There is just no proper way to debug this (at least frrom my side) The new kernel has been uploaded hours ago, so just try it.

greetz
devil

Offline ralul

  • User
  • Posts: 1.814
[SOLVED] kernel 3.5 towo produces filesystem errors
« Reply #32 on: 2012/07/31, 02:46:21 »
What me really wonders:
- It is for sure .config is the same as aptosid?
- Patchlevel seems to be equal with slh ...
- Is there a somehow different initramfs, if so, I wonder how, but our keyboard usb-hid bug just showed there might be issues ...
- Last possible cause: different compiler optimization level, which is an issue often heard of with the young gcc-4.7 compiler!

As ever, there should be - as last resort - the last stable 3.4.7 kernel! With a slightly higher RCU-Boost priority that kernel is BFS-424-ck3 patchable!
experiencing siduction runs better than my gentoo makes me know I know nothing

Offline clubex

  • User
  • Posts: 265
[SOLVED] kernel 3.5 towo produces filesystem errors
« Reply #33 on: 2012/08/01, 18:03:30 »
My apologies for the delay in trying the newer version of the kernel. (Community Centre duties).

I've now tried 3.5-0-towo (Debian 3.5-2) and there have been no problems. There are no DMA errors as there were with towo 3.5-0 (Debian 3.5.1) and the journal now loads OK.

Although there is no explanation why towo 3.5-0 (Debian 3.5.1) failed and slh 3.5-0 (Debian 3.5.1) didn't if no one objects I'll mark this thread as solved.

Thanks to all that tried.