Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] (gelöst) kmetronome  (Read 4527 times)

Offline spacepenguin

  • User
  • Posts: 862
    • spacepenguin.de
[DE] (gelöst) kmetronome
« Reply #15 on: 2012/08/11, 18:06:55 »
Als Befehl für einen Menü-Starter würde diese Zeile nicht funktionieren?
Susan | Hardware: SysProfile
Music-Profile: http://www.last.fm/de/user/spacepengu

Offline spacepenguin

  • User
  • Posts: 862
    • spacepenguin.de
(gelöst) kmetronome
« Reply #16 on: 2012/08/11, 18:57:09 »
Der Entwickler von Kmentronome hat folgendes vorgeschlagen:

Quote
try this Bash script:

$ cat kmetronome-autoplay.sh
#!/bin/bash
kmetronome &
sleep 1s
SERVICE="net.sourceforge.kmetronome-$(pidof kmetronome)"
qdbus $SERVICE / play

http://kde-apps.org/content/show.php?content=22485

Das sieht im Grunde wie deine Lösung aus, ayla - aber du warst schneller ;).
Susan | Hardware: SysProfile
Music-Profile: http://www.last.fm/de/user/spacepengu

Online ayla

  • User
  • Posts: 1.744
(gelöst) kmetronome
« Reply #17 on: 2012/08/11, 20:03:26 »
Quote from: "spacepenguin"
Als Befehl für einen Menü-Starter würde diese Zeile nicht funktionieren?


Hier bei KDE funktionierts indem ich das script einfach aus dem Dolphin in die Kontrolleiste ziehe und dort per Klick starte.

Wie ich einen Menüeintrag hinzufüge hab ich schon wieder mal vergessen...  :)

Gruß
ayla

Offline michaa7

  • User
  • Posts: 2.298
(gelöst) kmetronome
« Reply #18 on: 2012/08/11, 23:17:18 »
Ha, kaum geht man mal kurz weg, schon wird das problem von anderen gelöst ... das mach ich jetz öfters ;-), das könnt sogar ne regel werden.

Danke euch beiden. Wo legt man so ein script am geeignetsten hin, nach ~.kde/??, oder ~bin (ja, ist kein binary)?
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline michaa7

  • User
  • Posts: 2.298
(gelöst) kmetronome
« Reply #19 on: 2012/08/12, 00:23:21 »
Also, da sscript liegt bei mir jetz unter /home/<user>/bin/mnom-p.sh und im fluxbox menü habe ich einfach das script mit pfad angegebenden.
"spleep 1" funktioniert nicht, eine sekunde ist wohl zu kurz, da unter fluxbox kdeinit4, klaunch und kded4 erst noch gestartet werden müssen. Mit "sleep 3" klappt das jedoch.

Danke nochmals euch beiden!
Ok, you can't code, but you still might be able to write a bug report for Debian's sake