Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] [SOLVED]: British English spellcheckers not working in KDE  (Read 3693 times)

chandra

  • Guest
Hello,

I have just moved from Kubuntu 13.04 to siduction 2013.1 Firestarter KDE. And I am very happy with everything so far :-) So, thank you.

My first problem is this.

Although the Spell Checker under System Settings on KDE has English (United Kingdom) selected, Kate or Kile are unable to pick up wrong spellings.

What do I need to do?

Do I need to install some dictionaries, and if so, which?

Or do I need to install the KDE engb language-pack, which I think is not necessary?

Thank you.

Offline piper

  • User
  • Posts: 1.785
  • we are the priests ... of the temples of syrinx
RE: British English spellcheckers not working in KDE
« Reply #1 on: 2013/06/19, 21:21:48 »
It works here in kate, example, the word color was underlined in red so right click on the word color > spelling > choose colour

make sure automatic spell checking enabled by default is checked, exit, reopen
Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Offline absolut

  • User
  • Posts: 455
RE: British English spellcheckers not working in KDE
« Reply #2 on: 2013/06/19, 21:57:39 »
Quote

Do I need to install some dictionaries, and if so, which?


you probably need to check which spell-check libraries are installed...
Code: [Select]
dpkg -l | grep -i spell

if none, you can chose from aspell, myspell and hunspell dictionaries available in the debian repos

Offline piper

  • User
  • Posts: 1.785
  • we are the priests ... of the temples of syrinx
RE: British English spellcheckers not working in KDE
« Reply #3 on: 2013/06/20, 03:54:15 »
myspell-en-gb

would be the one you need

libaspell15, libenchant1c2a, libhunspell-1.3-0 (aspell spell checker libs/wrapper) won't hurt either
Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

chandra

  • Guest
Re: RE: British English spellcheckers not working in KDE
« Reply #4 on: 2013/06/20, 04:55:01 »
Quote from: "piper"
make sure automatic spell checking enabled by default is checked, exit, reopen


Yes, indeed, it is. But curiously, the tick is in white rather than green. Perhaps that is a sign that something is amiss.

chandra

  • Guest
Re: RE: British English spellcheckers not working in KDE
« Reply #5 on: 2013/06/20, 05:21:27 »
Quote
you probably need to check which spell-check libraries are installed...
Code: [Select]
dpkg -l | grep -i spell

if none, you can chose from aspell, myspell and hunspell dictionaries available in the debian repos


Here is what I have installed
Code: [Select]
ii  aspell  0.60.7~20110707-1   amd64   GNU Aspell spell-checker
ii  dictionaries-common 1.20.1  all Common utilities for spelling dictionary tools
ii  libaspell15 0.60.7~20110707-1   amd64   GNU Aspell spell-checker runtime library
ii  libenchant1c2a:amd64    1.6.0-10    amd64   Wrapper library for various spell checker engines (runtime libs)
ii  libhunspell-1.3-0:amd64 1.3.2-4 amd64   spell checker and morphological analyzer (shared library)
ii  myspell-de-de   20120607-1  all German dictionary for myspell
ii  myspell-en-us   1:3.3.0-4   all English_american dictionary for myspell
ii  myspell-pt-br   20130317-1  all Brazilian Portuguese dictionary for myspell


Code: [Select]
apt-get install myspell-en-gb did the trick.

Thank you.

chandra

  • Guest
Re: RE: British English spellcheckers not working in KDE
« Reply #6 on: 2013/06/20, 05:24:08 »
Quote from: "piper"
myspell-en-gb

would be the one you need

libaspell15, libenchant1c2a, libhunspell-1.3-0 (aspell spell checker libs/wrapper) won't hurt either


Yes, indeed. I have installed `myspell-en-gb` and spell checking now works.

Thank you.