Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] [SOLVED]: Setting default webbrowser for Icedove  (Read 9360 times)

chandra

  • Guest
[EN] [SOLVED]: Setting default webbrowser for Icedove
« on: 2013/06/21, 11:58:24 »
After installing Icedove and Iceweasel, whenever I clicked on an http hyperlink in an email, it opened up in Iceweasel, which is also set as my default browser and my x-www-browser.

After installing Chromium, however, http links in emails in Icedove open up in Chromium.

There is no change in my default browser, or x-www-browser, or the preferred browser in KDE Settings, or in $HOME/.local/share/applications/defaults.list, or in HOME/.local/share/applications/mimeapps.list. The following text in user.js in the .icedove/default directory also does not seem to work:

Code: [Select]
user_pref("network.protocol-handler.app.http", "/usr/bin/iceweasel");
user_pref("network.protocol-handler.app.https", "/usr/bin/iceweasel");
user_pref("network.protocol-handler.app.ftp", "/usr/bin/iceweasel");

Finally, setting the http, https, and ftp protocol handlers to x-www-browser or to iceweasel in Edit -> Preferences -> Advanced -> Config Editor in Icedove also does not seem to work.

Interestingly, however, removing Chromium restores Iceweasel as the default browser for links in Icedove.

Can someone please throw light on this behaviour and advise me how to work around it so that Iceweasel remains my default browser in Icedove.

[I cannot rule out some relic config file from previous distros in my home directory as the cause of this spot of bother, but I do not know which. My suspicion, though, is that some post-installation script for Chromium is modifying a default preference somewhere.]

Thank you.

Offline michaaa62

  • User
  • Posts: 299
Setting default webbrowser for Icedove
« Reply #1 on: 2013/06/21, 13:36:20 »
Code: [Select]
update-alternatives --config x-www-browsershould give you the choice of all the browsers installed to choose from

chandra

  • Guest
RE: Setting default webbrowser for Icedove
« Reply #2 on: 2013/06/21, 14:34:48 »
Yes, thank you. Here are the results:

Code: [Select]
update-alternatives --config x-www-browser
There are 3 choices for the alternative x-www-browser (providing /usr/bin/x-www-browser).

  Selection    Path                Priority   Status
------------------------------------------------------------
  0            /usr/bin/konqueror   100       auto mode
  1            /usr/bin/chromium    40        manual mode
* 2            /usr/bin/iceweasel   70        manual mode
  3            /usr/bin/konqueror   100       manual mode

Press enter to keep the current choice[*], or type selection number:


But Chromium is still launched from links in Icedove. Hence my question.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.842
RE: Setting default webbrowser for Icedove
« Reply #3 on: 2013/06/21, 15:27:16 »
Go to systemsettings - file associations (this is a wild guess, I do not have a EN environment at the moment)

open txt, klick on html  and move iceweasel to the top, same under applications with xhtml. That should set preference for Iceweasel everywhere.

greetz
devil

chandra

  • Guest
RE: Setting default webbrowser for Icedove
« Reply #4 on: 2013/06/21, 16:27:01 »
Iceweasel is at the top already.

chandra

  • Guest
RE: Setting default webbrowser for Icedove
« Reply #5 on: 2013/06/21, 16:33:27 »
Fortunately, there was a suggestion at

http://kb.mozillazine.org/Default_browser#Setting_the_browser_that_opens_in_Thunderbird_-_Linux

that worked. Here is the quote from there:

Quote
If you are still unable to change the browser after modifying these settings, editing the mimeTypes.rdf file, also located in your Profile folder, can fix the problem. Simply use a text editor to search for all references to the browser that links are currently opening in and replace them with references to the browser that you would like links to open in.

If there are no references to browsers to be replaced in the mimeTypes.rdf file, then adding some new sections to this file can fix the problem. Rather than directly editing the file, you can get Thunderbird to automatically add the required sections as follows:

    Navigate to "Edit --> Preferences --> Advanced" in the Thunderbird menus and click on the "Config Editor" button.
    Search for the following three entries:
       
Code: [Select]
       network.protocol-handler.warn-external.http
        network.protocol-handler.warn-external.https
        network.protocol-handler.warn-external.ftp

    Set the value of each of these three entries to true (you can do this by double-clicking on each entry, then close the "about:config" window and click "OK" on the "Thunderbird Preferences" window).

Having completed these steps, the next time you click on an http, https or ftp link in Thunderbird, you will be presented with the "Launch Application" window. Press the "Choose" button on this window to select your browser of choice. This will add the required entry to the mimeTypes.rdf file. This is a one-time task; having selected the browser once, links of the same type will now always be opened with the selected browser.


I set each preference to x-www-browser, asked it to be persistent, and now the links open in Iceweasel as I want them to :-)

Thanks

P.S. I can also confirm that removing and re-installing Chromium has no effect on the setting of the preferred bowser for Icedove now.