Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] kdepim-runtime package from kdenext appears to be incomplete  (Read 2452 times)

wicket

  • Guest
I've been using Siduction for about three weeks now and first of all I'd like to congratulate and thank the Siduction community for such an awesome distro.  I have however run into the following problem.

I'm trying to configure Akonadi to synchronise with my ownCloud CalDAV account as per the ownCloud documentation however the "DAV groupware resource" option is unavailable in Siduction.  Upon further investigation I discovered that I was missing the file /usr/bin/akonadi_davgroupware_resource.

An apt-file search reports that this file is included in the package kdepim-runtime and the web page for the Debian sid package shows this too.  Of course the package that has been installed is kdepim-runtime 4:4.10.5+really4.4.11.1-0r1 from the Siduction kdenext  repo and this version of the package is missing the akonadi_davgroupware_resource file.

Is this file omission deliberate?  If so, why?

Is there somewhere that I can read about the architecture of Siduction in terms of what it provides in addition to Debian sid?  In particular I'd like to know more about the benefits of the kdenext repo over the standard Debian sid packages.

Offline piper

  • User
  • Posts: 1.785
  • we are the priests ... of the temples of syrinx
RE: kdepim-runtime package from kdenext appears to be incomp
« Reply #1 on: 2013/08/19, 00:33:53 »
Perhaps

http://forum.siduction.org/index.php?topic=3720
Quote from: Santa
Hello,

KDE SC 4.11.0 has now moved to kdenext/unstable from kdenext/experimental-snapshots. The new kdepim 4.11 is not available yet in kdenext/kdepim-ng but I just hope to upload it soon.
« Last Edit: 2013/11/09, 23:35:48 by melmarker »
Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

wicket

  • Guest
Re: RE: kdepim-runtime package from kdenext appears to be in
« Reply #2 on: 2013/08/19, 20:19:05 »
Quote from: piper
Perhaps

http://forum.siduction.org/index.php?topic=3720
Quote from: Santa
Hello,

KDE SC 4.11.0 has now moved to kdenext/unstable from kdenext/experimental-snapshots. The new kdepim 4.11 is not available yet in kdenext/kdepim-ng but I just hope to upload it soon.

Thanks for the info.  I am indeed using kdenext/unstable but the kdepim-runtime package is still at version 4.10.5+really4.4.11.1-0r1.

Any idea what sort of time frame we're looking at for this to be fixed in kdenext/unstable?  Or should I just enable the kdenext/kdepim-ng repo?
« Last Edit: 2013/11/09, 23:37:52 by melmarker »

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.844
Re: RE: kdepim-runtime package from kdenext appears to be in
« Reply #3 on: 2013/08/19, 21:32:32 »
It does not need to be fixed because it is not broken, just not uploaded yet, because we prefer packages in a working condition. Santa, woh packages KDE for us, has a sparce internet connection, so be prepared for days at least.
kdenext/kdepim-ng is not recommended other than on test-environments.

greetz
devil

wicket

  • Guest
RE: Re: RE: kdepim-runtime package from kdenext appears to b
« Reply #4 on: 2013/08/19, 21:38:22 »
Thanks devil.  Does that mean that /usr/bin/akonadi_davgroupware_resource was excluded from the package because it is broken in upstream Debian?

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.844
RE: Re: RE: kdepim-runtime package from kdenext appears to b
« Reply #5 on: 2013/08/19, 21:45:32 »
That you will have to ask Santa. My guess is yes.

greetz
devil

Santa

  • Guest
Re: RE: Re: RE: kdepim-runtime package from kdenext appears
« Reply #6 on: 2013/09/13, 22:15:37 »
Hello,

Quote from: "wicket"
Thanks devil.  Does that mean that /usr/bin/akonadi_davgroupware_resource was excluded from the package because it is broken in upstream Debian?


No, the file wasn't excluded in the kdepim-runtime package; it just doesn't exist in the old kdepim 4.4; probably the feature which you want to use is only available in the new kdepim 4.11.1 (which has the file you are looking for); if you whish to use it (at your own risk) just add the kdepim-ng line to your sources.list.