Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] Fehlermeldung nach du  (Read 9430 times)

Offline manilg

  • User
  • Posts: 235
[DE] Fehlermeldung nach du
« on: 2013/12/01, 10:13:44 »
Hi,

seit einigen Tagen erhalte ich beim DU folgende Fehlermeldung:
Quote
vlc-data (2.1.1-1) wird eingerichtet ...
rmdir: konnte „/etc/vlc/lua/http/dialogs“ nicht entfernen: Datei oder Verzeichnis nicht gefunden
rmdir: konnte „/etc/vlc/lua/http“ nicht entfernen: Datei oder Verzeichnis nicht gefunden
rmdir: konnte „/etc/vlc/lua“ nicht entfernen: Datei oder Verzeichnis nicht gefunden
dpkg: Fehler beim Bearbeiten von vlc-data (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libvlccore7:
 libvlccore7 hängt ab von vlc-data (= 2.1.1-1); aber:
  Paket vlc-data ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von libvlccore7 (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libvlc5:
 libvlc5 hängt ab von libvlccore7 (>= 2.1.0); aber:
  Paket libvlccore7 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von libvlc5 (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von vlc-nox:
 vlc-nox hängt ab von libvlc5 (>= 2.1.0); aber:
  Paket libvlc5 ist noch nicht konfiguriert.
 vlc-nox hängt ab von libvlccore7 (>= 2.1.0); aber:
  Paket libvlccore7 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von vlc-nox (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von vlc:
 vlc hängt ab von vlc-nox (= 2.1.1-1); aber:
  Paket vlc-nox ist noch nicht konfiguriert.
 vlc hängt ab von libvlccore7 (>= 2.1.0); aber:
  Paket libvlccore7 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von vlc (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 vlc-data
 libvlccore7
 libvlc5
 vlc-nox
 vlc
E: Sub-process /usr/bin/dpkg returned an error code (1)


Ich habe alle 5 Dateien gepurged und wieder installiert, das hat keinen Effekt. Vlc ist installiert und funktioniert.

manilg

DeKa

  • Guest
Re: Fehlermeldung nach du
« Reply #1 on: 2013/12/01, 10:28:44 »
Hallo,
du mischt zwei Versionen: 2.1.0 und 2.1.1 da ist es klar das die Abhängigkeiten fehlen.

Code: [Select]
root@siductionbox:/home/deka# apt-cache policy vlc*
vlc-plugin-notify:
  Installiert:           (keine)
  Installationskandidat: 2.1.1-1
  Versionstabelle:
     1:2.1.1-dmo2 0
        300 http://www.deb-multimedia.org/ sid/main amd64 Packages
     2.1.1-1 0
        500 http://ftp2.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.is.debian.org/debian/ unstable/main amd64 Packages
vlc-plugin-fluidsynth:
  Installiert:           (keine)
  Installationskandidat: 2.1.1-1
  Versionstabelle:
     1:2.1.1-dmo2 0
        300 http://www.deb-multimedia.org/ sid/main amd64 Packages
     2.1.1-1 0
        500 http://ftp2.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.is.debian.org/debian/ unstable/main amd64 Packages
vlc-nox:
  Installiert:           2.1.1-1
  Installationskandidat: 2.1.1-1
  Versionstabelle:
     1:2.1.1-dmo2 0
        300 http://www.deb-multimedia.org/ sid/main amd64 Packages
 *** 2.1.1-1 0
        500 http://ftp2.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.is.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status
vlc-plugin-zvbi:
  Installiert:           (keine)
  Installationskandidat: 2.1.1-1
  Versionstabelle:
     1:2.1.1-dmo2 0
        300 http://www.deb-multimedia.org/ sid/main amd64 Packages
     2.1.1-1 0
        500 http://ftp2.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.is.debian.org/debian/ unstable/main amd64 Packages
vlc-plugin-jack:
  Installiert:           (keine)
  Installationskandidat: 2.1.1-1
  Versionstabelle:
     1:2.1.1-dmo2 0
        300 http://www.deb-multimedia.org/ sid/main amd64 Packages
     2.1.1-1 0
        500 http://ftp2.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.is.debian.org/debian/ unstable/main amd64 Packages
vlc-plugin-sdl:
  Installiert:           (keine)
  Installationskandidat: 2.1.1-1
  Versionstabelle:
     1:2.1.1-dmo2 0
        300 http://www.deb-multimedia.org/ sid/main amd64 Packages
     2.1.1-1 0
        500 http://ftp2.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.is.debian.org/debian/ unstable/main amd64 Packages
vlc-data:
  Installiert:           2.1.1-1
  Installationskandidat: 2.1.1-1
  Versionstabelle:
     1:2.1.1-dmo2 0
        300 http://www.deb-multimedia.org/ sid/main amd64 Packages
 *** 2.1.1-1 0
        500 http://ftp2.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.is.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status
vlc-plugin-vlsub:
  Installiert:           (keine)
  Installationskandidat: 0.9.10-1
  Versionstabelle:
     0.9.10-1 0
        500 http://ftp2.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.is.debian.org/debian/ unstable/main amd64 Packages
vlc-plugin-svg:
  Installiert:           (keine)
  Installationskandidat: 2.1.1-1
  Versionstabelle:
     1:2.1.1-dmo2 0
        300 http://www.deb-multimedia.org/ sid/main amd64 Packages
     2.1.1-1 0
        500 http://ftp2.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.is.debian.org/debian/ unstable/main amd64 Packages
vlc:
  Installiert:           2.1.1-1
  Installationskandidat: 2.1.1-1
  Versionstabelle:
     1:2.1.1-dmo2 0
        300 http://www.deb-multimedia.org/ sid/main amd64 Packages
 *** 2.1.1-1 0
        500 http://ftp2.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.is.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status
vlc-dbg:
  Installiert:           (keine)
  Installationskandidat: 2.1.1-1
  Versionstabelle:
     1:2.1.1-dmo2 0
        300 http://www.deb-multimedia.org/ sid/main amd64 Packages
     2.1.1-1 0
        500 http://ftp2.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.is.debian.org/debian/ unstable/main amd64 Packages
vlc-plugin-pulse:
  Installiert:           (keine)
  Installationskandidat: 2.1.1-1
  Versionstabelle:
     1:2.1.1-dmo2 0
        300 http://www.deb-multimedia.org/ sid/main amd64 Packages
     2.1.1-1 0
        500 http://ftp2.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.is.debian.org/debian/ unstable/main amd64 Packages
Bringe mal die folgenden Pakete auf die gleiche Version, install --reinstall.
Laut Siduction ist die Version 2.1.1 verfügbar.
Code: [Select]
root@siductionbox:/home/deka# apt-cache policy libvlccore7
libvlccore7:
  Installiert:           2.1.1-1
  Installationskandidat: 2.1.1-1
  Versionstabelle:
     1:2.1.1-dmo2 0
        300 http://www.deb-multimedia.org/ sid/main amd64 Packages
 *** 2.1.1-1 0
        500 http://ftp2.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.is.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status
Code: [Select]
root@siductionbox:/home/deka# apt-cache policy libvlc5
libvlc5:
  Installiert:           2.1.1-1
  Installationskandidat: 2.1.1-1
  Versionstabelle:
     1:2.1.1-dmo2 0
        300 http://www.deb-multimedia.org/ sid/main amd64 Packages
 *** 2.1.1-1 0
        500 http://ftp2.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.is.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status

Offline manilg

  • User
  • Posts: 235
Re: Fehlermeldung nach du
« Reply #2 on: 2013/12/01, 11:23:53 »
Das habe ich ja gemacht:
Quote

pt-cache policy vlc
vlc:
  Installiert:           2.1.1-1
  Installationskandidat: 2.1.1-1
  Versionstabelle:
 *** 2.1.1-1 0
        500 http://ftp.de.debian.org/debian/ sid/main i386 Packages
        100 /var/lib/dpkg/status
# apt-cache policy vlc-nox
vlc-nox:
  Installiert:           2.1.1-1
  Installationskandidat: 2.1.1-1
  Versionstabelle:
 *** 2.1.1-1 0
        500 http://ftp.de.debian.org/debian/ sid/main i386 Packages
        100 /var/lib/dpkg/status
# apt-cache policy vlc-data
vlc-data:
  Installiert:           2.1.1-1
  Installationskandidat: 2.1.1-1
  Versionstabelle:
 *** 2.1.1-1 0
        500 http://ftp.de.debian.org/debian/ sid/main i386 Packages
        100 /var/lib/dpkg/status
# apt-cache policy libvlc5
libvlc5:
  Installiert:           2.1.1-1
  Installationskandidat: 2.1.1-1
  Versionstabelle:
 *** 2.1.1-1 0
        500 http://ftp.de.debian.org/debian/ sid/main i386 Packages
        100 /var/lib/dpkg/status
# apt-cache policy libvlccore7
libvlccore7:
  Installiert:           2.1.1-1
  Installationskandidat: 2.1.1-1
  Versionstabelle:
 *** 2.1.1-1 0
        500 http://ftp.de.debian.org/debian/ sid/main i386 Packages
        100 /var/lib/dpkg/status


Das ändert aber nichts an der Fehlermeldung

manilg

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
Re: Fehlermeldung nach du
« Reply #3 on: 2013/12/01, 11:46:36 »
Füsse stillhalten, weitergehen, heut abend noch mal versuchem - dann dürften auch die letzten benötigten pakete in sid sein. Hoffe ich :)
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

DeKa

  • Guest
Re: Fehlermeldung nach du
« Reply #4 on: 2013/12/01, 12:04:18 »
Da hat @melmarker recht, du nutzt ja nicht das Böse deb-multimedia.
Daher dauert es mit den restlichen Paketen etwas länger, aber auch diese werden aktualisiert  ;D

Offline manilg

  • User
  • Posts: 235
Re: Fehlermeldung nach du
« Reply #5 on: 2013/12/01, 12:05:51 »
Was auch "seltsam" ist:
Code: [Select]
apt-get install --reinstall vlc
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
0 aktualisiert, 0 neu installiert, 1 erneut installiert, 0 zu entfernen und 1 nicht aktualisiert.
5 nicht vollständig installiert oder entfernt.
Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.
E: Internal Error, No file name for vlc:i386


manilg

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
Re: Fehlermeldung nach du
« Reply #6 on: 2013/12/01, 12:11:50 »
Was erwartest Du, wenn nich alle Dateien beider architekturen oder alle benötigten Dateien einer Architektur da sind?
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline manilg

  • User
  • Posts: 235
Re: Fehlermeldung nach du
« Reply #7 on: 2013/12/01, 12:19:29 »
Na ja diese Fehlermeldung
Code: [Select]
E: Internal Error, No file name for vlc:i386


jedenfalls nicht, vlc lässt sich ja installieren und funktioniert auch(wie ich geschrieben hatte), aber es kommt weiter zu diesen zitierten Fehlermeldungen.

manilg

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
Re: Fehlermeldung nach du
« Reply #8 on: 2013/12/01, 14:09:15 »
Code: [Select]
$ apt-cache policy vlc vlc:i386

vlc:
  Installiert:           2.1.1-1
  Installationskandidat: 2.1.1-1
  Versionstabelle:
 *** 2.1.1-1 0
        500 http://ftp.debian.org/debian/ unstable/main amd64 Packages
        500 http://debian.siduction.org/ testing/main amd64 Packages
        100 /var/lib/dpkg/status
     2.0.3-5 0
        500 http://debian.siduction.org/ stable/main amd64 Packages
vlc:i386:
  Installiert:           (keine)
  Installationskandidat: 2.1.1-1
  Versionstabelle:
     2.1.1-1 0
        500 http://ftp.debian.org/debian/ unstable/main i386 Packages
        500 http://debian.siduction.org/ testing/main i386 Packages
     2.0.3-5 0
        500 http://debian.siduction.org/ stable/main i386 Packages

Sollte eigentlich™ nicht sein - welchen Spiegel verwendest Du?
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline manilg

  • User
  • Posts: 235
Re: Fehlermeldung nach du
« Reply #9 on: 2013/12/01, 14:45:57 »
Folgende:
Code: [Select]
deb http://packages.siduction.org/user unstable main contrib non-free
deb http://packages.siduction.org/fixes unstable main contrib non-free

deb http://packages.siduction.org/extra unstable main contrib non-free
deb http://packages.siduction.org/kdenext unstable main
deb http://packages.siduction.org/base unstable main contrib non-free
deb http://ftp.de.debian.org/debian/ sid main contrib non-free


"multimedia" ist nicht in der sourcen
Code: [Select]
apt-cache policy vlc vlc:i386
vlc:
  Installiert:           2.1.1-1
  Installationskandidat: 2.1.1-1
  Versionstabelle:
 *** 2.1.1-1 0
        500 http://ftp.de.debian.org/debian/ sid/main i386 Packages
        100 /var/lib/dpkg/status
vlc:
  Installiert:           2.1.1-1
  Installationskandidat: 2.1.1-1
  Versionstabelle:
 *** 2.1.1-1 0
        500 http://ftp.de.debian.org/debian/ sid/main i386 Packages
        100 /var/lib/dpkg/status


manilg

DeKa

  • Guest
Re: Fehlermeldung nach du
« Reply #10 on: 2013/12/01, 15:24:16 »
Zeige mal:
Code: [Select]
apt-cache policy libvlc5
und
Code: [Select]
apt-cache policy libvlccore7

Wenn du die Pakete noch in dem Archiv hast könntest du erst einmal versuchen diese zu konfigurieren.
Code: [Select]
cd /var/cache/apt/archives
dpkg -i libvlccore7.deb libvlc5.deb
apt-get -f install

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
Re: Fehlermeldung nach du
« Reply #11 on: 2013/12/01, 15:35:22 »
ich mag ja blöde sein - aber wo ist das Problem? vlc ist in der aktuellen version in beiden Architekturen installiert. Das Einzige, was mir noch einfällt ist ein apt-get clean, dann apt-get update und danach ein apt-get --reinstall install vlc:i386

Wenn dabei dann Fehler auftauchen, könntest Du die bitte pasten?
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline manilg

  • User
  • Posts: 235
Re: Fehlermeldung nach du
« Reply #12 on: 2013/12/01, 15:43:35 »
@melmarker,
nach apt-get clean, apt-get update
Code: [Select]
apt-get --reinstall install vlc:i386
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
0 aktualisiert, 0 neu installiert, 1 erneut installiert, 0 zu entfernen und 1 nicht aktualisiert.
5 nicht vollständig installiert oder entfernt.
Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.
E: Internal Error, No file name for vlc:i386


@DeKa

Code: [Select]
apt-cache policy libvlc5
libvlc5:
  Installiert:           2.1.1-1
  Installationskandidat: 2.1.1-1
  Versionstabelle:
 *** 2.1.1-1 0
        500 http://ftp.de.debian.org/debian/ sid/main i386 Packages
        100 /var/lib/dpkg/status
$ apt-cache policy libvlccore7
libvlccore7:
  Installiert:           2.1.1-1
  Installationskandidat: 2.1.1-1
  Versionstabelle:
 *** 2.1.1-1 0
        500 http://ftp.de.debian.org/debian/ sid/main i386 Packages
        100 /var/lib/dpkg/status

Quote
cd /var/cache/apt/archives
dpkg -i libvlccore7.deb libvlc5.deb
apt-get -f install

hat nichts verändert

manilg

DeKa

  • Guest
Re: Fehlermeldung nach du
« Reply #13 on: 2013/12/01, 16:17:11 »
Versuche mal ein:
Code: [Select]
dpkg --configure -a
und
Code: [Select]
dpkg-reconfigure vlc:i386

Offline manilg

  • User
  • Posts: 235
Re: Fehlermeldung nach du
« Reply #14 on: 2013/12/01, 16:31:44 »
Code: [Select]
dpkg --configure -a
vlc-data (2.1.1-1) wird eingerichtet ...
rmdir: konnte „/etc/vlc/lua/http/dialogs“ nicht entfernen: Datei oder Verzeichnis nicht gefunden
rmdir: konnte „/etc/vlc/lua/http“ nicht entfernen: Datei oder Verzeichnis nicht gefunden
rmdir: konnte „/etc/vlc/lua“ nicht entfernen: Datei oder Verzeichnis nicht gefunden
dpkg: Fehler beim Bearbeiten von vlc-data (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libvlccore7:
 libvlccore7 hängt ab von vlc-data (= 2.1.1-1); aber:
  Paket vlc-data ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von libvlccore7 (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von vlc:
 vlc hängt ab von libvlccore7 (>= 2.1.0); aber:
  Paket libvlccore7 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von vlc (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libvlc5:
 libvlc5 hängt ab von libvlccore7 (>= 2.1.0); aber:
  Paket libvlccore7 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von libvlc5 (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von vlc-nox:
 vlc-nox hängt ab von libvlc5 (>= 2.1.0); aber:
  Paket libvlc5 ist noch nicht konfiguriert.
 vlc-nox hängt ab von libvlccore7 (>= 2.1.0); aber:
  Paket libvlccore7 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von vlc-nox (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 vlc-data
 libvlccore7
 vlc
 libvlc5
 vlc-nox

Code: [Select]
dpkg-reconfigure vlc:i386
/usr/sbin/dpkg-reconfigure: vlc:i386 ist kaputt oder nicht komplett installiert


manilg