Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: Sound  (Read 3402 times)

mylo

  • Guest
Sound
« on: 2014/01/12, 21:30:08 »
Hallo,

mit dem cli-installer habe ich die aktuelle iso installiert. Sound ist  nicht vorhanden und kann auch nicht via kmix oder alsamixer herausgelockt werden.

Code: [Select]
lsmod | grep snd
snd_hda_codec_hdmi     25441  1
snd_hda_codec_realtek    35020  1
snd_hda_intel          29125  4
snd_hda_codec         110349  3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
snd_hwdep               5381  1 snd_hda_codec
snd_pcm                61945  3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_page_alloc          6130  2 snd_pcm,snd_hda_intel
snd_seq                41741  0
snd_seq_device          4744  1 snd_seq
snd_timer              15356  2 snd_pcm,snd_seq
snd                    50139  17 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_hda_codec,snd_hda_intel,snd_seq_device
soundcore               4378  1 snd
mylo@tuap:~$ cat /proc/asound/cards
 0 [MID            ]: HDA-Intel - HDA Intel MID
                      HDA Intel MID at 0xf7e14000 irq 52
 1 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7e10000 irq 51
mylo@tuap:~$ aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
hdmi:CARD=MID,DEV=0
    HDA Intel MID, HDMI 0
    HDMI Audio Output
default:CARD=PCH
    HDA Intel PCH, ALC887-VD Analog
    Default Audio Device
sysdefault:CARD=PCH
    HDA Intel PCH, ALC887-VD Analog
    Default Audio Device
front:CARD=PCH,DEV=0
    HDA Intel PCH, ALC887-VD Analog
    Front speakers
surround40:CARD=PCH,DEV=0
    HDA Intel PCH, ALC887-VD Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=PCH,DEV=0
    HDA Intel PCH, ALC887-VD Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=PCH,DEV=0
    HDA Intel PCH, ALC887-VD Analog                                                                                                                                                                       
    5.0 Surround output to Front, Center and Rear speakers                                                                                                                                                 
surround51:CARD=PCH,DEV=0                                                                                                                                                                                 
    HDA Intel PCH, ALC887-VD Analog                                                                                                                                                                       
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers                                                                                                                                     
surround71:CARD=PCH,DEV=0                                                                                                                                                                                 
    HDA Intel PCH, ALC887-VD Analog                                                                                                                                                                       
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers                                                                                                                                   
iec958:CARD=PCH,DEV=0                                                                                                                                                                                     
    HDA Intel PCH, ALC887-VD Digital                                                                                                                                                                       
    IEC958 (S/PDIF) Digital Audio Output

What to do?

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.537
Re: Sound
« Reply #1 on: 2014/01/12, 21:48:18 »
echo options snd_hda_intel index=1 > /etc/modprobe.d/mysound.conf

könnte helfen. Danach rebooten.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

mylo

  • Guest
Re: Sound
« Reply #2 on: 2014/01/13, 20:53:53 »
Thanks towo, it did not help. I also tested all the devices listed, but none gave a sound. Other idea where to search?

Offline sunrat

  • User
  • Posts: 405
Re: Sound
« Reply #3 on: 2014/01/14, 06:35:51 »
Both cards use snd-hda-intel so this is tricky. You need to get HDA Intel PCH to be card0.

Try this. Create a file /etc/asound.conf and put this in it:
Code: [Select]
pcm.!default {
   type plug
   slave.pcm {
     @func getenv
     vars [ ALSAPCM ]
     default "hw:HDA Intel PCH"
   }
 }

And if that doesn't work, try adding to /etc/modprobe.d/alsa-base.conf -
Code: [Select]
options snd-hda-intel enable=0,1
Google Translate:
Beide Karten verwenden snd-hda-intel so ist dies schwierig. Sie benötigen den HDA Intel PCH card0 zu sein.

Versuchen Sie dieses. Erstellen Sie eine Datei /etc/asound.conf und legte diese in ihm:
Code: [Select]
pcm.!default {
   type plug
   slave.pcm {
     @func getenv
     vars [ ALSAPCM ]
     default "hw:HDA Intel PCH"
   }
 }


Und wenn das nicht funktioniert, versuchen Sie, die Datei /etc/modprobe.d/alsa-base.conf -
Code: [Select]
options snd-hda-intel enable=0,1

mylo

  • Guest
Re: Sound
« Reply #4 on: 2014/01/16, 06:58:08 »
Hi sunrat, I made a screenshot from the audio devices in the systemsettings (attached). However, I do not have a separate soundcard, just the onboard sound (or at least I did not pay for an extra one). So may be, I can just delete some of the entries in the table?

I'll try your hints and report back later.

Offline sunrat

  • User
  • Posts: 405
Re: Sound
« Reply #5 on: 2014/01/16, 07:11:56 »
Click on the one marked "Default Audio Device" and move it to the top. This was sufficient to get all my audio players working, but not for Flash in Iceweasel. For that I had to edit alsa-base.conf.
The goal is to make the device show as card 0 in aplay -l (that's a small letter "L" ) and cat /proc/asound/cards.

mylo

  • Guest
Re: Sound
« Reply #6 on: 2014/01/16, 07:13:22 »
Hi, both hints did not work. I try the move tonight (office awaits me).
Thanks first!

Offline sunrat

  • User
  • Posts: 405
Re: Sound
« Reply #7 on: 2014/01/16, 11:00:40 »
You do need to reboot after editing the config file.

mylo

  • Guest
Re: Sound -Solved-
« Reply #8 on: 2014/01/16, 23:36:02 »
Hi sunrat,

I rebooted, but could not here anything after.
I started a console, started alsamixer and played around. At first, with no success. Although then, I found an interesting phenomena, which I try to explain here after.

I talk about the first, the third and fourth setting in aösamixer, named

1 - Master
3 - PCM
4 - Front.

I set up Master to a preset below the red one. Nothing.
I tried 3 and 4 the same. Nothing.

Then I set Master to 100% red and had a very very little volume, when opening the volume at the speakers to 100%.

And, and and..at the end:

At the end I found out:

The signal lined out to the speakers is an addition of all three presets on Master, PCI and Front. I set up all short below red and my speaker provides normal volume at normal preset.

Questions to this welcome. Hope this helps other, as alsamixer presets semm to be too low.

sunrat, thanks for leading to a solution!

.
« Last Edit: 2014/01/16, 23:51:38 by mylo »

Offline sunrat

  • User
  • Posts: 405
Re: Sound
« Reply #9 on: 2014/01/17, 01:15:20 »
Good you got it working! :)
I discounted that simple solution as you said you had set volumes in alsamixer in first post. It is usually the first suggestion I would make.