Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] (solved) After system run out of RAM now daily exim warning  (Read 7682 times)

Offline michaa7

  • User
  • Posts: 2.304
Two days ago my system temporarily run out of RAM. After hard resett all was well. Exept, I now get a warning (mail to root, forwarded to user):
Quote
exim paniclog /var/log/exim4/paniclog on lintower.picasso has non-zero size, mail system might be broken. The last 10 lines are quoted below.
 
2014-01-12 19:26:33 daemon: fork of queue-runner process failed: Cannot allocate memory
I assume currently there is no danger anymore as my E-mail system runs as it should. So the question is: Does anybody know how to get rid of this message *without* breaking something. May I simply delete  /var/log/exim4/paniclog? Or do I need to create a zero size file via "touch /var/log/exim4/paniclog" afterwards?
( Aunt Google does not know ;-) )
« Last Edit: 2014/01/17, 18:04:55 by michaa7 »
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline cas

  • User
  • Posts: 401
Re: After system run out of RAM now daily exim warning
« Reply #1 on: 2014/01/16, 00:10:12 »
May I simply delete  /var/log/exim4/paniclog? Or do I need to create a zero size file via "touch /var/log/exim4/paniclog" afterwards?

dont know whether these two alternatives make a difference, but paniclog should always be empty

cf. https://wiki.debian.org/PkgExim4UserFAQ   or
http://www.exim.org/exim-html-current/doc/html/spec_html/ch-log_files.html

otherwise you get mail.
(did you expect to get mail from exim? ;-)

i would simply empty it.

greetings, c

Offline michaa7

  • User
  • Posts: 2.304
Re: After system run out of RAM now daily exim warning
« Reply #2 on: 2014/01/17, 18:04:28 »
...(did you expect to get mail from exim? ;-)
Yes, seriously. Because I foward, as mentioned above, all mails to root to the user. So reciving that warning was inteded. But I want to stop the *daily* warning after noticing it.

By default the paniclog empties itself being logrotated. Which happens when the file amount to 10 MB ;-) .
Now, you may logrotate it manually issuing:
logrotate -f -v /etc/logrotate.d/exim4-paniclog
Unfortunately there *was* a bug preventing logrotate working as expected when called with the "-f" option. But the maintainer responded quickly to my bugrepot and thus logrotes v3.8.7 (debian/incoming) soved the problem
Quote
i would simply empty it.
This would work, but I woudl loose this entry in the log. No big deal, but I wanted to preserve a complete log.
Ok, you can't code, but you still might be able to write a bug report for Debian's sake