Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] [SOLVED] nmbd fails via systemd on boot, samba not working  (Read 7842 times)

bmorency

  • Guest
Hi,

I am using samba to connect to my computer using a  media player and every time I try to connect to a share it will not work unless I manually restart the samba service.

I did a bit a searching on this issue and I found this.

https://bbs.archlinux.org/viewtopic.php?pid=1183853

This is exactly what is happening to me.  In that link it mentions the person filled a bug report about it because he had to manually change a file provided by the package maintaner.

Here is what is in my log file.

Code: [Select]
*****
[2014/05/10 14:22:13,  0] ../source3/nmbd/nmbd.c:57(terminate)
  Got SIGTERM: going down...
[2014/05/10 14:22:13,  0] ../source3/libsmb/nmblib.c:873(send_udp)
  Packet send failed to 10.0.0.255(138) ERRNO=Invalid argument
[2014/05/10 14:22:13,  0] ../source3/libsmb/nmblib.c:873(send_udp)
  Packet send failed to 10.0.0.255(138) ERRNO=Invalid argument
[2014/05/10 11:52:42,  0] ../source3/nmbd/nmbd.c:902(main)
  nmbd version 4.1.7-Debian started.
  Copyright Andrew Tridgell and the Samba Team 1992-2013
[2014/05/10 11:52:42,  0] ../source3/lib/util_sock.c:485(open_socket_in)
  bind failed on port 137 socket_addr = 10.0.0.110.
  Error = Cannot assign requested address
[2014/05/10 11:52:42,  0] ../source3/nmbd/nmbd_subnetdb.c:113(make_subnet)
  nmbd_subnetdb:make_subnet()
    Failed to open nmb socket on interface 10.0.0.110 for port 137.  Error was Cannot assign requested address
[2014/05/10 11:52:42,  0] ../source3/nmbd/nmbd.c:1047(main)
  ERROR: Failed when creating subnet lists. Exiting.
[2014/05/10 21:10:58,  0] ../source3/nmbd/nmbd.c:902(main)
  nmbd version 4.1.7-Debian started.
  Copyright Andrew Tridgell and the Samba Team 1992-2013
[2014/05/10 21:11:21,  0] ../source3/nmbd/nmbd_become_lmb.c:397(become_local_master_stage2)
  *****

Does a bug report need to be reported on this or is there somethng wrong just on my system and I will need to edit the same files mentioned in that link?

I am using amd64. If any one needs more info let me know.

Thank you.

Beau
« Last Edit: 2014/05/19, 23:57:58 by bmorency »

bmorency

  • Guest
Re: nmbd fails via systemd on boot, samba not working
« Reply #1 on: 2014/05/19, 23:57:37 »
I have solved this issue. To fix it I went into the samba config file and I made the interfaces line a comment. After I did that I rebooted and samba was working fine.