Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] neue Gimp Entwicklerversion? (für siduction experimental Repo)  (Read 3089 times)

Offline Lanzi

  • User
  • Posts: 1.781
Eine Frage zu unseren Repos:
Für Windows gibt es ja immer mal wieder neue Builds auf der Homepage von gimp, für Linux nie.
Wir haben in unseren Repo eine 2.91., die soweit ich weiß von 2012 stammt.

Code: [Select]
# apt-cache policy gimp

gimp:
  Installiert:           2.8.10-1
  Installationskandidat: 2.8.10-1
 
Versionstabelle:
     2.9.1-0.siduction.1 0
        100 http://packages.siduction.org/experimental/ unstable/main amd64 Packages
 *** 2.8.10-1 0

        500 http://ftp.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian/ testing/main amd64 Packages

     2.8.10-0.siduction.1 0
        500 http://packages.siduction.org/extra/ unstable/main amd64 Packages


Gibt es Zwischenstände von gimp, die sich lohnen würden, so das unser Packet mal aktualisiert wird?
Wo kann man da schauen?

Towo?


hefee

  • Guest
Es normalerweise immer etwas kniffelig rauszubekommen, ob in einem Projekt was wichtiges abgeschlossen wurde. Meintest muss mensch dazu schon dem primären Diskkusionsmedium folgen, was die Entwickler pflegen (meist eine mailingliste).

Ansonsten lies dir die Seite durch:
http://wiki.gimp.org/wiki/Roadmap

und werf* einen Blick auf die commits, ob da was spannendes hinzugekommen ist:
https://git.gnome.org/browse/gimp/log/

(btw. die Versionen 2.9.X  sind entwickler version - die nächste stabile wird 2.10 sein, deswegen findest du immer nur was von 2.8 und 2.10).


Offline Lanzi

  • User
  • Posts: 1.781
Ich verfolge es immer in Google+ und da ist schon ne Menge hinzugekommen, u.a. ein besseres Morphingtool.
Die Roadmap ist bei gimp zumindest was die Veröffentlichungsdaten angeht eh wertlos, die verschieben viel zu viel, was ja auch sinnvoll ist, solange die Sachen noch buggy sind.

Leider hat sich da bei mir viel Frust angesammelt, denn im Grunde tritt man bei gimp seit 4-5 Jahren auf der Stelle. die 2.8 hat Jahre gedauert und brachte kaum sinnvoll Neues, statt dessen einen neuen rückständigen und unhandlichen Export- und Speicherdialog, der nur Klickorgien hervorruft (wenns geht keine Diskussion darüber, hatten wir vor 2 Jahren schon)
Die Hauptneuerung von 2.8 war, dass jetzt alles vorbereitet war auf 16bit und GEGL.

Wie auch immer, meine letzte Hoffnung ist die 2.10er und bis jetzt lesen sich die Neuerungen ganz gut.

Wäre halt cool, wenn wir mal eine der Unstableversionen testen könnten.



Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.948
Code: [Select]
towo:Defiant> apt-cache policy gimp
gimp:
  Installiert:           2.9.1~git20140624-1.siduction.2
  Installationskandidat: 2.9.1~git20140624-1.siduction.2
  Versionstabelle:
 *** 2.9.1~git20140624-1.siduction.2 0
        100 http://packages.siduction.org/extra/ experimental/main amd64 Packages
        100 /var/lib/dpkg/status
     2.8.10-1 0
        500 http://http.debian.net/debian/ unstable/main amd64 Packages
        500 http://http.debian.net/debian/ testing/main amd64 Packages
     2.8.10-0.siduction.1 0
        500 http://packages.siduction.org/extra/ unstable/main amd64 Packages
     2.8.2-2+deb7u1 0
        500 http://http.debian.net/debian/ stable/main amd64 Packages

Bitteschön.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.373
    • Land of the Buckeye
Very nice -- thanks towo!
System76 Oryx Pro, Intel Core i7-11800H, SSD 970 EVO Plus;  Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO

Offline Lanzi

  • User
  • Posts: 1.781
perfectooooo :-)
Danke Towo.



Offline Lanzi

  • User
  • Posts: 1.781
Habedie gimp manuel runtergeladen und mit dpkg installiert, da eiin apt-get install -t experimental nicht ging.

Beim Start kommt allerdings nun der  Fehler

Code: [Select]
GEGL operation missing!

GIMP requires the GEGL operation "gegl:seamless-clone".
This operation cannot be found. Check your
GEGL install and ensure it has been compiled
with any dependencies required for GIMP.

[/code)

installiert ist eine zu alte version von Gegl. Bevor ich jetzt alles händisch mache, wie kann ich gimp per apt installieren?
in den preferences habe ich siduction-experimental mal 500 gegeben, bringt aber nichts.



Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.948
dpkg -l | grep gegl

sollte dann so aussehen:

Code: [Select]
towo:Defiant> dpkg -l | grep gegl
ii  gegl                                               0.3.0-0.siduction.3               amd64        Generic Graphics Library Test Program
ii  libgegl-0.3-0:amd64                                0.3.0-0.siduction.3               amd64        Generic Graphics Library
ii  libgegl-dev:amd64                                  0.3.0-0.siduction.3               amd64        Generic Graphics Library (development files)
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline hendrikL

  • Administrator
  • User
  • *****
  • Gravatar
  • Posts: 982
moin,

Quote
Bevor ich jetzt alles händisch mache, wie kann ich gimp per apt installieren?

/etc/apt/source.lis.d/xy.list entsprechend anpassen (siehe posting von towo) dann,

Code: [Select]
apt-get update && apt-get install -t experimental gimp/experimental libgimp2.0/experimental gimp-data/experimental
greetz
« Last Edit: 2014/06/26, 14:55:48 by hendrikL »

Offline Lanzi

  • User
  • Posts: 1.781
ja, habe jetzt alles manuell gemacht.
Wollte halt wissen, ob ich per apt das hinkriege.

Läuft jetzt aber.
gimp läuft scheinbar auch stabil und gut


Danke Euch beiden!