Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] Passworteingbe bei Lukspartition unmöglich (emergency mode)  (Read 1755 times)

Offline Lanzi

  • User
  • Posts: 1.781
Seltsames Problem hier:

Habe hier noch einen Rechner als Datengrab, mit vielen alten, kleinen Platten. Diese sind alle mit Luks/dm-crypt verschlüsselt. Ging auch ein Jahr lang ales gut, aber seit einem Du vor ca. 2 Monaten (und nah dem heutigen DU hat sich die Lage eher verschlimmert) habe ich keine Zeit mehr, meinen Passwortsatz einzugeben.

Beim Hochfahren meldet sich die EIngabe, bei der ich dann das Passwort für jede Platte eingeben muss, aber während ich das tue, kommt eine neue Zeile "Welcome to emergency mode! After logging in type ... (siehe Foto), type Control D to continue"

Wenn ich sehr schnell bin schaffe ich es ein, zweilmal das Passwort einzugeben, aber es ist ein Wettrennen. Drücke ich Ctrl-D kommt die nächste Eingabeaufforderung für ein Passwort, dann sofoert wieder die nächste emergency Meldung...

a) warum kommt der emergency mode?
b) wie kann ich verhindern, dass er kommt.

« Last Edit: 2014/09/13, 20:17:48 by Lanzi »

Offline unklarer

  • User
  • Posts: 840
Mit Luks kenne ich mich nicht aus...

Du könntest aber mal das machen, was da steht
Code: [Select]
journalctl -xb dann kannst Du durchscrollen
und der Fehler sollte Dir in der Farbe rot entgegenscheinen.

Der Emergency mode ist meißt ein Hinweis, dass sich im System die UUID von XXX geändert hat.
Es hilft oft auch an die Kernelzeile den Parameter nofail anzuhängen  ;)  um 'reinzukommen und den
Fehler "vor Ort" zu reparieren.

Offline Lanzi

  • User
  • Posts: 1.781
Eine konsoleneingabe ist nicht möglich, da er zwei Buchstaben darstellt und dann immer ein Sternchen kommt, (weil er noch auf Passwörter wartet, was wohl auch urch ein Einloggen nicht verhindert wird)

vertrackte Situation....

Offline Lanzi

  • User
  • Posts: 1.781
so mit viel beharlichhkeit und sehr chnellem tippen habe ich aus dem journal folgende Fehlermeldungen gezogen:

- Dependency failed for local File System
  subject: Unit local-fs.target has failed
  Defined by Systemd

- Dependency failed for Clean up any mess left by 0dns-up


Die option nofail am Ende der Kernelzeile brachte übrigens nichts.