Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] solved: xserver does not start after d-u  (Read 4133 times)

Offline ayla

  • User
  • Posts: 1.744
[EN] solved: xserver does not start after d-u
« on: 2014/11/01, 11:08:21 »
After d-u this morning xserver does not start, not from normal login and not from console with startx command.

Had to use apt-get -f install two times to complete the d-u.

System: amd64, kde, lightdm, intel core i5, hd3000 graphic.

Last d-u was a while ago, it's my laptop and I only update it from time to time.

Messages from journalctl -b -p err:
Quote
tpm-tis 00:05: A TPM error (6) occured attempting to read a pcr value
kvm: disabled by bios

Errors in /var/log/Xorg.0.log:

Quote
Failed to load module "modesetting" (module does not exist)

greets
ayla
« Last Edit: 2014/11/01, 19:20:51 by ayla »

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.844
Re: xserver does not start after d-u
« Reply #1 on: 2014/11/01, 11:39:32 »
Ich habe ein ähnliches Notebook gerade upgedated und es startet normal. Scheint also erstmal ein individuelles Problem zu sein. vielleicht hilft Dir
Code: [Select]
journalctl -xb | grep -i failed weiter.


greetz
devil

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.360
    • Land of the Buckeye
Re: xserver does not start after d-u
« Reply #2 on: 2014/11/01, 13:21:03 »
Does the filesystem have free space?
System76 Oryx Pro, Intel Core i7-11800H, SSD 970 EVO Plus;  Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO

Offline vilde

  • User
  • Posts: 708
Re: xserver does not start after d-u
« Reply #3 on: 2014/11/01, 14:00:55 »
Could it be they same problem I had when uuid on your my (and devils) hard disks was changed by some unknown reason, check if the uuid:s are correct in fstab.

mimir

  • Guest
Re: xserver does not start after d-u
« Reply #4 on: 2014/11/01, 15:50:09 »
http://pastebin.com/kwdDs62z

Here is the error output of journalctl

mimir

  • Guest
Re: xserver does not start after d-u
« Reply #5 on: 2014/11/01, 16:06:31 »
http://pastebin.com/kwdDs62z

Here is the error output of journalctl
suggesting from output rebuilding nvidia module fixes my issue.

Offline ayla

  • User
  • Posts: 1.744
Re: xserver does not start after d-u
« Reply #6 on: 2014/11/01, 18:09:32 »
@devil:
besides "disabling ASPM" and "Sap driver initialization failed" I have a message "failed to get i915 symbols, graphics turbo disabled", so it's pointing to the intel driver. Will try to download and reinstall it, which is a little difficult because my network is causing problems also. Will have to dig in deeper.

@dibl: no problem with freespace, 4,9 GB free.

@ vilde: no problem with uuids

@mimir: no problem with lightdm so far

@ mods: as it seems to be an indiviual problem maybe someone likes to move it to software?

Thanks and greets
ayla

EDIT: Strange, cant get vesa to work either, using it with a xorg.conf  lightdm failes...

EDIT2:

After checking /var/log/apt/history.log:

apt-get -f install had removed my kde...

Code: [Select]
root@neskayamobil:~ #root: apt-get install plasma-widgets-addons ksysguard kde-plasma-desktop siduction-settings-kde-december kdebase-workspace kde-l10n-de
brought all back...
« Last Edit: 2014/11/01, 19:25:29 by ayla »