Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] 2 Computer mit Netzwerkabel verbinden  (Read 8996 times)

Offline unklarer

  • User
  • Posts: 821
[EN] Re: 2 Computer mit Netzwerkabel verbinden
« Reply #15 on: 2014/12/21, 13:07:29 »
Wenn das  also so ist...

michaa7
hat oben bereits einmal darauf aufmerksam gemacht. Kannst Du denn nicht die Terminalausgabe
Code: [Select]
$ ssh manllg@192.168.178.29(natürlich zu Deinen Laptop!)
hier posten?

Offline manilg

  • User
  • Posts: 235
Re: 2 Computer mit Netzwerkabel verbinden
« Reply #16 on: 2014/12/21, 14:47:18 »
vom pc zum Laptop

Code: [Select]
ssh siducer@192.168.178.42
siducer@192.168.178.42's password:
Permission denied, please try again.
siducer@192.168.178.42's password:
Permission denied, please try again.
siducer@192.168.178.42's password:
Permission denied (publickey,password).


Das Passwort ist sicher richtig eingegeben. Umgekehrt ist kein Problem

manilg

Offline michaa7

  • User
  • Posts: 2.302
Re: 2 Computer mit Netzwerkabel verbinden
« Reply #17 on: 2014/12/21, 15:43:28 »
mach das ganze mal mit der "-v" option (=verbose, gesprächig) , also "ssh -v siducer@192.168.178.42" , und ist überhaupt "PasswordAuthentication yes" in der config des 192.168.178.42-rechners gesetzt?
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Online ReinerS

  • User
  • Posts: 1.061
Re: 2 Computer mit Netzwerkabel verbinden
« Reply #18 on: 2014/12/21, 15:45:59 »
Kann es vielleicht auch daran liegen dass ssh-askpass nicht auf dem Stick mit drauf ist ? Bei mir ist es jedenfalls auf dem PC mit drauf.
Bei der Installation hatte ich auch start ssh mit angegeben, da werden wohl die entsprechenden Pakete installiert/konfiguriert.

Grüße

Reiner
slackware => SuSE => kanotix => sidux => aptosid  => siduction

Offline manilg

  • User
  • Posts: 235
Re: 2 Computer mit Netzwerkabel verbinden
« Reply #19 on: 2014/12/21, 15:52:05 »
Code: [Select]
ssh -v siducer@192.168.178.42
OpenSSH_6.7p1 Debian-3, OpenSSL 1.0.1j 15 Oct 2014
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to 192.168.178.42 [192.168.178.42] port 22.
debug1: Connection established.
debug1: permanently_set_uid: 0/0
debug1: key_load_public: No such file or directory
debug1: identity file /root/.ssh/id_rsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /root/.ssh/id_rsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /root/.ssh/id_dsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /root/.ssh/id_dsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /root/.ssh/id_ecdsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /root/.ssh/id_ecdsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /root/.ssh/id_ed25519 type -1
debug1: key_load_public: No such file or directory
debug1: identity file /root/.ssh/id_ed25519-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.7p1 Debian-3
debug1: Remote protocol version 2.0, remote software version OpenSSH_6.7p1 Debian-3
debug1: match: OpenSSH_6.7p1 Debian-3 pat OpenSSH* compat 0x04000000
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr umac-64-etm@openssh.com none
debug1: kex: client->server aes128-ctr umac-64-etm@openssh.com none
debug1: sending SSH2_MSG_KEX_ECDH_INIT
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ECDSA 44:71:47:d6:44:07:a6:71:69:9d:79:76:50:bd:9a:d4
debug1: Host '192.168.178.42' is known and matches the ECDSA host key.
debug1: Found key in /root/.ssh/known_hosts:1
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Trying private key: /root/.ssh/id_rsa
debug1: Trying private key: /root/.ssh/id_dsa
debug1: Trying private key: /root/.ssh/id_ecdsa
debug1: Trying private key: /root/.ssh/id_ed25519
debug1: Next authentication method: password
siducer@192.168.178.42's password:
debug1: Authentications that can continue: publickey,password
Permission denied, please try again.
siducer@192.168.178.42's password:
debug1: Authentications that can continue: publickey,password
Permission denied, please try again.
siducer@192.168.178.42's password:
debug1: Authentications that can continue: publickey,password
debug1: No more authentication methods to try.
Permission denied (publickey,password).

und ja

manilg

Offline manilg

  • User
  • Posts: 235
Re: 2 Computer mit Netzwerkabel verbinden
« Reply #20 on: 2014/12/21, 16:02:23 »
@ReinerS

Du hast recht, ssh-askpass war nicht installiert, habe ich nachgeholt und ssh neu gestartet. Aber keine Änderung.

manilg

Offline michaa7

  • User
  • Posts: 2.302
Re: 2 Computer mit Netzwerkabel verbinden
« Reply #21 on: 2014/12/21, 16:42:15 »
So schaut meine funktionierende sshd_config aus (port ausgeXXt):
Quote
$ cat /etc/ssh/sshd_config
# Package generated configuration file
# See the sshd_config(5) manpage for details

# What ports, IPs and protocols we listen for
Port XX
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
HostKey /etc/ssh/ssh_host_ecdsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 1024

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin no
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile     %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
#PasswordAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes

Das schaut danach aus dass #PasswordAuthentication yes wohl auskommentiert ist und die authentifizierung über PAM läuft (mir ist der unterschied nicht klar, ich verstehe das jedoch so, das das in einem fall ein expliziter ssh-user ist, im andern fall ein normaler user account ist, bin aber nicht sicher).

BTW, man kann die beiden configfiles ssh_config und sshd_config leicht verwechseln.

Eigentlich sollte im output nach der letzten von dir geposteten zeile "Permission denied (publickey,password)." das folgende stehen: "siducer@192.168.178.42's password:" . Was ist eigentlich das übliche siducer PW?

Ich würde auch mal die sshd_config_s der beiden beteiligten rechner vergleichen, wo da unterschiede liegen.
« Last Edit: 2014/12/21, 17:07:10 by michaa7 »
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline unklarer

  • User
  • Posts: 821
Re: 2 Computer mit Netzwerkabel verbinden
« Reply #22 on: 2014/12/21, 17:12:25 »
Für mich sieht das danach aus, dass mit root bereits einmal ein Verbindungsversuch gemacht wurde und demzufolge
bereits ein Schlüssel <FÜR ROOT> vorhanden ist

Code: [Select]
...
debug1: Server host key: ECDSA 44:71:47:d6:44:07:a6:71:69:9d:79:76:50:bd:9a:d4
debug1: Host '192.168.178.42' is known and matches the ECDSA host key.
debug1: Found key in /root/.ssh/known_hosts:1
...


Ich würde da jetzt als root diesen vorhandenen Schlüssel löschen
Code: [Select]
ssh-keygen -R hostname | ip

und dann das nochmal als USER machen.   ;)

Offline manilg

  • User
  • Posts: 235
Re: 2 Computer mit Netzwerkabel verbinden
« Reply #23 on: 2014/12/21, 20:36:17 »
@unklarer
 
das hat nichts geändert

@micha

das Passwort heist live; ich hab es auch schon mal probehalber geändert, das hat auch nicht gebracht.

manilg

Offline michaa7

  • User
  • Posts: 2.302
Re: 2 Computer mit Netzwerkabel verbinden
« Reply #24 on: 2014/12/22, 00:58:42 »
und hast du die sshd_config_s mal verglichen?
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline unklarer

  • User
  • Posts: 821
Re: 2 Computer mit Netzwerkabel verbinden
« Reply #25 on: 2014/12/22, 14:34:05 »
Quote from: manilg
@unklarer
 das hat nichts geändert

@micha
das Passwort heist live; ich hab es auch schon mal probehalber geändert, das hat auch nicht gebracht.
Begeisterung sieht irgendwie anders aus...

Kann es sein, Du benutzt die Live-ISO von dem Stick?
Quote
...
Den Laptop muss ich mit siduction-Stick starten.
Und, einen(mehrere) reboot hattest Du selbstverständlich nicht gemacht, weil Dir schon klar ist, die ISO ist nicht persistent.
Dauf verweisen ja auch die Macher.   :D


Gut, auch 88.
Im Faden schreibst Du irgendwo:
Quote
Das Passwort ist sicher richtig eingegeben. Umgekehrt ist kein Problem
Wenn es umgekehrt kein Problem ist, na, da mach' es doch und kopiere vom Laptop zum Desk mit scp oder was weiß ich,
der Möglichkeiten gibt es viele.   ;)

http://www.mpipks-dresden.mpg.de/~mueller/docs/suse10.3/opensuse-manual_de/manual/sec.filetrans.copy.html

Offline manilg

  • User
  • Posts: 235
Re: 2 Computer mit Netzwerkabel verbinden
« Reply #26 on: 2014/12/22, 15:25:43 »
@
unklarer,

das habe ich auch schon gemacht, insofern ist mein Problem gelöst.Ich dachte nur es ginge auch um eine grundsätzliche Lösung.

im Übringen

:siducer@siduction:~$ diff -q sshd_configlptop sshd_configpc
siducer@siduction:~$

manilg







Online ReinerS

  • User
  • Posts: 1.061
Re: 2 Computer mit Netzwerkabel verbinden
« Reply #27 on: 2014/12/22, 19:31:30 »
Tja eine grundsätzlich Lösung wäre zu begrüßen da es durchaus passieren kann dass man Verbindungen zwischen zwei Geräten per Live-DVDs/Sticks aufbauen möchte.
Ich meine mich erinnern zu können dass das (viel) früher ging.

Grüße

Reiner
slackware => SuSE => kanotix => sidux => aptosid  => siduction

walloac

  • Guest
Re: 2 Computer mit Netzwerkabel verbinden
« Reply #28 on: 2014/12/22, 19:43:55 »
Hallo,

als Notlösung wäre sicher ein Nullmodem wie auf "https://de.wikipedia.org/wiki/Nullmodem-Kabel" beschrieben.
Frohe Weihnachten an alle.

Groetjes

WalloAC

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.941
Re: 2 Computer mit Netzwerkabel verbinden
« Reply #29 on: 2014/12/22, 20:56:51 »

Quote
als Notlösung wäre sicher ein Nullmodem wie auf "https://de.wikipedia.org/wiki/Nullmodem-Kabel" beschrieben.
Bist ein Spaßvogel, oder?
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.