Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: WLAN RealtekRT8723BE  (Read 2278 times)

Offline H-Cl

  • User
  • Posts: 138
WLAN RealtekRT8723BE
« on: 2015/05/09, 17:44:33 »
Hallo zusammen

wie bekomme ich eine WLAN-Karte mit diesem Chip ans laufen.
firmware-realtek ist installiert, der Chip wird laut Beschreibung auch unterstützt.

Gruß

H-Cl
Dignus est intrare (Acidix Hydrochloridix)

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
Re: WLAN RealtekRT8723BE
« Reply #1 on: 2015/05/09, 18:28:30 »
schau mal ins firmware-verzeichnis nach passenden blobs - eventuell habe ich die falsch benannt
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.533
Re: WLAN RealtekRT8723BE
« Reply #2 on: 2015/05/09, 18:35:52 »
Mann könnte auch einfach ins Log gucken, was das System denn so zum Chipsatz spricht.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline H-Cl

  • User
  • Posts: 138
Re: WLAN RealtekRT8723BE
« Reply #3 on: 2015/05/09, 19:54:40 »
Wenn ich das richtig verstehe wird Wifi aus irgendeinem Grund deaktiviert.
Abgesehen von einem Hotkey für den Flugmodus finde ich aber weder am Gerät (Lenovo Yoga 2 13) noch im Handbuch eine Taste über die Wlan deaktiviert werden kann.

Im Netzwerkmanager wird Wifi als deaktiviert angezeigt und die Checkbox ist ausgegraut, also nicht bedienbar. Der Flugzeugmodus kann ein- und ausgeschaltet werden (allerdings nicht über den Hotkey).

Hier die Log-Einträge, die WLAN betreffen

Code: [Select]
19:21:27 kernel: rtl8723be: Using firmware rtlwifi/rtl8723befw.bin
19:21:27 kernel: ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
19:21:27 kernel: rtlwifi: rtlwifi: wireless switch is on

19:21:30 NetworkManager[851]: <info>  devices added (path: /sys/devices/pci0000:00/0000:00:1c.0/0000:01:00.0/net/wlan0, iface: wlan0)
19:21:30 NetworkManager[851]: <info>  device added (path: /sys/devices/pci0000:00/0000:00:1c.0/0000:01:00.0/net/wlan0, iface: wlan0): no ifupdown configuration found.

19:21:30 NetworkManager[851]: <info>  Loaded plugin ifupdown: (C) 2008 Canonical Ltd.  To report bugs please use the NetworkManager mailing list.
19:21:30 NetworkManager[851]: <info>  Loaded plugin keyfile: (c) 2007 - 2015 Red Hat, Inc.  To report bugs please use the NetworkManager mailing list.
19:21:30 NetworkManager[851]: <info>  (268455552) ... get_connections.
19:21:30 NetworkManager[851]: <info>  (268455552) ... get_connections (managed=false): return empty list.
19:21:30 NetworkManager[851]: <info>  get unmanaged devices count: 0
19:21:30 NetworkManager[851]: <info>  monitoring kernel firmware directory '/lib/firmware'.
19:21:30 NetworkManager[851]: <info>  monitoring ifupdown state file '/run/network/ifstate'.

19:21:30 NetworkManager[851]: <info>  rfkill3: found WiFi radio killswitch (at /sys/devices/pci0000:00/0000:00:1c.0/0000:01:00.0/ieee80211/phy0/rfkill3) (driver rtl8723be)
19:21:30 NetworkManager[851]: <info>  rfkill0: found WiFi radio killswitch (at /sys/devices/pci0000:00/0000:00:1f.0/PNP0C09:00/VPC2004:00/rfkill/rfkill0) (platform driver ideapad_acpi)
19:21:30 NetworkManager[851]: <info>  WiFi hardware radio set disabled
19:21:30 NetworkManager[851]: <info>  WWAN hardware radio set enabled

19:21:30 NetworkManager[851]: <info>  Loaded device plugin: /usr/lib/x86_64-linux-gnu/NetworkManager/libnm-device-plugin-bluetooth.so
19:21:30 NetworkManager[851]: <info>  Loaded device plugin: /usr/lib/x86_64-linux-gnu/NetworkManager/libnm-device-plugin-wwan.so
19:21:30 NetworkManager[851]: <info>  Loaded device plugin: /usr/lib/x86_64-linux-gnu/NetworkManager/libnm-device-plugin-wifi.so
19:21:30 NetworkManager[851]: <info>  Loaded device plugin: /usr/lib/x86_64-linux-gnu/NetworkManager/libnm-device-plugin-adsl.so
19:21:30 NetworkManager[851]: <info>  Loaded device plugin: /usr/lib/x86_64-linux-gnu/NetworkManager/libnm-device-plugin-team.so
19:21:30 NetworkManager[851]: <info>  WiFi disabled by radio killswitch; disabled by state file
19:21:30 NetworkManager[851]: <info>  WWAN enabled by radio killswitch; enabled by state file

19:21:30 NetworkManager[851]: <info>  WiMAX enabled by radio killswitch; enabled by state file
19:21:30 NetworkManager[851]: <info>  Networking is enabled by state file
19:21:30 NetworkManager[851]: <info>  (lo): link connected
19:21:30 NetworkManager[851]: <info>  (lo): carrier is ON
19:21:30 NetworkManager[851]: <info>  (lo): new Generic device (driver: 'unknown' ifindex: 1)
19:21:30 NetworkManager[851]: <info>  (lo): exported as /org/freedesktop/NetworkManager/Devices/0
19:21:30 NetworkManager[851]: <info>  (wlan0): using nl80211 for WiFi device control
19:21:30 NetworkManager[851]: <info>  (wlan0): driver supports Access Point (AP) mode
19:21:30 NetworkManager[851]: <info>  (wlan0): new 802.11 WiFi device (driver: 'rtl8723be' ifindex: 2)
19:21:30 NetworkManager[851]: <info>  (wlan0): exported as /org/freedesktop/NetworkManager/Devices/1
19:21:30 NetworkManager[851]: <info>  (wlan0): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
19:21:30 NetworkManager[851]: <info>  (wlan0): preparing device
19:21:30 NetworkManager[851]: <info>  (eth0): carrier is OFF
19:21:30 NetworkManager[851]: <info>  (eth0): new Ethernet device (driver: 'r8152' ifindex: 3)
19:21:30 NetworkManager[851]: <info>  (eth0): exported as /org/freedesktop/NetworkManager/Devices/2
19:21:30 NetworkManager[851]: <info>  (eth0): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
19:21:30 systemd-logind[858]: New seat seat0.



Ergänzung:

Code: [Select]
rfkill list
0: ideapad_wlan: Wireless LAN
        Soft blocked: no
        Hard blocked: yes
1: ideapad_bluetooth: Bluetooth
        Soft blocked: no
        Hard blocked: yes
2: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
3: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

Das passt ja zum Log, ich kann aber beim besten Willen keinen Schalter finden

Ergänzung 2:

Durch den Flugmodusschalter kann "Soft blocked" getoggelt werden, Hard blocked bleibt aber immer an.
Und falls die Frage kommt, WLAN ist im BIOS aktiviert und unter Win funktioniert es auch.

« Last Edit: 2015/05/09, 20:31:10 by H-Cl »
Dignus est intrare (Acidix Hydrochloridix)

Offline H-Cl

  • User
  • Posts: 138
Re: WLAN RealtekRT8723BE
« Reply #4 on: 2015/05/13, 23:31:43 »
Ich habe etwas gefunden, weiß aber nich so recht, wie ich das unter siduction umsetzen soll. Kann mich da jemand vielleicht unterstützen?

http://billauer.co.il/blog/2014/08/linux-ubuntu-yoga-hardware-blocked-wireless-lan/


Gruß

H-Cl
Dignus est intrare (Acidix Hydrochloridix)