Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] [SOLVED] smplayer. problem with åäö in subtitles, and a question  (Read 1958 times)

Offline vilde

  • User
  • Posts: 708
I have problem with smplayer not showing the Swedish native letters å ä ö right, in the subtitles. I did install smplayer-l10n but that didn't help.

And, why is not smplayer on the new release (xfce)?
« Last Edit: 2016/01/15, 15:43:44 by vilde »

holgerw

  • Guest
Re: smplayer. problem with åäö in subtitles, and a question
« Reply #1 on: 2016/01/15, 14:28:47 »
Hello @vilde,

do you play local stuff with smplayer or do you play stuff from nfs/cifs shares?

At home we play multimedia stuff from nfs share of a Debian NAS, I've had trouble with german äöü under a fresh installed FreeBSD system, because of different locale settings (de-utf8 under Debian NAS, de-iso ... under FreeBSD).  After switching FreeBSD locale to de-utf8 trouble has gone.

Quote
And, why is not smplayer on the new release (xfce)?

Maybe Torsten will integrate smplayer in the final release.

Kind regards,
  Holger
« Last Edit: 2016/01/15, 14:40:34 by holgerw »

Offline vilde

  • User
  • Posts: 708
Re: smplayer. problem with åäö in subtitles, and a question
« Reply #2 on: 2016/01/15, 15:22:48 »
I play movies from hd or usb hd.

I have sv_SE.UTF-8

and in vlc it works, I can use vlc but I would prefer smplayer, one reason is that smplayer handles the sound better on my system.

Offline vilde

  • User
  • Posts: 708
Re: smplayer. problem with åäö in subtitles, and a question
« Reply #3 on: 2016/01/15, 15:42:55 »
I manage to solve it by changing the settings in smplayer.

Settings-Subtitles-Default subtitle encoding: was set to West European Language I(SO-8859-1). I did change that to UTF-8 (UTF-8)  and after that smplayer shows my åäö.

Thank you holgerw for putting me on the right direction.