Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] [solved]Plasmashell (panel aka Kontrolleiste) freezes every few minutes  (Read 14789 times)

Offline finotti

  • User
  • Posts: 272
Thanks piper.  I will try that.  But I am confused: purging xserver-xorg-video-intel won't break X, as I am using intel driver?

Offline piper

  • User
  • Posts: 1.785
  • we are the priests ... of the temples of syrinx
If it don't boot, just reinstall xserver-xorg-video-intel

You can also try a 4.7.0-x series kernel if removing xserver-xorg-video-intel don't work
« Last Edit: 2017/01/02, 18:29:01 by piper »
Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Offline finotti

  • User
  • Posts: 272
OK, removing  xserver-xorg-video-intel I cannot start X.  Just removing the other packages had no effect...  Still freezes.  I will try an older kernel later.

Thanks for your help,

Luis

Offline piper

  • User
  • Posts: 1.785
  • we are the priests ... of the temples of syrinx
Thanks for the feedback.

 I didn't think removing xserver-xorg-video-intel would work, why I edited my post to the earlier kernel, it worked for some people with the intel video (kernel)

You could try this also before a different kernel

In  /etc/X11/xorg.conf.d/20-intel.conf   

Make it look like

Code: [Select]
Section "Device"
Identifier "Intel Graphics"
Driver "intel"
Option "DRI" "3"
EndSection

reboot
Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Offline whistler_mb

  • User
  • Posts: 198
4 month ago I removed the intel-video-driver. Since that, I have no more problems with short freezes.
Code: [Select]
$ inxi -CG
CPU:       Quad core Intel Core i7-4702MQ (-HT-MCP-) cache: 6144 KB
           clock speeds: max: 3200 MHz 1: 2201 MHz 2: 2213 MHz 3: 2213 MHz 4: 2220 MHz 5: 2200 MHz 6: 2200 MHz
           7: 2265 MHz 8: 2201 MHz
Graphics:  Card-1: Intel 4th Gen Core Processor Integrated Graphics Controller
           Card-2: NVIDIA GK106M [GeForce GTX 765M]
           Display Server: X.Org 1.19.0 drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
           GLX Renderer: Mesa DRI Intel Haswell Mobile GLX Version: 3.0 Mesa 13.0.2

Offline wodga

  • User
  • Posts: 191
I now solved the problem by simply installing the nvidia-driver instead of nouveau!
64bit, intel i5, GeForce GTX 650 Ti

Offline cliff6056

  • User
  • Posts: 21
Just as follow-up, I removed as per Piper's post, and as well installed nvidia-legacy-340xx-driver, and have not had a freeze for 24 hours. 

Thanks Piper. 

Offline finotti

  • User
  • Posts: 272
Thanks for the feedback.

 I didn't think removing xserver-xorg-video-intel would work, why I edited my post to the earlier kernel, it worked for some people with the intel video (kernel)

You could try this also before a different kernel

In  /etc/X11/xorg.conf.d/20-intel.conf   

Make it look like

Code: [Select]
Section "Device"
Identifier "Intel Graphics"
Driver "intel"
Option "DRI" "3"
EndSection

reboot

@piper: It seems that, indeed, adding
Code: [Select]
Option "DRI" "3"
fixed the problem.  I want to be a bit cautious here, as I had this bug seem to go away before and come back, but it has been a few days without problems.  Thanks for your help!

Offline piper

  • User
  • Posts: 1.785
  • we are the priests ... of the temples of syrinx
Nothing wrong with being cautious, I myself keep waiting for the lockup, so far so good.

Glad to be of assistance ;)
Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Offline glimfindel

  • User
  • Posts: 6
Thanks, piper, I adopted your suggestion for  my nouveau driven desktop by creating the file

/etc/X11/xorg.conf.d/20-xorg-nouveau.conf
-----------------------------------------------------
Section "Device"
        Option     "DRI"  "3"
        Identifier  "Nvidia Card"
        Driver      "nouveau"
        BusID       "PCI:1:0:0"
EndSection
-----------------------------------------------------

I did not recognize a freese for several hours now and I hope that this might be the (temporary) solution to get rid of that bug (although the BusID may be omitted).

Comparing the /var/log/Xorg.0.log, I now see the entries makred with "(**)" since now they are coming from the configuration file:

[  2407.593] (**) NOUVEAU(0): Option "DRI" "3"
...
[  2407.593] (**) NOUVEAU(0): Allowed maximum DRI level 3.

Before that change I saw that only DRI-Level 2 has been used by default:
[ 26931.919] (==) NOUVEAU(0): Allowed maximum DRI level 2.

So this works form me.

Offline piper

  • User
  • Posts: 1.785
  • we are the priests ... of the temples of syrinx
glimfindel

Thanks for the feedback.

I actually never thought of doing that outside of intel (which I don't own) and this was in my notes and where it was in my notes makes it kinda old(ish) and most likely got the info from a google search somewhere down the line :)

I will do some testing with this using

xserver-xorg-video-ati / xserver-xorg-video-radeon


Thanks to all who tried/tested and gave feedback, hopefully this helps others :)
« Last Edit: 2017/01/07, 16:47:36 by piper »
Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Offline bevo

  • User
  • Posts: 319
Quote

I will do some testing with this using

xserver-xorg-video-ati / xserver-xorg-video-radeon


Thanks Piper that works for me

bevo

Offline samoht

  • User
  • Posts: 478
Hi all,

upstream pretends that this annoying bug should be fixed:

https://bugs.freedesktop.org/show_bug.cgi?id=99333#c4
https://bugs.freedesktop.org/attachment.cgi?id=128844

Code: [Select]

xorg-server (2:1.19.1-1) unstable; urgency=medium
...
[ Andreas Boll ]
  * New upstream release.
    - AttendClient of grab-pervious client must queue to
      saved_ready_clients [v2] (Closes: #846779, #850940).
    - present: Only call present_flip_notify if vblank->queued == FALSE
      (Closes: #849250).
...

Greetings,
Tom
« Last Edit: 2017/01/19, 14:54:43 by samoht »

Offline glimfindel

  • User
  • Posts: 6
I just got the update for xserver-xorg-core 1.19.1-4 by a d-u, and noticed that bug above mentioned in the changelog:

/usr/share/doc/xserver-xorg-core/changelog.gz:
----------------------------------------------------------------------
...
commit 82dcb68a8782d0cce6e6ce1a375cda05c91fe8c3
Author: Keith Packard <keithp@keithp.com>
Date:   Mon Jan 9 18:10:21 2017 -0800

    AttendClient of grab-pervious client must queue to saved_ready_clients [v2]
   
    A client which is attended while a grab is blocking execution of its
    requests needs to be placed in the saved_ready_clients list so that it
    will get scheduled once the grab terminates. Otherwise, if the client
    never sends another request, there is no way for it to be placed in
    the ready_clients list.
   
    v2: Wrap comment above mark_client_saved_ready.
        Remove test for OS_COMM_IGNORED which will always be true.
   
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=99333
    Reviewed-by: Adam Jackson <ajax@redhat.com>
    Signed-off-by: Keith Packard <keithp@keithp.com>
    (cherry picked from commit 785053d033e73d2deb0ded4b97eabfd881991978)
...
-----------------------------------------------------------------

I did not see any freese, although I removed the workaround (DRI Level = 3).
so please have a try.