Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: noveau+KDE5 with GeForce Curie vs Quadro Fermi  (Read 1589 times)

Offline jaegermeister

  • User
  • Posts: 222
noveau+KDE5 with GeForce Curie vs Quadro Fermi
« on: 2017/03/03, 15:44:44 »

this is just a field report. I tried an install on an ASrock 4CoreN73PV-HD720p motherboard, which sports onboard a GeForce 6250 with shared memory. This installation is meant to work on a sony trinitron professional CRT screen commercially rebranded as IBM P275 with 1600x1200@85Hz.

Livecd: strange triangles and shapes drawn on plasma desktop, sometimes desktop hangs, resolution ok.
Installed: at the end of boot, after splash screen finishes, plasma desktop does not show panel and then also background disappears, leaving a useless mouse pointer around, which does no action, resolution ok.

I therefore installed a GeForce 7300GT on pcie16 bus, resulting with exact same problems.

Putting in place of the 7300GT a Quadro 2000 card solved all problems.

Clearly, although at https://nouveau.freedesktop.org/wiki/FeatureMatrix/ it looks like that Curie family (NV40) should be ready for production, only Fermi family (NVC0) filled up the bill.

This happened only when combining noveau with plasma on siduction, as other distros I tested, like partedmagic, correctly visualized desktops at 1600x1200@85Hz with noveau BUT without plasma on the Curie cards.

This leads me to think that, more than a bug within noveau, it's something that has to do in the way plasma interacts with noveau on certain hardware.

Hope this helps some progress.




  • Guest
Re: noveau+KDE5 with GeForce Curie vs Quadro Fermi
« Reply #1 on: 2017/03/28, 18:29:13 »
had the same issue with this configuration:
Code: [Select]
System:    Host: siduction Kernel: 4.10.1-towo.1-siduction-amd64 x86_64 (64 bit gcc: 6.3.0)
            Desktop: KDE Plasma 5.8.4 (Qt 5.7.1)
            Distro: siduction 17.1.0 Patience - kde - (201703051755)
 Machine:   Device: desktop System: Hewlett-Packard product: HP Compaq dc7900 Convertible Minitower
            Mobo: Hewlett-Packard model: 3032h
            BIOS: Hewlett-Packard v: 786G1 v01.16 date: 03/05/2009
 CPU:       Dual core Intel Core2 Duo E8400 (-MCP-) cache: 6144 KB
            flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) bmips: 11974
            clock speeds: max: 3000 MHz 1: 1998 MHz 2: 1998 MHz
 Memory:    Using dmidecode: you must be root to run dmidecode
 Graphics:  Card: NVIDIA G73 [GeForce 7600 GS] bus-ID: 20:00.0
            Display Server: X.Org 1.19.2 drivers: nouveau (unloaded: modesetting,fbdev,vesa)
            Resolution: 1920x1080@60.00hz
            GLX Renderer: Gallium 0.4 on NV4B
            GLX Version: 2.1 Mesa 13.0.5 Direct Rendering: Yes
 Audio:     Card Intel 82801JD/DO (ICH10 Family) HD Audio Controller
            driver: snd_hda_intel bus-ID: 00:1b.0
            Sound: Advanced Linux Sound Architecture v: k4.10.1-towo.1-siduction-amd64
 Network:   Card: Intel 82567LM-3 Gigabit Network Connection
trying to install with calamares it stopped after order to install with something
like a segmentation fault in nouveau.
changed to radeon and then everything worked fine.
greets, timo