Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] GELÖST // KDE5-Problem:Lange Pause zwischen Login und Erscheinen des KDE-Desktop  (Read 12261 times)

Offline cs

  • User
  • Posts: 94
@dsat: Das Update von gerade eben hat die Verzögerung leider nicht vermindert.

@der_Bud: LIRC (d.h. Infrarotfernbedienungen) nutze ich gar nicht. Kann man das irgendwie abschalten?

Die Partitionen habe ich ja seit dem Update auf KDE5 nicht verändert und vorher gab's diese Verzögerungen nicht. Dann wär's seltsam, wenn es an den Labels liegen würde, oder?

Hier die Ausgabe von systemctl status lightdm.service

● lightdm.service - Light Display Manager
   Loaded: loaded (/lib/systemd/system/lightdm.service; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2017-09-18 14:43:35 CEST; 3min 32s ago
     Docs: man:lightdm(1)
  Process: 768 ExecStartPre=/bin/sh -c [ "$(cat /etc/X11/default-display-manager 2>/dev/null)" = "/usr/sbin/lightdm" ] (code=exited, status=0/SUCCESS)
 Main PID: 771 (lightdm)
   CGroup: /system.slice/lightdm.service
           ├─771 /usr/sbin/lightdm
           └─786 /usr/lib/xorg/Xorg :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch

Sep 18 14:43:35 cord-x230 systemd[1]: Starting Light Display Manager...
Sep 18 14:43:35 cord-x230 systemd[1]: Started Light Display Manager.
Sep 18 14:43:37 cord-x230 lightdm[771]: user_get_uid: assertion 'user != NULL' failed
Sep 18 14:43:37 cord-x230 lightdm[2216]: pam_unix(lightdm-greeter:session): session opened for user lightdm by (uid=0)
Sep 18 14:45:00 cord-x230 lightdm[7726]: pam_unix(lightdm:session): session opened for user cord by (uid=0)


Offline piper

  • User
  • Posts: 1.785
  • we are the priests ... of the temples of syrinx
I have this problem also,(which was also posted here  https://forum.siduction.org/index.php?topic=6826.msg55567#msg55567)  this is experimental, I have a regular debian install (experimental also) with the same exact packages installed, but, no lag/wait time to login.

I have purged mythtv, mariadb, masked network-manager.wait-online.service,  etc, to no avail.

I am going to make a new build and start from scratch, not today, I had a long day at work and I am cranky and tired ;)

systemctl status sddm.service

Code: [Select]
● sddm.service - Simple Desktop Display Manager
   Loaded: loaded (/lib/systemd/system/sddm.service; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2017-09-18 09:32:15 EDT; 30min ago
     Docs: man:sddm(1)
           man:sddm.conf(5)
 Main PID: 800 (sddm)
   CGroup: /system.slice/sddm.service
           ├─800 /usr/bin/sddm
           └─969 /usr/lib/xorg/Xorg -nolisten tcp -auth /var/run/sddm/{051198af-358a-4fe6-88f5-716f1dd1863f} -background none -noreset -displa

Sep 18 09:32:15 x1 systemd[1]: Starting Simple Desktop Display Manager...
Sep 18 09:32:15 x1 systemd[1]: Started Simple Desktop Display Manager.
Sep 18 09:32:28 x1 sddm-helper[1181]: pam_unix(sddm-greeter:session): session opened for user sddm by (uid=0)
Sep 18 09:33:00 x1 sddm-helper[2714]: pam_unix(sddm:session): session opened for user piper by (uid=0)


systemd-analyze critical-chain

Code: [Select]
graphical.target @49.974s
└─multi-user.target @49.974s
  └─mythtv-backend.service @33.992s +5.105s
    └─mariadb.service @23.901s +10.089s
      └─network.target @23.893s
        └─NetworkManager.service @18.244s +5.646s
          └─dbus.service @16.962s
            └─basic.target @16.953s
              └─sockets.target @16.952s
                └─cups.socket @16.951s
                  └─sysinit.target @16.798s
                    └─systemd-timesyncd.service @15.494s +1.303s
                      └─systemd-tmpfiles-setup.service @15.372s +93ms
                        └─systemd-journal-flush.service @1.746s +13.622s
                          └─systemd-remount-fs.service @1.457s +242ms
                            └─systemd-journald.socket @1.425s
                              └─-.mount @1.414s
                                └─system.slice @1.423s
                                  └─-.slice @1.413s

systemd-analyze blame | head

   
Code: [Select]
13.622s systemd-journal-flush.service
         10.874s mythtv-status.service
         10.089s mariadb.service
          8.418s udisks2.service
          6.124s dev-sda10.device
          5.646s NetworkManager.service
          5.105s mythtv-backend.service
          5.056s loadcpufreq.service
          5.010s apache2.service
          4.531s disks-disk1part5.mount
Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
@Cord - komm mal in den IRC, wir sollten ein wenig aufräumen :D
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline bluelupo

  • User
  • Posts: 2.068
    • BluelupoMe
Hier an meinem Laptop keine Probleme nach aktuell heute ausgeführten d-u.


Code: [Select]
# systemd-analyze critical-chain
The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @7.194s
└─multi-user.target @7.194s
  └─postfix.service @7.191s +2ms
    └─postfix@-.service @6.802s +387ms
      └─network-online.target @6.801s
        └─NetworkManager-wait-online.service @2.163s +4.637s
          └─NetworkManager.service @2.025s +135ms
            └─dbus.service @1.969s
              └─basic.target @1.947s
                └─sockets.target @1.946s
                  └─pywwetha.socket @1.945s
                    └─sysinit.target @1.935s
                      └─systemd-timesyncd.service @1.873s +61ms
                        └─systemd-tmpfiles-setup.service @1.858s +7ms
                          └─systemd-journal-flush.service @1.738s +119ms
                            └─var.mount @1.717s +15ms
                              └─systemd-fsck@dev-disk-by\x2dlabel-VAR.service @1.671s +45ms
                                └─local-fs-pre.target @1.670s
                                  └─keyboard-setup.service @137ms +1.533s
                                    └─systemd-journald.socket @129ms
                                      └─-.slice @121ms

Code: [Select]
# systemd-analyze blame         
          4.637s NetworkManager-wait-online.service
          1.533s keyboard-setup.service
           576ms console-setup.service
           387ms postfix@-.service
           354ms dev-mapper-VGsys\x2dLVroot.device
           255ms udisks2.service
           231ms loadcpufreq.service
           192ms accounts-daemon.service
           180ms ModemManager.service
           135ms NetworkManager.service
           134ms colord.service
           127ms systemd-logind.service
           119ms systemd-journal-flush.service
           104ms ssh.service
           103ms lm-sensors.service
           103ms gpm.service
            97ms alsa-restore.service
            86ms pppd-dns.service
            81ms cpufrequtils.service
            80ms preload.service
            80ms upower.service
            77ms systemd-journald.service
            67ms systemd-udev-trigger.service
            64ms bluetooth.service
            61ms systemd-timesyncd.service
            60ms lvm2-monitor.service
            60ms systemd-fsck@dev-disk-by\x2dlabel-HOME.service
            55ms systemd-udevd.service
            50ms avahi-daemon.service
            49ms systemd-fsck@dev-disk-by\x2dlabel-MISC.service
            47ms polkit.service
            45ms systemd-fsck@dev-disk-by\x2dlabel-VAR.service
            38ms user@1000.service
            33ms systemd-fsck@dev-disk-by\x2dlabel-BOOT.service
            32ms systemd-tmpfiles-clean.service
            32ms systemd-tmpfiles-setup-dev.service
            31ms dns-clean.service
            28ms systemd-modules-load.service
            26ms systemd-cryptsetup@cryptsda2.service
            25ms systemd-user-sessions.service
            24ms openvpn.service
            22ms dev-mapper-VGsys\x2dLVswap.swap
            22ms mnt-share-misc.mount
            18ms boot.mount
            16ms wpa_supplicant.service
            16ms run-rpc_pipefs.mount
            15ms systemd-rfkill.service
            15ms var.mount
            15ms systemd-backlight@backlight:intel_backlight.service
            14ms sddm.service
            14ms rpcbind.service
            13ms sys-kernel-debug.mount
            13ms dev-hugepages.mount
            12ms dev-mqueue.mount
            11ms systemd-random-seed.service
            10ms hddtemp.service
            10ms systemd-remount-fs.service
            10ms systemd-sysctl.service
             8ms kmod-static-nodes.service
             8ms systemd-update-utmp.service
             8ms nfs-config.service
             8ms home.mount
             7ms systemd-tmpfiles-setup.service
             6ms systemd-update-utmp-runlevel.service
             2ms postfix.service

Offline der_bud

  • User
  • Posts: 1.078
  • member
Im englischsprachigen Teil ist das jetzt auch einmal geposted (finotti), da scheint also was im Busche zu sein...
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
Handaufleg: Ich hab das auf meinem kleinen Lappi installiert und alles ist fein - die einzigen Unterschiede, die ich bis jetzt sehe sind die verwendeten Grafik-Treiber.
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline cs

  • User
  • Posts: 94
@melmarker: Ich hab integrierte Intel-Grafik: Kann ich da einen anderen Grafik-Treiber verwenden bzw. testen? Wenn mir jemand einen Tipp gibt, probier' ich's gern aus.
Hier nochmal meine Grafik-Hardware:

Code: [Select]
Graphics:  Card: Intel 3rd Gen Core processor Graphics Controller
           Display Server: x11 (X.Org 1.19.3 ) drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.02hz
           OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile version: 4.2 Mesa 17.2.1

Übrigens: Hab mal spaßeshalber Gnome mit Wayland installiert: Startet alles ohne Verzögerung. Schade, bin eigentlich kein Gnome-Fan ...

TommiO

  • Guest
Hi,

hier habe ich das Problem auch, allerdings nicht auf allen Rechnern. Alle Rechner wurden regelmäßig aktualisiert:
  • T530: neue Installation Anfang August, intel-GraKa --> keine Probleme
  • T500: alte Installation, vor 2017, intel-GraKa --> Verzögerung beim Login
  • T61: alte Installation, vor 2017, nvidia-Graka --> Verzögerung beim Login
Meine Beobachtung:
  • Die Verzögerung tritt auch bei wiederholtem Login auf.
  • Die Verzögerung tritt/trat auf T500 bei allen Kombinationen von KDE, LXDE, intel und nvidia auf.
  • Nach einer Neuinstallation von T500 war das Problem behoben.
Eine Neuinstallation von T61 will ich mir vorerst sparen. Ich möchte gerne wissen, woran das liegt ;-)


Gruß
Thomas

Offline ReinerS

  • User
  • Posts: 1.078
Hmm,

wenn es dem Esel zuu wohl wird geht er aufs Eis oder installert sich zusätzlich zu XfCE zum Test auch noch KDE.  ;)

Habe ich letzte Nacht gemacht und habe jetzt dasselbe Problem, allerdings ohne KDE zu starten.

Nach dem Login per sddm kommt gefühlte Ewigkeit nur ein schwarzer Schirm mit dem Mauscursor bevor sich dann der XFCE-Desktop aufbaut. Ansonsten alles normal bis jetzt.

Bin mir daher auch nicht sicher ob das wirklich KDE-Related ist.
Als einziges KDE-Programm scheint okular im Hintergrund zu laufen, sonst sehe ich da aktuell nix von KDE.
Werde mal versuchen das rauszuschmeissen um zu sehen ob das was bringt.

Grüße

Reiner
« Last Edit: 2017/09/19, 09:52:24 by ReinerS »
slackware => SuSE => kanotix => sidux => aptosid  => siduction

Offline ReinerS

  • User
  • Posts: 1.078
Soderle,
da hatte sich auch noch kaccessibelapp rumgetrieben, aber jetzt nach dem Abmelden und Neustart von sddm sind das und auch Okular weg. Leider hat sich an der "Kaffeepause" nichts geändert.  :(

Grüße

Reiner
slackware => SuSE => kanotix => sidux => aptosid  => siduction

Offline ReinerS

  • User
  • Posts: 1.078
Hatte jetzt sddm in Verdacht da da anscheinend was mitkam und mal gdm3 und lighdm probiert.
Mit gdm 3 falle ich direkt wieder auf die Anmeldung zurück, mit lightdm gibts auch die "Kaffeepause" nur bleibt das Hintergrundbild bis zur XFCE-Session da und der Schirm wird nicht schwarz.

Grüße

Reiner
slackware => SuSE => kanotix => sidux => aptosid  => siduction

Offline ReinerS

  • User
  • Posts: 1.078
Hmm, noch was Selsames (seit heute).

Anscheinend werde ich jetzt nach einiger Zeit automatisch "abgeneldet".
Ist mir 2 mal aufgefallen, 1 mal mitten im "Betrieb" und einmal als ich kurz weg war.

Jedesmal kam der Anmeldescreen, ich meldete mich an und nach der "Kaffeepause" gings dann weiter.

Grüße

Reiner
slackware => SuSE => kanotix => sidux => aptosid  => siduction

Offline Geier0815

  • User
  • Posts: 590
Du hattest doch lightdm nachinstalliert, da wird es dir auch light-locker mit installiert haben. Der sperrt den Bildschirm und, anders als xscreensaver, verwendet zur Eingabe der Logindaten den Anmeldebildschirm.
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

Offline ReinerS

  • User
  • Posts: 1.078
Nein, den hatte ich schon drauf aber nicht aktiv. Den light-locker hatte ich aus anderen Gründen schon länger deinstalliert.
Ausserdem hatte ich wieder auf sddm gewechselt.

Grüße

Reiner
slackware => SuSE => kanotix => sidux => aptosid  => siduction

Offline der_bud

  • User
  • Posts: 1.078
  • member
... 
  • T530: neue Installation Anfang August, intel-GraKa --> keine Probleme
  • T500: alte Installation, vor 2017, intel-GraKa --> Verzögerung beim Login
  • T61: alte Installation, vor 2017, nvidia-Graka --> Verzögerung beim Login
... 
Bei mir auf den ersten Blick identische Hardware wie 3. (T61: alte Installation, vor 2017, nvidia-Graka), aber hier keine Verzögerung. Daher wäre vielleicht ein direkter Vergleich der Hardware/Pakete/Autostarteinträge/Dienste/etc zwischen TommiO und mir interessant, kann aber leider frühestens heute abend ran.
Ideen was man noch vergleichen sollte? Und wie kann man sowas weiter debuggen, aus grub nach init3 starten und dann 'startx' ,während auf anderen VTs journalctl tailt oder dmesg oder top/htop läuft?
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.