Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] 111 newly installed ?  (Read 1708 times)

Offline OppaErich

  • OLE
  • User
  • Posts: 381
[DE] 111 newly installed ?
« on: 2018/01/16, 12:00:03 »
Hi,


apt möchte mir 111 neue Pakete installieren. Da sind reichlich -dev Pakete dabei. Ist das so richtig ?


apt wants to install 111 new packages. A lot of them are -dev packages. Is this correct ?


Code: [Select]

root@oppa-hex-ssd:~# apt full-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  libkeybinder0 python-keybinder python-vte
Use 'apt autoremove' to remove them.
The following NEW packages will be installed:
  debhelper dh-autoreconf dh-strip-nondeterminism gir1.2-harfbuzz-0.0 gir1.2-keybinder-3.0 icu-devtools libarchive-cpio-perl libarchive-zip-perl libatk-bridge2.0-dev libatk1.0-dev libatspi2.0-dev libbrotli1
  libcairo-script-interpreter2 libcairo2-dev libdrm-dev libegl1-mesa-dev libepoxy-dev libexpat1-dev libfile-stripnondeterminism-perl libfontconfig1-dev libfreetype6-dev libgdk-pixbuf2.0-dev libglib2.0-dev
  libglib2.0-dev-bin libglvnd-core-dev libglvnd-dev libgnutls28-dev libgnutlsxx28 libgraphite2-dev libgtk-3-dev libharfbuzz-dev libharfbuzz-gobject0 libice-dev libicu-dev libidn2-0-dev libidn2-dev libirs160
  libkeybinder-3.0-0 libltdl-dev libp11-kit-dev libpango1.0-dev libpcre16-3 libpcre2-32-0 libpcre2-dev libpcre2-posix0 libpcre3-dev libpcre32-3 libpcrecpp0v5 libpixman-1-dev libpng-dev libpng-tools
  libpthread-stubs0-dev libsm-dev libtasn1-6-dev libtasn1-doc libtool libvte-2.91-dev libvte-2.91-doc libwayland-bin libwayland-dev libx11-dev libx11-doc libx11-xcb-dev libxau-dev libxcb-dri2-0-dev
  libxcb-dri3-dev libxcb-glx0-dev libxcb-present-dev libxcb-randr0-dev libxcb-render0-dev libxcb-shape0-dev libxcb-shm0-dev libxcb-sync-dev libxcb-xfixes0-dev libxcb1-dev libxcomposite-dev libxcursor-dev
  libxdamage-dev libxdmcp-dev libxext-dev libxfixes-dev libxft-dev libxi-dev libxinerama-dev libxkbcommon-dev libxrandr-dev libxrender-dev libxshmfence-dev libxtst-dev libxxf86vm-dev
  linux-headers-4.14.13-towo.2-siduction-amd64 linux-image-4.14.13-towo.2-siduction-amd64 nettle-dev python3-pbr wayland-protocols x11proto-composite-dev x11proto-core-dev x11proto-damage-dev x11proto-dri2-dev
  x11proto-fixes-dev x11proto-gl-dev x11proto-input-dev x11proto-kb-dev x11proto-randr-dev x11proto-record-dev x11proto-render-dev x11proto-xext-dev x11proto-xf86vidmode-dev x11proto-xinerama-dev
  xorg-sgml-doctools xtrans-dev
The following packages have been kept back:
  audacious audacious-plugins-data
The following packages will be upgraded:
  apache2-bin apt-listchanges aptitude aptitude-common base-files bind9-host bsdutils cdrdao dnsutils fdisk frei0r-plugins gjs gnome-shell gnome-shell-common guake hwinfo libao-common libao4
  libaopalliance-java libapparmor1 libbind9-160 libblkid1 libblkid1:i386 libbsd0 libbsd0:i386 libc-bin libc-dev-bin libc-l10n libc6 libc6:i386 libc6-dbg libc6-dev libc6-dev:i386 libc6-i386 libc6-x32
  libcommons-lang-java libcpupower1 libdns-export169 libdns169 libegl-mesa0 libegl1-mesa libexempi3 libfdisk1 libgbm1 libgc1c2 libgjs0g libgl1-mesa-dri libgl1-mesa-dri:i386 libgl1-mesa-glx libgl1-mesa-glx:i386
  libglapi-mesa libglapi-mesa:i386 libgles2-mesa libglx-mesa0 libglx-mesa0:i386 libgmp-dev libgmp10 libgmp10:i386 libgmp3-dev libgmpxx4ldbl libgraphicsmagick++-q16-12 libgraphicsmagick-q16-3 libhd21 libimlib2
  libisc-export166 libisc166 libisccc160 libisccfg160 libkf5coreaddons-data libkf5coreaddons5 liblwres160 libmd0 libmount1 libmount1:i386 libosmesa6 libperl5.26 libpsm-infinipath1 libqpdf18 libqt5designer5
  libqt5help5 libsmartcols1 liburi-perl libuuid1 libuuid1:i386 libwayland-egl1-mesa libxatracker2 linux-headers-siduction-amd64 linux-image-siduction-amd64 linux-libc-dev linux-libc-dev:i386 locales mount
  multiarch-support nvidia-egl-common nvidia-legacy-check nvidia-modprobe nvidia-persistenced perl perl-base perl-modules-5.26 ttf-mscorefonts-installer util-linux
102 upgraded, 111 newly installed, 0 to remove and 2 not upgraded.
Need to get 155 MB/182 MB of archives.
After this operation, 500 MB of additional disk space will be used.
Do you want to continue? [Y/n]

DeKa

  • Guest
Re: 111 newly installed ?
« Reply #1 on: 2018/01/16, 12:12:27 »
Vergleiche mal mit "apt dist-upgrade -s".

Offline OppaErich

  • OLE
  • User
  • Posts: 381
Re: 111 newly installed ?
« Reply #2 on: 2018/01/16, 12:35:46 »
Hi,
dann werde ich mit so etwas
Code: [Select]

Inst linux-headers-siduction-amd64 [4.14-23] (4.14-24 ftp.spline.de [amd64])
Inst linux-image-siduction-amd64 [4.14-23] (4.14-24 ftp.spline.de [amd64])
Conf libc6-x32 (2.26-4 Debian:unstable [amd64])
Conf libc-dev-bin (2.26-4 Debian:unstable [amd64])
Conf libc6-dev (2.26-4 Debian:unstable [amd64])
tonnenweise beworfen. Sagt mir gar nichts...

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.941
Re: 111 newly installed ?
« Reply #3 on: 2018/01/16, 12:48:45 »
Dein problem ist vermutlich guake, da ist der Maintainer wohl etwas über das Ziel hinaus geschossen, weil er da
libgtk-3-dev, libvte-2.91-dev und libglib2.0-dev als Depends reingepackt hat.
Das schreit förmlich nach einem Bugreport.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline OppaErich

  • OLE
  • User
  • Posts: 381
Re: 111 newly installed ?
« Reply #4 on: 2018/01/16, 13:04:56 »
Ah, Dankow! So viele dev Pakete konnte schlecht sein. Und ja, ist ein Gnome und hat die Gurke.