Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] [SOLVED] new problem with cron  (Read 1893 times)

hightime

  • Guest
[EN] [SOLVED] new problem with cron
« on: 2018/01/17, 02:47:54 »

UPDATE: Problem was with my home directory. My existing login continued to work so I did not notice the problem until I tried to start a new session. Not a cron or script problem at all.

I have line in my crontab that calls getmail to fetch my mail. A few days ago it stopped working. syslog shows that cron ran it, but it never fetches my mail.
After some experimenting I found that scripts don't seem to work anymore. Here are two very simple cases.


This works:
Code: [Select]
10 * * * * /bin/touch somefile


This does not:
Code: [Select]
10 * * * * /path/to/myscript.sh  # simple bash script that calls /bin/touch somefile


I also tried calling /bin/bash with myscript.sh as an argument. In both cases, cron logs to syslog that it ran the script, but the script doesn't do anything.
Has there been some change, possibly for security reasons, that prevents scripts from actually running when invoked from cron?


« Last Edit: 2018/01/17, 03:31:39 by hightime »