Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] Siduction und mullvad-Installation  (Read 3207 times)

lutz4711

  • Guest
[DE] Siduction und mullvad-Installation
« on: 2018/04/17, 09:54:11 »
Hallo, bei einer frischen Neuinstallation siduction-18.2.0-patience-kde-amd64 (ohne DU) kann ich als user - nicht wie gewohnt - mullvad starten.
Im einzelnen:

Code: [Select]

dpkg -i /media/DATEN/Linux/mullvad/mullvad_67-1_all.deb
Vormals nicht ausgewähltes Paket mullvad wird gewählt.
(Lese Datenbank ... 229048 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../mullvad/mullvad_67-1_all.deb ...
Entpacken von mullvad (67-1) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von mullvad:
 mullvad hängt ab von python-wxgtk2.8 | python-wxgtk3.0; aber:
  Paket python-wxgtk2.8 ist nicht installiert.
  Paket python-wxgtk3.0 ist nicht installiert.
 mullvad hängt ab von resolvconf; aber:
  Paket resolvconf ist nicht installiert.
 mullvad hängt ab von python-appindicator; aber:
  Paket python-appindicator ist nicht installiert.
 mullvad hängt ab von python-appdirs; aber:
  Paket python-appdirs ist nicht installiert.
 mullvad hängt ab von python-netifaces; aber:
  Paket python-netifaces ist nicht installiert.
 mullvad hängt ab von python-ipaddr; aber:
  Paket python-ipaddr ist nicht installiert.
 mullvad hängt ab von python-psutil; aber:
  Paket python-psutil ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes mullvad (--install):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Trigger für desktop-file-utils (0.23-2) werden verarbeitet ...
Trigger für mime-support (3.60) werden verarbeitet ...
Trigger für hicolor-icon-theme (0.17-1) werden verarbeitet ...
Fehler traten auf beim Bearbeiten von:
 mullvad

weiter:

Code: [Select]

apt-get -f install
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Abhängigkeiten werden korrigiert ... Fertig
Die folgenden zusätzlichen Pakete werden installiert:
  libappindicator1 libdbusmenu-glib4 libdbusmenu-gtk4 libindicator7 libwxbase3.0-0v5
  libwxgtk3.0-gtk3-0v5 python-appdirs python-appindicator python-ipaddr python-netifaces python-psutil
  python-wxgtk3.0 python-wxversion resolvconf
Vorgeschlagene Pakete:
  python-psutil-doc wx3.0-doc
Die folgenden NEUEN Pakete werden installiert:
  libappindicator1 libdbusmenu-glib4 libdbusmenu-gtk4 libindicator7 libwxgtk3.0-gtk3-0v5 python-appdirs
  python-appindicator python-ipaddr python-netifaces python-psutil python-wxgtk3.0 python-wxversion
  resolvconf
Die folgenden Pakete werden aktualisiert (Upgrade):
  libwxbase3.0-0v5
1 aktualisiert, 13 neu installiert, 0 zu entfernen und 1139 nicht aktualisiert.
1 nicht vollständig installiert oder entfernt.
Es müssen 11,3 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 48,1 MB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n]
Holen:1 http://deb.debian.org/debian unstable/main amd64 python-wxversion all 3.0.2.0+dfsg-7 [114 kB]
Holen:2 http://deb.debian.org/debian unstable/main amd64 libwxbase3.0-0v5 amd64 3.0.4+dfsg-3 [1.061 kB]
Holen:3 http://deb.debian.org/debian unstable/main amd64 libwxgtk3.0-gtk3-0v5 amd64 3.0.4+dfsg-3 [4.304 kB]
Holen:4 http://deb.debian.org/debian unstable/main amd64 python-wxgtk3.0 amd64 3.0.2.0+dfsg-7 [5.284 kB]
Holen:5 http://deb.debian.org/debian unstable/main amd64 resolvconf all 1.79 [74,2 kB]
Holen:6 http://deb.debian.org/debian unstable/main amd64 libdbusmenu-glib4 amd64 16.04.1+17.04.20170109.1-5 [57,8 kB]
Holen:7 http://deb.debian.org/debian unstable/main amd64 libdbusmenu-gtk4 amd64 16.04.1+17.04.20170109.1-5 [45,0 kB]
Holen:8 http://deb.debian.org/debian unstable/main amd64 libindicator7 amd64 0.5.0-3+b1 [52,9 kB]
Holen:9 http://deb.debian.org/debian unstable/main amd64 libappindicator1 amd64 0.4.92-5 [52,6 kB]
Holen:10 http://deb.debian.org/debian unstable/main amd64 python-appindicator amd64 0.4.92-5 [43,0 kB]
Holen:11 http://deb.debian.org/debian unstable/main amd64 python-appdirs all 1.4.3-1 [12,0 kB]
Holen:12 http://deb.debian.org/debian unstable/main amd64 python-netifaces amd64 0.10.4-1 [16,6 kB]
Holen:13 http://deb.debian.org/debian unstable/main amd64 python-ipaddr all 2.2.0-1 [16,0 kB]
Holen:14 http://deb.debian.org/debian unstable/main amd64 python-psutil amd64 5.4.2-1 [159 kB]
Es wurden 11,3 MB in 2 s geholt (5.022 kB/s).
Changelogs werden gelesen... Fertig
Preconfiguring packages ...
Vormals nicht ausgewähltes Paket python-wxversion wird gewählt.
(Lese Datenbank ... 229138 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../00-python-wxversion_3.0.2.0+dfsg-7_all.deb ...
Entpacken von python-wxversion (3.0.2.0+dfsg-7) ...
Vorbereitung zum Entpacken von .../01-libwxbase3.0-0v5_3.0.4+dfsg-3_amd64.deb ...
Entpacken von libwxbase3.0-0v5:amd64 (3.0.4+dfsg-3) über (3.0.3.1+dfsg2-1) ...
Vormals nicht ausgewähltes Paket libwxgtk3.0-gtk3-0v5:amd64 wird gewählt.
Vorbereitung zum Entpacken von .../02-libwxgtk3.0-gtk3-0v5_3.0.4+dfsg-3_amd64.deb ...
Entpacken von libwxgtk3.0-gtk3-0v5:amd64 (3.0.4+dfsg-3) ...
Vormals nicht ausgewähltes Paket python-wxgtk3.0 wird gewählt.
Vorbereitung zum Entpacken von .../03-python-wxgtk3.0_3.0.2.0+dfsg-7_amd64.deb ...
Entpacken von python-wxgtk3.0 (3.0.2.0+dfsg-7) ...
Vormals nicht ausgewähltes Paket resolvconf wird gewählt.
Vorbereitung zum Entpacken von .../04-resolvconf_1.79_all.deb ...
Entpacken von resolvconf (1.79) ...
Vormals nicht ausgewähltes Paket libdbusmenu-glib4:amd64 wird gewählt.
Vorbereitung zum Entpacken von .../05-libdbusmenu-glib4_16.04.1+17.04.20170109.1-5_amd64.deb ...
Entpacken von libdbusmenu-glib4:amd64 (16.04.1+17.04.20170109.1-5) ...
Vormals nicht ausgewähltes Paket libdbusmenu-gtk4:amd64 wird gewählt.
Vorbereitung zum Entpacken von .../06-libdbusmenu-gtk4_16.04.1+17.04.20170109.1-5_amd64.deb ...
Entpacken von libdbusmenu-gtk4:amd64 (16.04.1+17.04.20170109.1-5) ...
Vormals nicht ausgewähltes Paket libindicator7:amd64 wird gewählt.
Vorbereitung zum Entpacken von .../07-libindicator7_0.5.0-3+b1_amd64.deb ...
Entpacken von libindicator7:amd64 (0.5.0-3+b1) ...
Vormals nicht ausgewähltes Paket libappindicator1:amd64 wird gewählt.
Vorbereitung zum Entpacken von .../08-libappindicator1_0.4.92-5_amd64.deb ...
Entpacken von libappindicator1:amd64 (0.4.92-5) ...
Vormals nicht ausgewähltes Paket python-appindicator wird gewählt.
Vorbereitung zum Entpacken von .../09-python-appindicator_0.4.92-5_amd64.deb ...
Entpacken von python-appindicator (0.4.92-5) ...
Vormals nicht ausgewähltes Paket python-appdirs wird gewählt.
Vorbereitung zum Entpacken von .../10-python-appdirs_1.4.3-1_all.deb ...
Entpacken von python-appdirs (1.4.3-1) ...
Vormals nicht ausgewähltes Paket python-netifaces wird gewählt.
Vorbereitung zum Entpacken von .../11-python-netifaces_0.10.4-1_amd64.deb ...
Entpacken von python-netifaces (0.10.4-1) ...
Vormals nicht ausgewähltes Paket python-ipaddr wird gewählt.
Vorbereitung zum Entpacken von .../12-python-ipaddr_2.2.0-1_all.deb ...
Entpacken von python-ipaddr (2.2.0-1) ...
Vormals nicht ausgewähltes Paket python-psutil wird gewählt.
Vorbereitung zum Entpacken von .../13-python-psutil_5.4.2-1_amd64.deb ...
Entpacken von python-psutil (5.4.2-1) ...
libindicator7:amd64 (0.5.0-3+b1) wird eingerichtet ...
python-ipaddr (2.2.0-1) wird eingerichtet ...
python-wxversion (3.0.2.0+dfsg-7) wird eingerichtet ...
python-netifaces (0.10.4-1) wird eingerichtet ...
Trigger für siduction-dynamic-dms (2016.01.31) werden verarbeitet ...
libwxbase3.0-0v5:amd64 (3.0.4+dfsg-3) wird eingerichtet ...
libdbusmenu-glib4:amd64 (16.04.1+17.04.20170109.1-5) wird eingerichtet ...
Trigger für libc-bin (2.27-1) werden verarbeitet ...
python-psutil (5.4.2-1) wird eingerichtet ...
python-appdirs (1.4.3-1) wird eingerichtet ...
Trigger für systemd (237-4) werden verarbeitet ...
libwxgtk3.0-gtk3-0v5:amd64 (3.0.4+dfsg-3) wird eingerichtet ...
Trigger für man-db (2.8.2-1) werden verarbeitet ...
resolvconf (1.79) wird eingerichtet ...
Created symlink /etc/systemd/system/sysinit.target.wants/resolvconf.service → /lib/systemd/system/resolvconf.service.
python-wxgtk3.0 (3.0.2.0+dfsg-7) wird eingerichtet ...
update-alternatives: /usr/lib/wx/python/wx3.0.pth wird verwendet, um /usr/lib/wx/python/wx.pth (wx.pth) im automatischen Modus bereitzustellen
libdbusmenu-gtk4:amd64 (16.04.1+17.04.20170109.1-5) wird eingerichtet ...
libappindicator1:amd64 (0.4.92-5) wird eingerichtet ...
python-appindicator (0.4.92-5) wird eingerichtet ...
Trigger für siduction-dynamic-dms (2016.01.31) werden verarbeitet ...
mullvad (67-1) wird eingerichtet ...
Trigger für libc-bin (2.27-1) werden verarbeitet ...
Trigger für systemd (237-4) werden verarbeitet ...
Trigger für resolvconf (1.79) werden verarbeitet ...
needrestart is being skipped since dpkg has failed

weiter:
Code: [Select]
dpkg -i /media/DATEN/Linux/mullvad/mullvad_67-1_all.deb
(Lese Datenbank ... 229796 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../mullvad/mullvad_67-1_all.deb ...
Entpacken von mullvad (67-1) über (67-1) ...
mullvad (67-1) wird eingerichtet ...
Trigger für desktop-file-utils (0.23-2) werden verarbeitet ...
Trigger für mime-support (3.60) werden verarbeitet ...
Trigger für hicolor-icon-theme (0.17-1) werden verarbeitet ...

Aufruf von mullvad in der user-Konsole:

Code: [Select]

mullvad
Using GTK2
changing directory to /usr/lib/python2.7/dist-packages/mullvad
Setting logging directory to /home/lutz/.cache/mullvad/log

(mullvad:2414): GLib-GObject-WARNING **: cannot register existing type 'GdkDisplayManager'

(mullvad:2414): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(mullvad:2414): GLib-GObject-CRITICAL **: g_object_new_with_properties: assertion 'G_TYPE_IS_OBJECT (object_type)' failed

Die Systemaktivität zeigt unter mullvad den Befrehl /usr/bin/phython /usr/binmullvad an.

Was läuft da falsch - was mache ich falsch?

Entschuldigung für die Länge.

Offline OppaErich

  • OLE
  • User
  • Posts: 381
Re: Siduction und mullvad-Installation
« Reply #1 on: 2018/04/17, 10:47:35 »
Ich kenne das nicht aber eventuell liegt es daran:
Code: [Select]
und 1139 nicht aktualisiert.
« Last Edit: 2018/04/17, 11:49:34 by OppaErich »

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
Re: Siduction und mullvad-Installation
« Reply #2 on: 2018/04/17, 11:29:40 »
Ich das nicht aber eventuell liegt es daran:
Code: [Select]
und 1139 nicht aktualisiert.
und dazu kommt noch die missbräuchliche Nutzung von dpkg zur Installation von lokalen Paketen ...
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.844
Re: Siduction und mullvad-Installation
« Reply #3 on: 2018/04/17, 15:09:36 »
Mullvad lässt sich hier ohne weiteres als User starten und fragt dann das Root-PW ab. Liegt also nicht am System. Hier läuft Version 67 auf einem tagesaktuellen siduction.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.844
Re: Siduction und mullvad-Installation
« Reply #4 on: 2018/04/19, 13:27:51 »
Seit heute gleiches Problem mit gleicher Fehlermeldung. Ich hab mal deren Support angeschrieben.

Offline OppaErich

  • OLE
  • User
  • Posts: 381
Re: Siduction und mullvad-Installation
« Reply #5 on: 2018/04/19, 14:06:48 »
Tante Google sagt: Versuch mal
Code: [Select]
unset XDG_CURRENT_DESKTOPund dann starten.
https://github.com/telegramdesktop/tdesktop/issues/4298 <- Ist eine andere Soft aber dieselbe Fehlermeldung

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.844
Re: Siduction und mullvad-Installation
« Reply #6 on: 2018/04/19, 23:16:53 »
Danke, das wars leider nicht.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.844
Re: Siduction und mullvad-Installation
« Reply #7 on: 2018/04/20, 06:36:13 »
Antwort des Supports:
It seems that some users have issues with version 67 and some linux distros.
I would recommend you to run plain OpenVPN and see if that works better
for you.

https://mullvad.net/en/guides/linux-openvpn-installation/

We are currently developing a completely new application from scratch
for Linux and Windows which shouldn't be to far away at this moment.

Offline Lanzi

  • User
  • Posts: 1.781
Re: Siduction und mullvad-Installation
« Reply #8 on: 2018/06/01, 00:27:37 »
@Devil, gibts da Neuigkeiten. Mein VPN bricht immer ab und ich bin dann ungeschützt unterwegs, deswegen hattest Du mir mal Mullvad empfohlen.
Geht es wieder?
Bin bei der WM in Spanien und würde gerne ARD& ZDF schauen

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.844
Re: Siduction und mullvad-Installation
« Reply #9 on: 2018/06/01, 05:35:25 »
Leider gibt's noch keine Neuigkeiten :( 

lutz4711

  • Guest
Re: Siduction und mullvad-Installation
« Reply #10 on: 2018/06/01, 09:14:46 »
Hallo,

mir hat - zumindest temporär - geholfen:

https://askubuntu.com/questions/1029317/mullvad-vpn-client-wont-start-on-18-04

Gruß

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.844
Re: Siduction und mullvad-Installation
« Reply #11 on: 2018/11/11, 12:27:04 »
Falls es jemand noch nicht mitbekommen hat, verfügt Mullvad über einen neu geschriebenen Client, der jetzt Mullvad VPN heißt, wesentlich komfortabler ist und zudem auch funktioniert :)
Weiterhin kann Mullvad als einer der ersten VPN-Anbieter auch mit WireGuard betrieben werden: https://mullvad.net/de/guides/category/wireguard/

Neu ist soviel ich weiß auch die Seite, auf der die Sicherheit der Verbindung überprüft werden kann: https://am.i.mullvad.net
« Last Edit: 2018/11/11, 12:33:04 by devil »

Offline Lanzi

  • User
  • Posts: 1.781
Re: Siduction und mullvad-Installation
« Reply #12 on: 2018/11/11, 12:56:00 »
Danke für das Update :)