Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: Install failure  (Read 5772 times)

Offline piper

  • User
  • Posts: 1.785
  • we are the priests ... of the temples of syrinx
Re: Install failure
« Reply #15 on: 2019/01/25, 17:27:37 »
I had to do it once, yes, it was awhile ago, I had no problem at that time.
Thanks for saying not to do it again if the situation ever comes up again ;)

Now calamares just works out of the box  :)

Code: [Select]
System:    Host: x1 Kernel: 4.20.4-towo.1-siduction-amd64 x86_64 bits: 64 compiler: gcc v: 8.2.0 Desktop: KDE Plasma 5.14.5
           tk: Qt 5.11.3 wm: kwin_x11 dm: SDDM Distro: siduction 18.3.0 Paint It Black - kde - (201901241146)
           base: Debian GNU/Linux buster/sid
Machine:   Type: Desktop System: Gigabyte product: GA-970A-UD3 v: N/A serial: <root required> Chassis: type: 3
           serial: <root required>
           Mobo: Gigabyte model: GA-970A-UD3 v: x.x serial: <root required> BIOS: Award v: F7 date: 10/22/2012
Battery:   Device-1: hidpp_battery_0 model: Logitech Performance MX serial: 101a-e9-77-6f-11 charge: 70% (should be ignored)
           status: Discharging
Memory:    RAM: total: 15.65 GiB used: 4.38 GiB (28.0%)
           RAM Report: permissions: Unable to run dmidecode. Are you root?
CPU:       Topology: 6-Core model: AMD FX-6300 bits: 64 type: MCP arch: Bulldozer L2 cache: 2048 KiB
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 42283
           Speed: 1735 MHz min/max: 1400/3500 MHz Core speeds (MHz): 1: 1409 2: 1408 3: 1409 4: 1522 5: 1672 6: 1393
Graphics:  Device-1: NVIDIA GM204 [GeForce GTX 970] vendor: eVga.com. driver: nvidia v: 415.25 bus ID: 01:00.0
           chip ID: 10de:13c2
           Display: x11 server: X.Org 1.20.3 driver: nvidia unloaded: fbdev,modesetting,nouveau,vesa alternate: nv
           compositor: kwin_x11 resolution: 1920x1080~60Hz
           OpenGL: renderer: GeForce GTX 970/PCIe/SSE2 v: 4.6.0 NVIDIA 415.25 direct render: Yes
Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Offline Mte90

  • User
  • Posts: 179
  • KDE & Debian lover
    • http://www.mte90.net
Re: Install failure
« Reply #16 on: 2019/01/26, 16:01:42 »
I can confirm that a purge of appstream fix the problems during the install.If you take the 2018.3 patience calamares crash about issues with apt.Just to avoid any other errors I did also an apt update before tu run calamers because after the 10th test i was quite annoyed of the issue.Anyway this 2 commands let me to finish the distro installation.

Offline sunrat

  • User
  • Posts: 405
Re: Install failure
« Reply #17 on: 2019/04/12, 04:22:48 »
I just did 2 installs from the original 2018.3.0, one on bare metal and one in KVM/QEMU and both times hit this problem with appstream. Both times purging it from live allowed the installer to complete happily. Hopefully this is addressed before the next release.

 I was most impressed that doing d-u of over 1900 packages worked without a hitch! I will remember to ask on IRC for a more recent image next time if it's a long time since release, which may be soon as I have one more install to do soon.

Like the other poster here, I was also tempted to change to Debian stable and installed Buster with the intention of tracking it to release and then sticking with it. siduction is just better though so Buster hasn't won me over!  ;) 8) The only issue I've had with upgrades for a very, very long time is with Nvidia driver for the new 5.0 kernel and even that was easy to fix with the nvidia-driver package from experimental.


  • Guest
Re: Install failure
« Reply #18 on: 2019/06/20, 23:28:47 »
I ran into the same issue on more then one distro variant. The one that I did find to work, after being very patient was using Netrunner debian which is stable. By this I do mean it got stuck for a while between 20-40% before it continued with the full install.
ake sure you add the neccessary sources to do the upgrades.
Using smxi you can then add siduction stuff. I then set upgrading to testing and then go to unstable. Might not be the best way, but I am now up and running without formating my home partition.