Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: phonon packages kept back  (Read 912 times)

Offline jyp

  • User
  • Posts: 93
phonon packages kept back
« on: 2020/05/02, 19:16:14 »
These packages have been kept back through many recent d-u. Since I had a few sound issues in the past, I am a bit nervous about getting rid of them.I checked with htop if phonon was running and there is no pid related to it while, on the other hand, pulseaudio is running.
I use regularly, firefox (youtube), vlc, kdenlive.

Code: [Select]
# apt full-upgrade -d
...
The following packages have been kept back:
  phonon-backend-gstreamer-common phonon4qt5-backend-gstreamer
Code: [Select]
# apt depends phonon-backend-gstreamer-common
phonon-backend-gstreamer-common
  Suggests: phonon-backend-gstreamer
  Suggests: phonon4qt5-backend-gstreamer
Code: [Select]
# apt rdepends phonon-backend-gstreamer-common
phonon-backend-gstreamer-common
Reverse Depends:
  Depends: phonon-backend-gstreamer (= 4:4.9.0-1)
  Depends: phonon4qt5-backend-gstreamer (= 4:4.9.0-1)
  Depends: phonon4qt5-backend-gstreamer (= 4:4.10.0-1)

Here are some info on my system
Code: [Select]
System:    Host: omega Kernel: 5.6.7-towo.1-siduction-amd64 x86_64 bits: 64 Desktop: KDE Plasma 5.17.5
           Distro: siduction 17.1.0 Patience - kde - (201703051755)
Machine:   Type: Desktop System: ASUS product: All Series v: N/A serial: N/A
           Mobo: ASUSTeK model: SABERTOOTH Z87 v: Rev 1.xx serial: 130612993600174 BIOS: American Megatrends v: 1803
           date: 02/17/2014
CPU:       Topology: Quad Core model: Intel Core i5-4670K bits: 64 type: MCP L2 cache: 6144 KiB
           Speed: 3398 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 3398 2: 3398 3: 3398 4: 3398
...
Audio:     Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio driver: snd_hda_intel
           Device-2: Intel 8 Series/C220 Series High Definition Audio driver: snd_hda_intel
           Sound Server: ALSA v: k5.6.7-towo.1-siduction-amd64
Code: [Select]
# dpkg -l | grep ii | grep sound
ii  libasound2:amd64                              1.2.2-2.1                               amd64        shared library for ALSA applications
ii  libasound2-data                               1.2.2-2.1                               all          Configuration files and profiles for ALSA drivers
ii  libasound2-plugins:amd64                      1.2.2-1                                 amd64        ALSA library additional plugins
ii  libcanberra-gtk3-0:amd64                      0.30-7                                  amd64        GTK+ 3.0 helper for playing widget event sounds with libcanberra
ii  libcanberra0:amd64                            0.30-7                                  amd64        simple abstract interface for playing event sounds
ii  libsoundtouch1:amd64                          2.1.2+ds1-1                             amd64        Sound stretching library
ii  oxygen-sounds                                 4:5.17.5-2                              all          Sounds for the Oxygen desktop theme
ii  pulseaudio                                    13.0-5                                  amd64        PulseAudio sound server
ii  pulseaudio-module-bluetooth                   13.0-5                                  amd64        Bluetooth module for PulseAudio sound server
ii  pulseaudio-module-gsettings                   13.0-5                                  amd64        GSettings module for PulseAudio sound server
ii  pulseaudio-module-zeroconf                    13.0-5                                  amd64        Zeroconf module for PulseAudio sound server
ii  pulseaudio-utils                              13.0-5                                  amd64        Command line tools for the PulseAudio sound server
ii  sound-theme-freedesktop                       0.8-2                                   all          freedesktop.org sound theme
ii  timgm6mb-soundfont                            1.3-3                                   all          TimGM6mb SoundFont from MuseScore 1.3
Code: [Select]
# dpkg -l | grep ii | grep phonon
ii  libphonon4:amd64                              4:4.10.3-2                              amd64        multimedia framework from KDE - core library
ii  libphonon4qt5-4:amd64                         4:4.11.1-3                              amd64        multimedia framework from KDE using Qt 5 - core library
ii  libphonon4qt5-data                            4:4.11.1-3                              all          multimedia framework from KDE using Qt 5 - core library data
ii  phonon:amd64                                  4:4.10.3-2                              amd64        multimedia framework from KDE using Qt 4 - metapackage
ii  phonon-backend-gstreamer:amd64                4:4.9.0-1                               amd64        Phonon GStreamer 1.0 backend
ii  phonon-backend-gstreamer-common:amd64         4:4.9.0-1                               amd64        Phonon GStreamer 1.0.x backend icons
ii  phonon4qt5:amd64                              4:4.11.1-3                              amd64        multimedia framework from KDE using Qt 5 - metapackage
ii  phonon4qt5-backend-gstreamer:amd64            4:4.9.0-1                               amd64        Phonon Qt5 GStreamer 1.0 backend

Thank you

Offline piper

  • User
  • Posts: 1.787
  • we are the priests ... of the temples of syrinx
Re: phonon packages kept back
« Reply #1 on: 2020/05/02, 23:23:26 »
Anything showing for

Code: [Select]
apt-mark showhold

apt policy phonon-backend-gstreamer-common phonon4qt5-backend-gstreamer

Code: [Select]
phonon-backend-gstreamer-common:
  Installed: 4:4.10.0-1
  Candidate: 4:4.10.0-1
  Version table:
 *** 4:4.10.0-1 500
        500 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
phonon4qt5-backend-gstreamer:
  Installed: 4:4.10.0-1
  Candidate: 4:4.10.0-1
  Version table:
 *** 4:4.10.0-1 500
        500 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status


apt update; apt full-upgrade -d -V -y -s

Code: [Select]
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
   linux-headers-5.6.7-towo.1-siduction-amd64 (5.6-7)
   linux-image-5.6.7-towo.1-siduction-amd64 (5.6-7)
Use 'apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


dpkg -l | grep ii | grep phonon

Code: [Select]
ii  libphonon4qt5-4:amd64                         4:4.11.1-3                          amd64        multimedia framework from KDE using Qt 5 - core library
ii  libphonon4qt5-data                            4:4.11.1-3                          all          multimedia framework from KDE using Qt 5 - core library data
ii  phonon-backend-gstreamer-common:amd64         4:4.10.0-1                          amd64        Phonon GStreamer 1.0.x backend icons
ii  phonon4qt5:amd64                              4:4.11.1-3                          amd64        multimedia framework from KDE using Qt 5 - metapackage
ii  phonon4qt5-backend-gstreamer:amd64            4:4.10.0-1                          amd64        Phonon Qt5 GStreamer 1.0 backend
Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Offline sunrat

  • User
  • Posts: 404
Re: phonon packages kept back
« Reply #2 on: 2020/05/03, 07:22:59 »
I've been wondering about the same thing for ages as the same packages have been held back. apt-mark showhold reported nothing. So I made a full system backup and determined to solve it.
Turned out I still had the phonon-backend-gstreamer metapackage which is now deprecated but depends on v.4:4.9.0-1 of those 2 packages.
Solution - remove phonon-backend-gstreamer and those 2 will then be upgradeable to the current v.4:4.10.0-1
Sound still works.  ;) 8)

Offline piper

  • User
  • Posts: 1.787
  • we are the priests ... of the temples of syrinx
Re: phonon packages kept back
« Reply #3 on: 2020/05/03, 20:56:12 »
@sunrat

Thanks, and glad you figured it out :)

read the plant … be the plant … smoke the plant …

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Offline brutor

  • User
  • Posts: 12
Re: phonon packages kept back
« Reply #4 on: 2020/12/13, 09:14:29 »
this problem was already present for a long time, but now I tried to remove phonon-backend-gstreamer.
A lot of other packages get removed with it. This doesn't seem safe ?
Code: [Select]
apt-get remove -s phonon-backend-gstreamer
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libbctoolbox1 libbzrtp0 libmediastreamer-base10 libmediastreamer-voip10 libopenexr23 libortp13
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  dolphin4 jovie kaccessible kde-runtime kdepasswd kdesudo konqueror-nsplugins kopete kremotecontrol kscd kuser libakonadi-contact4 libk3b6 libk3b6-extracodecs
  libkcddb4 libkcompactdisc4 libkonq-common libkonq5abi1 libokularcore7 phonon phonon-backend-gstreamer
0 upgraded, 0 newly installed, 21 to remove and 1 not upgraded.
1 not fully installed or removed.
Remv dolphin4 [4:16.08.3-1]
Remv jovie [4:17.08.3-1]
Remv kaccessible [4:17.08.3-1]
Remv kuser [4:16.08.0-1]
Remv kscd [4:17.08.3-1]
Remv kde-runtime [4:17.08.3-2.1] [kremotecontrol:amd64 kdepasswd:amd64 kopete:amd64 kdesudo:amd64 konqueror-nsplugins:amd64 ]
Remv kdepasswd [4:16.08.3-3] [kremotecontrol:amd64 kopete:amd64 kdesudo:amd64 konqueror-nsplugins:amd64 ]
Remv kdesudo [3.4.2.4-2] [kremotecontrol:amd64 kopete:amd64 konqueror-nsplugins:amd64 ]
Remv konqueror-nsplugins [4:16.08.3-1] [kremotecontrol:amd64 kopete:amd64 ]
Remv kopete [4:17.08.3-2.1] [kremotecontrol:amd64 ]
Remv kremotecontrol [4:17.08.3-1]
Remv libakonadi-contact4 [4:4.14.10-11]
Remv libk3b6-extracodecs [2.0.3a-2+b2]
Remv libk3b6 [2.0.3a-2+b2]
Remv libkcddb4 [4:16.08.3-1]
Remv libkcompactdisc4 [4:16.04.0-2]
Remv libkonq5abi1 [4:16.08.3-3]
Remv libkonq-common [4:16.08.3-3]
Remv libokularcore7 [4:16.08.2-1+b1]
Remv phonon [4:4.10.3-2]
Remv phonon-backend-gstreamer [4:4.9.1-1]
Conf python3-paraview (5.9.0~rc1-1+b1 Debian:unstable [amd64])

Offline sunrat

  • User
  • Posts: 404
Re: phonon packages kept back
« Reply #5 on: 2020/12/13, 11:11:34 »
this problem was already present for a long time, but now I tried to remove phonon-backend-gstreamer.
A lot of other packages get removed with it. This doesn't seem safe ?
Code: [Select]
apt-get remove -s phonon-backend-gstreamer
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libbctoolbox1 libbzrtp0 libmediastreamer-base10 libmediastreamer-voip10 libopenexr23 libortp13
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  dolphin4 jovie kaccessible kde-runtime kdepasswd kdesudo konqueror-nsplugins kopete kremotecontrol kscd kuser libakonadi-contact4 libk3b6 libk3b6-extracodecs
  libkcddb4 libkcompactdisc4 libkonq-common libkonq5abi1 libokularcore7 phonon phonon-backend-gstreamer
0 upgraded, 0 newly installed, 21 to remove and 1 not upgraded.
1 not fully installed or removed. ...

Have you not done a dist-upgrade for a very long time? All those packages to remove are deprecated and no longer in Debian sid. You can check by running apt policy for all those packages. Let them go.
You should follow up if you still get the message "1 not fully installed or removed" after you d-u. Find out which is the offending package and try to find a solution.

Offline brutor

  • User
  • Posts: 12
Re: phonon packages kept back
« Reply #6 on: 2020/12/14, 22:28:21 »
Not really, I do weekly dist-upgrades.But like in the original post, those 2 phonon packages were on hold for some unknown reason.I'll check what can be removed.
The other offending package is python3-paraview, but that doesn't worry me for the moment.