Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: Live Iso Xorg bootet nicht.  (Read 1080 times)

Offline snow_freak

  • User
  • Posts: 64
Live Iso Xorg bootet nicht.
« on: 2020/11/30, 21:23:34 »
Hallo,ich habe mir siduction-patience-xorg-amd64-latest.iso heruntergeldaden und auf einen USB Stick kopiert. Auf meinem PC bootet der einwandfrei.
Siduction xorg möchte ich auf einem älteren Laptop (Lenovo Thinkpad E525) installieren. Wenn ich vom USB Stick boote kommt nur ein Bildschirm mit inversem "Welcome to GRUB!". Sonst nix.
Weiß jemand, wie ich von dem Stick booten kann?

Offline axt

  • User
  • Posts: 478
    • axebase.net
Re: Live Iso Xorg bootet nicht.
« Reply #1 on: 2020/12/01, 17:04:10 »
Quote from: snow_freak
auf einen USB Stick kopiert

Wie/womit?

Im UEFI des Lenovo ThinkPad Edge E525 bzgl. UEFI/CSM was konkret eingestellt?

Wird tatsächlich versucht, von Stick zu booten (ist eine LED verbaut, kann man Zugriffe sehen)?

Letzterhältliches UEFI 1.14 geflasht? Auch schon 7 Jahre alt. Gibt es auch als ODD-Image, wenn kein Windows installiert ist (Achtung, das ist kein Hybrid, ohne Bearbeitung ist es nicht für USB-Stick verwendbar!).

"Welcome to GRUB!" ist zur Ursachenfindung ansonsten etwas mager, dennoch kann man danach suchen.

Offline snow_freak

  • User
  • Posts: 64
Re: Live Iso Xorg bootet nicht.
« Reply #2 on: 2020/12/01, 18:59:01 »
Die iso Datei habe ich mit dd auf den Stick kopiert. An meinem Desktop PC kann ich problemlos von dem Stick booten.
Im Boot Menu am Laptop kann ich den USB Stick als Boot Device auswählen. Das BIOS ist die aktuellste Version, aber halt schon 7 Jahre alt.
Mehr als "Welcome to GRUB!" wird halt leider nicht angezeigt.
Das iso Abbild hab ich auch schon auf DVD gebrannt und versucht davon zu booten, leider mit dem gleichemn Ergebnis wir von USB Stick.

Offline axt

  • User
  • Posts: 478
    • axebase.net
Re: Live Iso Xorg bootet nicht.
« Reply #3 on: 2020/12/01, 20:22:48 »
Ich wiederhole:

Im UEFI des Lenovo ThinkPad Edge E525 bzgl. UEFI/CSM was konkret eingestellt?

Wird tatsächlich versucht, von Stick zu booten (ist eine LED verbaut, kann man Zugriffe sehen)?

Offline snow_freak

  • User
  • Posts: 64
Re: Live Iso Xorg bootet nicht.
« Reply #4 on: 2020/12/01, 21:20:19 »
Im BIOS ist eingestellt:
UEFI/Legacy Boot [Both]
UEFI/Legacy Boot Priority [UEFI First]
Mit diesen Einstellungen wird in der Boot Device List auch der USB Stick angezeigt. Mit anderen Optionen nicht.

Der USB Stick hat eine LED und die ist immer an.
Aber wie schon geschrieben: Ich habe das Image auch auf DVD gebrannt. Da bin ich sicher, dass von der DVD gebootet wird, und auch da sehe ich nur den schwarzen Bildschirm mit "Welcome to GRUB!"


Offline axt

  • User
  • Posts: 478
    • axebase.net
Re: Live Iso Xorg bootet nicht.
« Reply #5 on: 2020/12/01, 21:40:30 »
Stelle im UEFI ein: Legacy only, also nur CSM, kein UEFI!

Mit F10 speichern und beenden und mit gestecktem Stick gleich wieder ins UEFI gehen! Da Du mit dd geschrieben hast, der Stick somit mit UEFI und CSM boot-fähig ist, steht er jetzt unter HDD. Dort setzt Du ihn an erste Stelle.

Offline snow_freak

  • User
  • Posts: 64
Re: Live Iso Xorg bootet nicht.
« Reply #6 on: 2020/12/01, 21:53:06 »
Ich habe auf legacy only gestellt.
Wenn ich dann starte taucht der Stick überhaupt nicht im Boot Menü auf. Kann also gar nicht gebootet werden.
In der Boot Priority Order steht USD HDD ganz oben.

Offline axt

  • User
  • Posts: 478
    • axebase.net
Re: Live Iso Xorg bootet nicht.
« Reply #7 on: 2020/12/01, 22:03:38 »
Er taucht nicht namentlich auf. Ich habe schon unzählige BIOS-/UEFI-Versionen vor der Nase gehabt, täglich seit Jahrzehnten, kann nicht sämtliche Eventualitäten auf's Pixel genau aufzählen (so habe ich bspw. F10 für "save & exit" geschrieben, es gibt aber auch F4, selbst an so einem Rechner gesessen).

Mit anderen Worten, ist der Stick CSM-boot-fähig, kann das Mainboard es (und ein mindestens 7 Jahre altes kann es noch, nur bei wirklich aktuellen wird das weggelassen), kannst Du es auch einstellen.

Und Du mußt eben mal die Menus durchgehen.

Meist kann man Startreihenfolge der Devices ändern (ODD/HDD/PXE) und dann in einem separaten HDD-Menu die HDD/SSD wählen. Da der Stick als HDD eingerichtet und als solcher erkannt wird, steht er logischerweise unter HDDs.

Offline snow_freak

  • User
  • Posts: 64
Re: Live Iso Xorg bootet nicht.
« Reply #8 on: 2020/12/02, 11:22:35 »
Anscheinend schließen sich lagacy boot und USB aus! Mit der lagacy boot Option und dem iso auf DVD startet das Live System.
Die Installation ist ohne murren durchgelaufen.


ABER: das neue System startet nicht von der Festplatte. Der Laptop startet immer wieder neu und geht dann ins Boot Menü. Wenn ich die Festplatte zum booten auswähle, geht er wieder ins Boot Menü.
Hat dafür jemand einen Tip?

Offline axt

  • User
  • Posts: 478
    • axebase.net
Re: Live Iso Xorg bootet nicht.
« Reply #9 on: 2020/12/02, 13:23:41 »
Quote from: snow_freak
Anscheinend schließen sich lagacy boot und USB aus!

Nein. Nicht, wenn der Stick hybrid oder für CSM eingerichtet und so geflasht ist. Es ist allerdings möglich, daß nur von einem bestimmten USB-Port gebootet werden kann. Sowas probiert man im Zweifel aber mal aus.

Quote
das neue System startet nicht von der Festplatte.

Grub muß korrekt geschrieben worden sein, auf /dev/sda (wenn das das HDD/SSD ist) und nicht etwa /dev/sda1, CSM muß selbstverständlich weiterhin ausgewählt sein.
« Last Edit: 2020/12/02, 13:27:07 by axt »

Offline snow_freak

  • User
  • Posts: 64
Re: Live Iso Xorg bootet nicht.
« Reply #10 on: 2020/12/02, 20:22:58 »
Ich habe alle Ports ausprobiert. Es geht nicht.

Was das booten des neu installierten Systems betrifft: ich habe nach der Anleitung

"Verwendung einer chroot-Umgebung zur Wiederherstellung eines überschriebenen oder korrumpierten Grub in MBR"
https://manual.siduction.org/sys-admin-grub2

Grub auf /dev/sda geschrieben. Das System startet immer noch nicht. :(