Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: My desktop environment, XFCE, freeze occasionally  (Read 396 times)

Offline vilde

  • User
  • Posts: 690
My desktop environment, XFCE, freeze occasionally
« on: 2021/01/09, 09:49:44 »
Today, for the third time in a while my desktop environment XFCE freeze and is not connectable. The first two times I did a hard reset, this time I tried "Ctrl+Alt+F5" and I did log in as root and made a "reboot"
When it happens I do have maybe +10 different Firefoxs windows open, Gramps, Transmission and Virtualbox running W10. Unfortunately I do have to use W10 to run some genealogy tools/registers, I haven't found any other way to do that.

I do a lot of "copy and paste" from V-Box/Win 10 to my XFCE environment and  I do have problems with that, because after a while the "copy and paste" doesn't work anymore and my computer starts to run very slowly, it helps to clean from clipboard on both environments then and then but it still is problematic. I just cleaned the clipboards before the last freeze. I believe that this anyway maybe can be the cause of the freeze also.
The computer runs always, it's nearly only shut of/rebooted when I do a D-U, and that's not that often ;)
I will try to remember to shut down V-Box during the night, maybe it helps?

What can I do to find out what's happening?
Can I do something from the virtual terminal? Close/kill V-Box ore anything else. A log to pin down the problem?
My environment:
  Host: vilde-master Kernel: 5.10.3-towo.1-siduction-amd64 x86_64 bits: 64
  compiler: gcc v: 10.2.1 Desktop: Xfce 4.16.0
  Distro: siduction 18.3.0 Patience - xfce - (202007152111)
  base: Debian GNU/Linux bullseye/sid
  Type: Laptop System: LENOVO product: 23471C4 v: ThinkPad T430
  serial: <superuser required>
  Mobo: LENOVO model: 23471C4 serial: <superuser required>
  UEFI [Legacy]: LENOVO v: G1ETB8WW (2.78 ) date: 09/19/2018
  ID-1: BAT0 charge: 17.6 Wh condition: 17.6/56.2 Wh (31%)
  model: SANYO 45N1001 status: Full
  Info: Dual Core model: Intel Core i5-3320M bits: 64 type: MT MCP
  arch: Ivy Bridge rev: 9 L2 cache: 3 MiB
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20752
  Speed: 1598 MHz min/max: 1200/3300 MHz Core speeds (MHz): 1: 1598 2: 1794
  3: 1787 4: 1724
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo
  driver: i915 v: kernel bus ID: 00:02.0
  Device-2: Chicony Thinkpad T430 camera type: USB driver: uvcvideo
  bus ID: 1-1.6:7
  Display: x11 server: X.Org 1.20.10 driver: modesetting
  unloaded: fbdev,vesa resolution: 1920x1200~60Hz
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2)
  v: 4.2 Mesa 20.2.6 direct render: Yes
  Device-1: Intel 82579LM Gigabit Network vendor: Lenovo driver: e1000e
  v: kernel port: 6080 bus ID: 00:19.0
  IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: 28:d2:44:01:d9:47
  Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
  v: kernel port: efa0 bus ID: 03:00.0
  IF: wlp3s0 state: down mac: 9e:44:33:c7:06:5b
  Local Storage: total: 2.2 TiB used: 209.06 GiB (9.3%)
  Processes: 198 Uptime: 36m Memory: 15.32 GiB used: 7.49 GiB (48.9%)
  Init: systemd runlevel: 5 Compilers: gcc: 10.2.1 Packages: 2145
  Shell: Bash v: 5.1.0 inxi: 3.2.01

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.144
    • Land of the Buckeye
Re: My desktop environment, XFCE, freeze occasionally
« Reply #1 on: 2021/01/09, 11:04:29 »
Quote from: vilde
I do have maybe +10 different Firefoxs windows open, Gramps, Transmission and Virtualbox running W10. Unfortunately I do have to use W10 to run some genealogy tools/registers, I haven't found any other way to do that.

Hi vilde --. I also use my siduction system for genealogy work, and I also need a Win10 VM to run my tools. I first ran Win7 on VMware and that was great when it worked, but VMware's kernel module builder is fragile and breaks every time there is a change in the kernel. I gave Vbox a try, but it seemed to have a lot of demands for tweaking things to keep it going. About 2014 I "bit the bullet" and worked my way through installation of qemu and kvm and their dependencies, made a bridge network, and got my first Win8 VM up and running. Since that time, and continuing with Win10, I have had only a couple of problems, and always found a fix for the issue.

I think the online documentation for a Qemu/KVM setup on Debian is much better today -- I would encourage you to take a good look at it. PM me if you need more info.

Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD2003FZEX in BTRFS