Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: Zim and autolinking  (Read 2227 times)

Offline orinoco

  • User
  • Posts: 179
Zim and autolinking
« on: 2021/01/24, 22:06:37 »
Hello,

I use the latest zim (0.73.4) as a notepad for my daily work. So far so good.

If I add text like www.example.com it will be converted to a link after hitting enter. But after saving the whole document a new and empty node www.example.com will be created on the left pane, too.

In this case I want to document all the sub-domains of a webserver. No intend to build a linklist etc.

It looks to me that zim assume that I want to add a new subpage. How can I prevent this annoying behavior?

I tried to disable "camel case to link" and "autolink files" in preferences but it doesn't help.

I also tried "remove link" from context menu with no success. The link format has gone but the node is still there.

How can I disable this "feature"? Or disable all the automatic stuff in general?

I added a screenshot to give you an idea of how it looks like. Please ignore the poor contrast, because I'm still experimenting for a propper dark theme with Plasma Dark-Breeze. But this is a different story.

Offline der_bud

  • User
  • Posts: 986
  • member
Re: Zim and autolinking
« Reply #1 on: 2021/01/25, 08:59:51 »
I can't help in disabling that, but can confirm that it happens here too with 0.73.4 and the same in a portable install on windows.

My observation is that that happens on URLs without http(s), so your
Code: [Select]
www.example.com
    as well as
en.wikipedia.org/wiki/Network_analysis_(electrical_circuits)
show up in the page index pane. If I change both to starting with http(s), eg
Code: [Select]
http://www.example.com
 and
https://en.wikipedia.org/wiki/Network_analysis_(electrical_circuits)
, they disappear in the index.
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.