Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [solved] Sound Kartenzuordnung Pulse/Alsa beheben mit HDA JackRetask  (Read 407 times)

Offline der_bud

  • User
  • Posts: 1.015
  • member
Einer unserer User im IRC hatte Probleme mit nicht mehr funktionierender Soundausgabe, diverse Fehlerbehebungsversuche im Chat schlugen fehl. Er hat dann per Archforum selber eine funktionierende Lösung gefunden, seine Anleitung/Notizen dazu auf Debians Pasteservice gepackt und im Chat verlinkt mit der Bemerkung "...Gerne weiterleiten oder auch ins Forum einbinden..." <=> Da der Pasteservice nach einem Tag "expired", bin ich mal so frei ;)   :
Quote from: michisiduction
Anleitung und Lösung für Sound-Problem nach Neuinstallation von Siduction 2021.01 "Farewell"/KDE/ AMD64

Folgende Schritte sind erforderlich, um bei fehlender Soundausgabe, die Verbindung zur Soundkarte
wieder herzustellen:


1) Als normaler "user", nicht "root"!!!
a)
$ systemctl --user mask pulseaudio.socket #unmask to revert
b)
$ systemctl --user stop pulseaudio.service

Jetzt ist pulseaudio "temporär" auf Eis gelegt und eine sich sonst einstellende Fehlermeldung
im nachfolgenden Programm "HDA JackRetask" sollte soweit ausbleiben.

Wichtig! Wir laden jetzt über apt-get das Programm "HDA JackRetask" (Paketname: alsa-tools-gui) in das installierte System dazu.

$ apt-get install alsa-tools-gui

Danach wird das Programm "HDA JackRetask" gestartet und wir wählen unsere individuelle Sound-Problemzone.
Bei mir waren es die Lautsprecher, zu der die Soundkarte -via ALSA und pulseaudio-
keine Verbindung aufgebaut hatte.
Los gehs--->
2)
Wir wählen den voreingestellten Codec aus:
VIA VT1808 (kommt möglicherweise auf die Soundkarte an, aber bei mir hat es funktioniert.)

Dann wählen wir bei:
InternalSpeaker
das Feld "Override"
aus.

Abschliessend bestätigen wir diese Auswahl rechts unten mit:
"Apply now"

Jetzt wird die Verbindung von ALSA/ pulseaudio zur Soundkarte -im Regelfall- wieder richtig erkannt.
Aber halt! Wir sind noch nicht ganz fertig!

Jetzt müssen wir über die Konsole wieder das pulseaudio-System "entmasken" und neustarten!
Dies erfolgt ebenfalls als normaler "user" (nicht root!) mit den beiden Befehlen:
3)

a)
$ systemctl --user unmask pulseaudio.socket
b)
$ systemctl --user start pulseaudio.service
c)
Wir verlassen die Konsole mit
$ exit

Abschliessend suchen wir uns nun einen Musiktitel oder eine Internetseite mit Video/ Audioinhalt und
testen, ob alles wieder richtig flutscht.
Jap, der Ton geht jetzt wieder "out of the box" ;)

Siductiöse Grüße! :)
michisiduction

Quelle:
https://bbs.archlinux.org/viewtopic.php?id=235854
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.