Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] [GELÖST]:GEDIT: Themes können nicht installiert werden  (Read 2290 times)

Offline Isegrimm666

  • User
  • Posts: 67
[DE] [GELÖST]:GEDIT: Themes können nicht installiert werden
« on: 2023/06/24, 09:28:06 »
Hallo zusammen ...

Ich habe mir jetzt einige Gedit-Themes runtergeladen (*.xml-Dateien) und in einem separaten Ordner abgespeichert.

Wenn ich in Gedit in ../Einstellungen/Schriften und Farben/ gehe, auf das "+" klicke, in den Ordner navigiere, das Theme auswähle und auf "Theme hinzufügen klicke", kommt die Fehlermeldung "Theme ist nicht installiert".

Natürlich ist es das nicht ... das soll ja erst passieren ... und nach einer Recherche im Netz ist das auch der Weg zur Installation.

Ein Rechteproblem liegt nicht vor ... ich bin der Eigentümer der *.xml-Dateien.

Woran kann's liegen?

Update (25.06.2023, 08:02h):
Lösung



« Last Edit: 2023/06/25, 08:03:20 by Isegrimm666 »

Offline unklarer

  • User
  • Posts: 806
Re: GEDIT: Themes können nicht installiert werden
« Reply #1 on: 2023/06/24, 09:59:29 »
Ich benutze kein gedit.

Schon mal nachgeschaut?
Code: [Select]
[font=monospace][color=#000000]apt-cache depends gedit [/color]
gedit
  Hängt ab von: gedit-common
  Hängt ab von: gedit-common
  Hängt ab von: gir1.2-glib-2.0
  Hängt ab von: gir1.2-gtk-3.0
  Hängt ab von: gir1.2-gtksource-4
  Hängt ab von: gir1.2-pango-1.0
  Hängt ab von: gir1.2-peas-1.0
  Hängt ab von: gsettings-desktop-schemas
  Hängt ab von: iso-codes
  Hängt ab von: python3-gi
  Hängt ab von: python3-gi-cairo
  Hängt ab von: <python3:any>
    python3
  Hängt ab von: python3.11
  Hängt ab von: libamtk-5-0
  Hängt ab von: libatk1.0-0
  Hängt ab von: libc6
  Hängt ab von: libcairo2
  Hängt ab von: libgdk-pixbuf-2.0-0
  Hängt ab von: libgirepository-1.0-1
  Hängt ab von: libglib2.0-0
  Hängt ab von: libgspell-1-2
  Hängt ab von: libgtk-3-0
  Hängt ab von: libgtksourceview-4-0
  Hängt ab von: libpango-1.0-0
  Hängt ab von: libpeas-1.0-0
  Hängt ab von: libtepl-6-2
  Empfiehlt: yelp
  Empfiehlt: zenity
  Schlägt vor: gedit-plugins[/font]
[font=monospace]
[/font]

Offline Isegrimm666

  • User
  • Posts: 67
Re: GEDIT: Themes können nicht installiert werden
« Reply #2 on: 2023/06/24, 10:04:45 »
Gedit war bei der Basis-Installation von Siduction bei ... ich gehe davon aus, das alle Abhängigkeiten erfüllt sind.

Sonst läuft er ja ...:)

Offline edlin

  • User
  • Posts: 501
Re: GEDIT: Themes können nicht installiert werden
« Reply #3 on: 2023/06/24, 10:16:02 »
Ich hab mal gedit auf die Schnelle installiert und ein x-beliebiges Thema in mein Homeverzeichnis runtergeladen; konnte Thema problemlos hinzufügen und anwenden.

edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Offline Isegrimm666

  • User
  • Posts: 67
Re: GEDIT: Themes können nicht installiert werden
« Reply #4 on: 2023/06/24, 10:36:58 »
Ich habe Siduction aus den Test-Builds installiert (wg. "Cinnamon") ... vielleicht liegt da die Ursache.

Eben hatte ich auch versucht, R-Studio als *.deb zu installieren, ... ging nicht, unerfüllte Abhängigkeiten wg. zurückgehaltener Pakete.

Muß ich wohl etwas Geduld haben *g

Offline unklarer

  • User
  • Posts: 806
Re: GEDIT: Themes können nicht installiert werden
« Reply #5 on: 2023/06/24, 10:51:54 »
Weiterer Vorschlag.
Hast du denn gedit auch im Terminal aufgerufen und dann das Prozedere mit dem Thema gemacht?

nur ein Gedanke: Vielleicht ruft das Thema ja das falsche python auf.

Offline Isegrimm666

  • User
  • Posts: 67
Re: GEDIT: Themes können nicht installiert werden
« Reply #6 on: 2023/06/24, 11:02:04 »
Jup ... sogar als User und als root.

Ergebnis:


Offline edlin

  • User
  • Posts: 501
Re: GEDIT: Themes können nicht installiert werden
« Reply #7 on: 2023/06/24, 12:29:22 »
Dass das Testbuild von Cinnamon als Ursache in Frage kommt, mag ich bezweifeln. Es wird ja nicht auf geheime Cinnamon-Repos zugegriffen, sondern auf die gleichen Quellen, wie bei den anderen Geschmacksrichtungen von MoW auch.
Stellt sich eher die Frage, warum und welche Pakete zurückgehalten werden. Wird auch bei einem
Code: [Select]
apt update && apt upgrade etwas zurückgehalten oder werden evtl. ein paar Pakete aktualisiert?

edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Offline unklarer

  • User
  • Posts: 806
Re: GEDIT: Themes können nicht installiert werden
« Reply #8 on: 2023/06/24, 14:57:13 »
Jup ... sogar als User und als root.

Ergebnis:


Ich denke, die Ausgabe des Terminal ist bestimmt nicht so sinnfrei, wie dieses Bild.>:(

Offline edlin

  • User
  • Posts: 501
Ich habs mir angetan ...
« Reply #9 on: 2023/06/24, 15:32:52 »
Da draußen die Sonne scheint und Gruftis solch miserables Wetter hassen, hab ich mirs mal selbst gemacht:
1. siduction-22.1.2-Masters_of_War-cinnamon-amd64-202305281632.iso vom Stick gestartet.
2. Cinnamon installiert
3. apt update && apt full-upgrade ausgeführt
4. Thema für gedit geladen
5. gedit aufgerufen und Thema installiert.
6. Keine Probleme - ärgere mich gerade wegen des Aufwandes.

edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Offline Isegrimm666

  • User
  • Posts: 67
[GELÖST] GEDIT: Themes können nicht installiert werden
« Reply #10 on: 2023/06/25, 08:00:13 »
Guten Morgen zusammen ...

Ich muss mich bei allen Hilfeleistenden - und im Speziellen bei edlin für den Aufwand - entschuldigen.

Die Ursache war banaler als gedacht:

Die zuerst verwendeten *.xml-Files waren fehlerhaft ... ich habe mir neue Themefiles (von: https://github.com/ricardograca/gedit-themes) geladen ... und damit funktioniert es, wie es anfangs sollte.

:(

Offline edlin

  • User
  • Posts: 501
Re: [GELÖST]:GEDIT: Themes können nicht installiert werden
« Reply #11 on: 2023/06/25, 11:30:51 »
Keine Ursache. Dein Problem ist ja gelöst und ich machs ja freiwillig, schon aus Interesse. Und eine Testinstallation ist ja heute fix erledigt.
Bei der Wahl des Themas hatte ich halt Glück gehabt und mir zufällig eine funktionierende xml-Datei rausgepickt; im nächsten Schritt hätte ich die dir verlinkt, um Versionskonflikte etc. auszuschließen.

Schönen Sonntag noch.

edlin
 
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates