Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] SOLVED - FreeCAD 0.21. openGL-Problem  (Read 3614 times)

Offline klinkenberg

  • Newbie
  • Posts: 2
[EN] SOLVED - FreeCAD 0.21. openGL-Problem
« on: 2023/08/03, 12:53:20 »
At a current system I can not start the new FreeCAD-0.21-appimage, it stops with an openGL-error as follows:


klinkenberg@kli:~/Downloads$ ./FreeCAD_0.21.0-Linux-x86_64.AppImage
FreeCAD 0.21.0, Libs: 0.21.0R33675 (Git)
© Juergen Riegel, Werner Mayer, Yorik van Havre and others 2001-2023
FreeCAD is free and open-source software licensed under the terms of LGPL2+ license.
FreeCAD wouldn't be possible without FreeCAD community.
  #####                 ####  ###   #### 
  #                    #      # #   #   #
  #     ##  #### ####  #     #   #  #   #
  ####  # # #  # #  #  #     #####  #   #
  #     #   #### ####  #    #     # #   #
  #     #   #    #     #    #     # #   #  ##  ##  ##
  #     #   #### ####   ### #     # ####   ##  ##  ##

libGL error: MESA-LOADER: failed to open nouveau: /tmp/.mount_FreeCAEemDMR/usr/bin/../lib/libstdc++.so.6: version `GLIBCXX_3.4.32' not found (required by /lib/x86_64-linux-gnu/libLLVM-15.so.1) (search paths /usr/lib/x86_64-linux-gnu/dri:\$${ORIGIN}/dri:/usr/lib/dri, suffix _dri)
libGL error: failed to load driver: nouveau
libGL error: MESA-LOADER: failed to open nouveau: /tmp/.mount_FreeCAEemDMR/usr/bin/../lib/libstdc++.so.6: version `GLIBCXX_3.4.32' not found (required by /lib/x86_64-linux-gnu/libLLVM-15.so.1) (search paths /usr/lib/x86_64-linux-gnu/dri:\$${ORIGIN}/dri:/usr/lib/dri, suffix _dri)
libGL error: failed to load driver: nouveau
libGL error: MESA-LOADER: failed to open swrast: /tmp/.mount_FreeCAEemDMR/usr/bin/../lib/libstdc++.so.6: version `GLIBCXX_3.4.32' not found (required by /lib/x86_64-linux-gnu/libLLVM-15.so.1) (search paths /usr/lib/x86_64-linux-gnu/dri:\$${ORIGIN}/dri:/usr/lib/dri, suffix _dri)
libGL error: failed to load driver: swrast
2.175107 <asm3.main> init_gui.py(14): no solver backend found
WebEngineContext used before QtWebEngine::initialize() or OpenGL context creation failed.
QGLXContext: Failed to create dummy context
Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples 0, swapBehavior QSurfaceFormat::DefaultSwapBehavior, swapInterval 1, colorSpace QSurfaceFormat::DefaultColorSpace, profile  QSurfaceFormat::NoProfile)
/tmp/.mount_FreeCAEemDMR/AppRun: Zeile 43: 63232 Abgebrochen             ${MAIN} "$@"

Who knows more?


This is my system:
linkenberg@kli:~$ inxi -v3
System:
  Host: kli Kernel: 6.4.7-1-siduction-amd64 arch: x86_64 bits: 64
    compiler: gcc v: 13.1.0 Desktop: KDE Plasma v: 5.27.5 Distro: siduction
    13.2.1 December - kde - (201401272125) base: Debian GNU/Linux trixie/sid
Machine:
  Type: Desktop System: Dell product: Vostro 420 Series v: N/A
    serial: <superuser required>
  Mobo: Dell model: 0R038D v: A00 serial: <superuser required> BIOS: Dell
    v: 1.1.4 date: 04/17/2009
CPU:
  Info: quad core model: Intel Core2 Quad Q9550 bits: 64 type: MCP
    arch: Penryn rev: A cache: L1: 256 KiB L2: 12 MiB
  Speed (MHz): avg: 2436 high: 2826 min/max: 1995/2828 cores: 1: 2826
    2: 2826 3: 2100 4: 1995 bogomips: 22608
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx
Graphics:
  Device-1: NVIDIA GP108 [GeForce GT 1030] vendor: Gigabyte driver: nouveau
    v: kernel arch: Pascal bus-ID: 01:00.0 temp: 39.0 C
  Device-2: SunplusIT USB 2.0 Camera driver: snd-usb-audio,uvcvideo
    type: USB bus-ID: 3-4:4
  Display: x11 server: X.Org v: 1.21.1.8 with: Xwayland v: 22.1.9 driver: X:
    loaded: modesetting unloaded: fbdev,vesa dri: nouveau gpu: nouveau
    resolution: 1: 1920x1200~60Hz 2: 1920x1200~60Hz
  API: OpenGL v: 4.3 Mesa 23.1.4-1 renderer: NV138 direct-render: Yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Dell driver: r8169 v: kernel port: e800 bus-ID: 04:00.0
  IF: eth0 state: up speed: 100 Mbps duplex: full mac: 00:21:9b:1d:9e:8c
  IF-ID-1: docker0 state: down mac: 02:42:39:6a:07:b4
  IF-ID-2: virbr0 state: down mac: 52:54:00:e9:0e:56
  IF-ID-3: wlx1cbfceb0c010 state: up mac: 1c:bf:ce:b0:c0:10
Drives:
  Local Storage: total: 532.84 GiB used: 364.45 GiB (68.4%)
Info:
  Processes: 294 Uptime: 0m Memory: total: 8 GiB available: 7.76 GiB
  used: 2.44 GiB (31.5%) Init: systemd target: graphical (5) Compilers:
  gcc: 13.2.0 Packages: 4800 Shell: Bash v: 5.2.15 inxi: 3.3.28
« Last Edit: 2023/08/07, 13:41:18 by klinkenberg »

Offline edlin

  • User
  • Posts: 599
Re: FreeCAD 0.21. openGL-Problem
« Reply #1 on: 2023/08/05, 11:10:20 »
Try starting the AppImage with the following line:

Code: [Select]
LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libstdc++.so.6 /opt/FreeCad/FreeCAD_0.21.0-Linux-x86_64.AppImage
Of course, you still have to adjust the path if necessary.

I found the tip at:

https://debianforum.de/forum/viewtopic.php?t=183776#p1297463

I hope it helps you, I was able to start FreeCAD without any problems.


edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Offline klinkenberg

  • Newbie
  • Posts: 2
Re: FreeCAD 0.21. openGL-Problem
« Reply #2 on: 2023/08/07, 13:40:14 »
Thanks! Worked for me.