Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic:  WiFi im Bootvorgang deaktivieren  (Read 1317 times)

Offline knorki

  • User
  • Posts: 74
WiFi im Bootvorgang deaktivieren
« on: 2024/02/25, 07:47:49 »
Hallo,
mein neuer Laptop hat kein Netzwerk Kabelanschluss mehr, nur noch WiFi.
Ich verwende XFCE mit Netzwerk Standard Einstellungen.
Bei Bootvorgang wird automatisch WiFi aktiviert.
Wie müssen die nm-settings geändert werden, damit nicht schon beim booten eine WiFi -Verbindung hergestellt wird.
Die nm-settings ist komplett in englisch und so umfangreich, das ich damit überfordert bin.
   

Offline ro_sid

  • User
  • Posts: 228
Re: WiFi im Bootvorgang deaktivieren
« Reply #1 on: 2024/02/25, 15:08:43 »
Ein Weg ist :
Quote
How to disable wireless from command line [https://askubuntu.com/questions/597116/how-to-disable-wireless-from-command-line]

Code: [Select]
nmcli radio wifi off
Vielleicht gibt es eine Datei, die das konfiguriert, aber das kann ich zur Zeit nicht nachsehen.

Offline scholle1

  • User
  • Posts: 87
Re: WiFi im Bootvorgang deaktivieren
« Reply #2 on: 2024/02/25, 22:23:13 »
Am einfachsten im NM-Applet
  [ You are not allowed to view this attachment ]  
Einen Rechtsklick darauf und vor "Funknetzwerk aktivieren" das Häkchen entfernen. Das wird bei einem Reboot berücksichtigt.
Willst du WIFI aktiv lassen, aber die Automatische Verbindung zu einem (oder mehreren) bekannten Netzwerk abschalten, auch einen Rechtsklick auf das NM-Applet und dann "Verbindungen bearbeiten ..." auswählen, Netzwerk auswählen und im Reiter "Allgemein" die Option "Automatisch mit Priorität verbinden" abschalten.
Je mehr Bürgerinnen und Bürger mit Zivilcourage ein Land hat, desto weniger Helden wird es einmal brauchen.
(Franka Magnani)

Offline knorki

  • User
  • Posts: 74
Re: WiFi im Bootvorgang deaktivieren
« Reply #3 on: 2024/02/26, 08:15:02 »
@ scholle1
Die Einstellung htte ich auch schon gemacht, aber manchmal vergisst  das NM-Applet die Einstellung und nach dem booten ist das wifi bereits aktiv.
Ich habe jedoch noch nicht darauf geachtet ob dies speziell nach einem Ubdate der Fall ist, das fällt mir gerade so ein.

Offline hendrikL

  • Administrator
  • User
  • *****
  • Gravatar
  • Posts: 947
Re: WiFi im Bootvorgang deaktivieren
« Reply #4 on: 2024/02/26, 08:34:32 »
Frage, hat das Laptop einen Hardwareschalter, also um das WIFI Modul abzustellen?
Wenn nicht, um während des boot Vorganges das WiFi abzustellen, muss man entweder via nmcli das ganze deaktivieren, oder man deaktiviert es softwaretechnisch via "rfkill block".  "rfkill list", listet alle Verbindungsarten auf, dann rfkill block "die Zahl, die vor Wireless lan" steht, mit rfkill unblock Zahl, hebt man das wieder auf. Dans ganze als root. rfkill help ist auch nützlich!
« Last Edit: 2024/02/26, 08:39:33 by hendrikL »

Offline ro_sid

  • User
  • Posts: 228
Re: WiFi im Bootvorgang deaktivieren
« Reply #5 on: 2024/02/26, 10:35:09 »
Aber nmcli ist doch auch eine softwaretechnische Lösung :), es wird lediglich der Chip deaktiviert.

Ernsthafter: Die einzige vorgesehene Einstellungsmöglichkeit die ich gefunden habe, ist per /etc/NetworkManager/NetworkManager.conf[.d/...]. Mir ist aber nicht klar, ob und wie man dort WiFi ausschalten kann.
Ein /etc/default/[...] scheint es für den NetworkManager nicht zu geben.

Bliebe nur noch, das nmcli-Kommando in eine Boot-rc-Datei einzutragen - oder eben rfkill.

Offline hendrikL

  • Administrator
  • User
  • *****
  • Gravatar
  • Posts: 947
Re: WiFi im Bootvorgang deaktivieren
« Reply #6 on: 2024/02/26, 11:15:31 »
@ro_sid, rfkill will nicht so wie ich wohl will, nun werde ich auch nicht allzu viel Zeit daran verschwenden, vielleicht später.

Die Lösung mit nmcli sollte funzen, ich habe mal das Ganze mit nmtui probiert, geht auch, via der Radio Einstellungen.
Wobei die nmcli Lösung wesentlich schneller ist. :)


Offline der_bud

  • User
  • Posts: 1.073
  • member
Re: WiFi im Bootvorgang deaktivieren
« Reply #7 on: 2024/02/26, 11:31:12 »
Weitere Möglichkeit: vielleicht das für Laptops ohnehin nützliche Tool "tlp" aus den Debian-Repos installieren [1] [2], dort dann in der /etc/tlp.conf zum [3] Beispiel
Code: [Select]
DEVICES_TO_DISABLE_ON_STARTUP="bluetooth wifi wwan" eintragen.

Tipp: tlp stellt auch kleine Wraper zur Verfügung, so dass man einfach im Terminal z.B. mit "wifi on" "wifi off" "wifi toggle" umswitchen kann [4]


[1] https://packages.debian.org/sid/tlp
[2] https://linrunner.de/tlp/index.html
[3] https://linrunner.de/tlp/settings/radio.html#devices-to-disable-on-startup
[4] https://linrunner.de/tlp/usage/radio.html#bluetooth-nfc-wifi-wwan
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline ro_sid

  • User
  • Posts: 228
Re: WiFi im Bootvorgang deaktivieren
« Reply #8 on: 2024/02/26, 11:52:31 »
@der_bud: Vielen Dank für den Tipp mit "tip".
tip hatte ich bisher nicht auf dem Radar. Seit systemd ist ja das Eingreifen in Bootvorgänge erheblich komplizierter geworden. Sowas hilft (mir) da.

Offline der_bud

  • User
  • Posts: 1.073
  • member
Re: WiFi im Bootvorgang deaktivieren
« Reply #9 on: 2024/02/26, 15:57:21 »
Kurzer Hinweis: kleines L, nicht i, also T L P, sonst quakt apt install... ;)
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline ro_sid

  • User
  • Posts: 228
Re: WiFi im Bootvorgang deaktivieren
« Reply #10 on: 2024/02/26, 16:16:31 »
Hach, dann paßt mein Wortwitz ja gar nicht :o.
Aber danke für den Hinweis.

Offline knorki

  • User
  • Posts: 74
Re: WiFi im Bootvorgang deaktivieren, gelöst
« Reply #11 on: 2024/02/26, 20:30:09 »
Danke für die Tips, TLP klappt prima.
Allerdings muß ich vor dem reboot oder shutdown expliziet  "Netzwerke aktivieren" abwählen (also Häcken weg).
Das ist aber ok so.