Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [SOLVED] Systemd-fsck stops boot when 2:hd is gone  (Read 3856 times)

Offline vilde

  • User
  • Posts: 690
I did a new installation some days ago and I have one extra hd in my laptop, this time the extra hd was there when I did the installation, that has been so before but this was the first time I installed with systemd from the beginning.

Today when I removed the extra hd and put the cd/dvd drive in instead the computer stops during boot. The last I can see is systemd-fsck ......something, then it stops. The extra hd has ntfs and an installation of an ugly os that I will not mention by name here and has not been written on during installation.

Putting back the extra hd and boot will work as it should.

I have no idea if this is a bug or what?

(XFCE 32 bit on a 64 bit computer.)
« Last Edit: 2014/04/08, 07:39:19 by vilde »

Offline GoinEasy9

  • User
  • Posts: 487
Re: Systemd-fsck stops boot when 2:hd is gone
« Reply #1 on: 2014/04/07, 23:55:07 »
I'm thinking that the second HD has a line in /etc/fstab, and, that's what causing the problem.  You might want to change the option "auto" in that line to "nofail" and see if that helps. 
Linux Counter number 348347

Offline vilde

  • User
  • Posts: 690
Re: Systemd-fsck stops boot when 2:hd is gone
« Reply #2 on: 2014/04/08, 07:37:49 »
I'm thinking that the second HD has a line in /etc/fstab, and, that's what causing the problem.  You might want to change the option "auto" in that line to "nofail" and see if that helps.
You where thinking very right GoinEasy9, that did the trick.  :)