Welcome, Guest. Please login or register.
Did you miss your activation email?

Recent Posts

Pages: 1 2 3 [4] 5 6 ... 10
31
Software - Support / Re: mount of iso image failed on current kernel
« Last post by towo on 2024/04/03, 20:01:16 »
Code: [Select]
sudo mount -o loop,ro grub.iso /mnt
Should do the trick.
32
Software - Support / mount of iso image failed on current kernel
« Last post by Teriarch on 2024/04/03, 18:21:08 »
I booted the system under exactly equal environments and tried to mount an iso image:

$ sudo mount grub.iso /mnt

With kernel 6.7.10-1-siduction-amd64 the call succeeded. With kernel 6.8.2-1-siduction-amd64 it failed:

mount: /mnt: /dev/loop0 already mounted or mount point busy.
       dmesg(1) may have more information after failed mount system call.

When I replaced the kernel under exactly the same environment with some other 6.8 kernel the call
succeeded again. I tried several times to be sure. I compared the kernel configs and the offending
configuration value seems to be:

# CONFIG_BLK_DEV_WRITE_MOUNTED is not set (for the siduction 6.8 kernel
CONFIG_BLK_DEV_WRITE_MOUNTED=y (for the other 6.8 kernel)

Can someone confirm the findings (you can try the Giants ISO image) and maybe remedy
the problem? The snapd depends on mounting read only  images and fails e.g. for the skype app.
33
Software - Support / Re: Nouveau ----> Nvidia, trouble changing driver
« Last post by dibl on 2024/04/03, 13:51:34 »
... if it (=nvidia(-current)) is (now) really included in the initramfs-image, you might be able to use the "module-load=nvidia-current" kernel option now with grub.

Tried this -- after unloading nouveau, and building nvidia-current, and "modprobe nviidia-current", I updated initramfs, edited the grub-cmd line, updated grub, and rebooted.

nouveau driver was automatically loaded and working beautifully.    :'(
34
Software - Support / Re: Nouveau ----> Nvidia, trouble changing driver
« Last post by dibl on 2024/04/03, 10:55:54 »
.... you might be able to use the "module-load=nvidia-current" kernel option now with grub.

I will test that today.

Quote
... it should work fine as long as there is no "3d-fast-action" required (e.g. in games) and no GPU-computations or "-multi-media-live-decodings".

I don't need Cuda or the most extreme capabilities of the Nvidia driver. It's just been my habit for many years to run the desktops with Nvidia graphics and their driver. It won't cause any problem to use Nouveau.

Thank you, @ro_sid, for your attention and ideas.   :D
35
Software - Support / iptables - portforward
« Last post by hsp on 2024/04/03, 10:26:26 »
Ich habe mir nach dieser Anleitung für libvirt ein hookscript angelegt für qemu zum portforward für ssh (NAT Network). Funktioniert auch bestens. Aber was nicht geht ist eine Verbindung von localhost (ssh -p 2222 localhost). Ich habe keine Ahnung waum. Jemand eine Idee was fehlt oder falsch ist?

https://wiki.libvirt.org/Networking.html#forwarding-incoming-connections

Hier der hookscript
Code: [Select]
#!/bin/bash
#
if [ "${1}" = "foobarbox" ]; then
#
# Update the following variables to fit your setup
GUEST_IP="192.168.122.19"
GUEST_PORT="22"
HOST_PORT="2222"
BRIDGE="virbr0"
#
    if [ "${2}" = "stopped" ] || [ "${2}" = "reconnect" ]; then
        /usr/sbin/iptables -D FORWARD -o $BRIDGE -d $GUEST_IP -j ACCEPT
        /usr/sbin/iptables -t nat -D PREROUTING -p tcp --dport $HOST_PORT -j DNAT --to $GUEST_IP:$GUEST_PORT
    fi
#
    if [ "${2}" = "start" ] || [ "${2}" = "reconnect" ]; then
        /usr/sbin/iptables -I FORWARD -o $BRIDGE -d $GUEST_IP -j ACCEPT
        /usr/sbin/iptables -t nat -I PREROUTING -p tcp --dport $HOST_PORT -j DNAT --to $GUEST_IP:$GUEST_PORT
    fi
fi


Danke...
36
Software - Support / Re: Nouveau ----> Nvidia, trouble changing driver
« Last post by ro_sid on 2024/04/03, 01:33:11 »
[...]
The command
Code: [Select]
modprobe nvidia-current returns quickly to the prompt with no feedback or error message.  However, lsmod shows no loaded nvidia modules.
I have never experienced such a result! Either "modprobe" complained in some way (e.g. no "such" hardware available), or the corresponding module had been loaded, though not necessarily being "in use" (i.e. a "0" and no "using modules" shown by lsmod).
Quote
I have rebuilt the initramfs at this point, but of course that has no effect.
Well, if it (=nvidia(-current)) is (now) really included in the initramfs-image, you might be able to use the "module-load=nvidia-current" kernel option now with grub.
Once this really works as desired, we can get rid of all the grub options, because as @towo already pointed out, a proper install should set this up automatically. But first we need a proof of concept.
Quote
So, I am now officially in the nouveau-lovers club.   ;D
Well, as far as I have read - but not experienced -, it should work fine as long as there is no "3d-fast-action" required (e.g. in games) and no GPU-computations or "-multi-media-live-decodings".
37
Upgrade Warnings / Re: Attention! Malicious Software in testing and sid
« Last post by finotti on 2024/04/02, 23:37:34 »
This appears in my Google News: https://www.bleepingcomputer.com/news/security/new-xz-backdoor-scanner-detects-implant-in-any-linux-binary/amp/  It refers to this scanner for vulnerability: https://xz.fail/ 

Does anyone know if it is trustworthy?  I had never heard of binarly...

Edit: I suppose it does not matter, as certainly Debian's versions should be fine.
38
Software - Support / Re: Nouveau ----> Nvidia, trouble changing driver
« Last post by dibl on 2024/04/02, 21:47:53 »
I have discovered that with "nomodeset" included in the grub command options line, it is possible to rmmod nouveau after booting to runlevel 3, tty1. This tty goes black, but then I can use another tty to log in and isolate the multi-user target, which will give you back tty1.  lsmod verifies that nouveau is not loaded.

Then I can use either of towo's commands to build the nvidia modules. It shows they are installed in their correct directory.

The command
Code: [Select]
modprobe nvidia-current returns quickly to the prompt with no feedback or error message.  However, lsmod shows no loaded nvidia modules.

I have rebuilt the initramfs at this point, but of course that has no effect.

So, I am now officially in the nouveau-lovers club.   ;D
39
Software - Support / Login Manager not working with Nvidia Driver
« Last post by Sir_Aim on 2024/04/02, 17:17:42 »
Hi, I did a fresh install this weekend, and all seems to be fine - but after I switched to the Nvidia Driver I can not log in from the graphical login manager.

After login the screen turns black for a few seconds and throws me back to the login screen...
When I login in a new terminal and launch KDE with startx it works without a promblem.

Does anyone know this issue and how to fix it?

Code: [Select]
System:
  Host: i9 Kernel: 6.8.2-1-siduction-amd64 arch: x86_64 bits: 64 compiler: gcc
    v: 14.0.1
  Desktop: KDE Plasma v: 5.27.10 Distro: siduction 2023.1.1 giants - kde -
    (202403291554) base: Debian GNU/Linux trixie/sid
Machine:
  Type: Desktop Mobo: ASUSTeK model: PRIME Z370-A II v: Rev X.0x
    serial: <superuser required> UEFI-[Legacy]: American Megatrends v: 0602
    date: 03/12/2019
CPU:
  Info: 8-core model: Intel Core i7-9700K bits: 64 type: MCP arch: Coffee Lake
    rev: D cache: L1: 512 KiB L2: 2 MiB L3: 12 MiB
  Speed (MHz): avg: 800 min/max: 800/4900 cores: 1: 800 2: 800 3: 800 4: 800
    5: 800 6: 800 7: 800 8: 800 bogomips: 57600
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: NVIDIA TU116 [GeForce GTX 1660 Ti] vendor: ASUSTeK driver: nvidia
    v: 550.67 arch: Turing bus-ID: 01:00.0
  Display: server: X.Org v: 21.1.11 with: Xwayland v: 23.2.4 driver: X:
    loaded: nvidia unloaded: fbdev,modesetting,nouveau,vesa gpu: nvidia
    resolution: 1: 1920x1200~60Hz 2: 1920x1200~60Hz 3: 1920x1200~60Hz
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.67
    glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce GTX 1660 Ti/PCIe/SSE2

40
You are right.
I have the nvidia debian repository because I have cuda installed so this is the reason why I am not getting the siduction package.

I will wait for nvidia do update those packages for the latest linux kernel.
Pages: 1 2 3 [4] 5 6 ... 10