Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: libelf1:i386 update error  (Read 685 times)

Offline xChris

  • User
  • Posts: 12
libelf1:i386 update error
« on: 2021/02/05, 13:15:45 »
Hi,

I tried to do a apt update/upgrade and stops there, Can I force the installation? thanks!



Code: [Select]
The following packages have unmet dependencies:
 libdw1:i386 : Depends: libelf1:i386 (= 0.182+20210203-1.1) but 0.182+20210203-1 is installed
 libelf1 : Breaks: libelf1:i386 (!= 0.182+20210203-1.1) but 0.182+20210203-1 is installed
 libelf1:i386 : Breaks: libelf1 (!= 0.182+20210203-1) but 0.182+20210203-1.1 is installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
$ sudo apt -fix-broken install
E: Command line option 'i' [from -fix-broken] is not understood in combination with the other options.
$ sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  linux-headers-5.10.11-towo.1-siduction-amd64 linux-image-5.10.11-towo.1-siduction-amd64
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libelf1:i386
The following packages will be upgraded:
  libelf1:i386
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
60 not fully installed or removed.
Need to get 0 B/171 kB of archives.
After this operation, 1,024 B of additional disk space will be used.
Do you want to continue? [Y/n]
(Reading database ... 329349 files and directories currently installed.)
Preparing to unpack .../libelf1_0.182+20210203-1.1_i386.deb ...
Unpacking libelf1:i386 (0.182+20210203-1.1) over (0.182+20210203-1) ...
dpkg: error processing archive /var/cache/apt/archives/libelf1_0.182+20210203-1.1_i386.deb (--unpack):
 trying to overwrite shared '/usr/share/locale/en@boldquot/LC_MESSAGES/elfutils.mo', which is different from other instances of package libelf1:i386
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libelf1_0.182+20210203-1.1_i386.deb
needrestart is being skipped since dpkg has failed
E: Sub-process /usr/bin/dpkg returned an error code (1)



Online towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.507
Re: libelf1:i386 update error
« Reply #1 on: 2021/02/05, 13:19:15 »
Code: [Select]
mv /usr/share/locale/en@boldquot/LC_MESSAGES/elfutils.mo /usr/share/locale/en@boldquot/LC_MESSAGES/elfutils.mo-back && apt -f install
« Last Edit: 2021/02/05, 13:30:15 by towo »
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline xChris

  • User
  • Posts: 12
Re: libelf1:i386 update error
« Reply #2 on: 2021/02/05, 13:23:14 »
cheers! this worked!

Offline xChris

  • User
  • Posts: 12
Re: libelf1:i386 update error
« Reply #3 on: 2021/02/05, 13:33:45 »
hm.. something is broken with the 5.10.13 kernel , booting goes to a flickering SDDM, login flickers like hell I can't even login... so I am back to 5.10.12
(PC has i3-4160)

Online towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.507
Re: libelf1:i386 update error
« Reply #4 on: 2021/02/05, 14:32:30 »
1st, one thread for each problem
2nd, does
Code: [Select]
dmesg | egrep -i "warn|fail|error" show anything important?

Code: [Select]
System:    Host: Defiant Kernel: 5.10.13-towo.1-siduction-amd64 x86_64 bits: 64 Desktop: KDE Plasma 5.20.90
           Distro: siduction 18.3.0 Patience - kde - (202010061355)
Machine:   Type: Desktop System: CSL- & KG product: A0000001 v: N/A serial: <superuser required>
           Mobo: ASUSTeK model: ROG STRIX B450-F GAMING v: Rev 1.xx serial: <superuser required> UEFI: American Megatrends
           v: 4007 date: 12/08/2020
CPU:       Info: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP L2 cache: 4 MiB
           Speed: 1889 MHz min/max: 2200/3700 MHz Core speeds (MHz): 1: 1889 2: 1887 3: 2183 4: 2070 5: 1942 6: 2065 7: 2068
           8: 2191 9: 1886 10: 1886 11: 2139 12: 1887 13: 1889 14: 2192 15: 2193 16: 2188
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] driver: amdgpu
           v: kernel
           Display: x11 server: X.Org 1.20.10 driver: loaded: amdgpu,ati unloaded: fbdev,modesetting,vesa
           resolution: 1920x1080~60Hz
           OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.40.0 5.10.13-towo.1-siduction-amd64 LLVM 11.0.1)
           v: 4.6 Mesa 21.1.0-devel
Info:      Processes: 392 Uptime: 1m Memory: 31.34 GiB used: 1.61 GiB (5.1%) Shell: Bash inxi: 3.3.00

I can't see any problem here on my system.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline xChris

  • User
  • Posts: 12
Re: libelf1:i386 update error
« Reply #5 on: 2021/02/05, 14:36:32 »
opps sorry! its ok after a second reboot!

Offline Camelot

  • User
  • Posts: 53
Re: libelf1:i386 update error
« Reply #6 on: 2021/02/05, 17:10:37 »
My solution: I download libelf1_0.182+20210203-1.1+b1_i386.deb then overwrite elfutils.mo with

Code: [Select]
apt update //
dpkg -i --force-overwrite libelf1_0.182+20210203-1.1+b1_i386.deb && apt upgrade

And I think he means elfutils.mo.bak|.old not elfutils.mo-back?

Online towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.507
Re: libelf1:i386 update error
« Reply #7 on: 2021/02/05, 17:12:34 »
Names are smoke and mirrors, the main thing is that the file is no longer available.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline eriefisher

  • User
  • Posts: 67
Re: libelf1:i386 update error
« Reply #8 on: 2021/02/09, 13:06:19 »
There is also a version mis-match between 32 and 64 bit. I have i386 architecture enabled for a couple packages.
Code: [Select]
The following packages have unmet dependencies:
 libdw1:i386 : Depends: libelf1:i386 (= 0.182+20210203-1.1+b1) but 0.182+20210203-1 is installed
 libelf1 : Breaks: libelf1:i386 (!= 0.182+20210203-1.1+b1) but 0.182+20210203-1 is installed
 libelf1:i386 : Breaks: libelf1 (!= 0.182+20210203-1) but 0.182+20210203-1.1+b1 is installed