Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: qemu dependency issue blocking d-u  (Read 994 times)

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.117
    • Land of the Buckeye
qemu dependency issue blocking d-u
« on: 2021/03/13, 12:19:07 »
Since yesterday morning (U.S. Eastern), this is the situation:

Code: [Select]
Reading state information... Done
Calculating upgrade... Error!
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 qemu-system-common : Depends: qemu-system-x86 (= 1:5.2+dfsg-6+b1) but it is not going to be installed or
                               qemu-system-arm (= 1:5.2+dfsg-6+b1) but it is not going to be installed or
                               qemu-system-mips (= 1:5.2+dfsg-6+b1) but it is not going to be installed or
                               qemu-system-ppc (= 1:5.2+dfsg-6+b1) but it is not going to be installed or
                               qemu-system-sparc (= 1:5.2+dfsg-6+b1) but it is not going to be installed or
                               qemu-system-misc (= 1:5.2+dfsg-6+b1) but it is not going to be installed or
                               qemu-system-s390x (= 1:5.2+dfsg-6+b1) or
                               qemu-system-x86-xen (= 1:5.2+dfsg-6+b1) but it is not installable
 qemu-system-gui : Depends: qemu-system-x86 (= 1:5.2+dfsg-6+b1) but it is not going to be installed or
                            qemu-system-arm (= 1:5.2+dfsg-6+b1) but it is not going to be installed or
                            qemu-system-mips (= 1:5.2+dfsg-6+b1) but it is not going to be installed or
                            qemu-system-ppc (= 1:5.2+dfsg-6+b1) but it is not going to be installed or
                            qemu-system-sparc (= 1:5.2+dfsg-6+b1) but it is not going to be installed or
                            qemu-system-misc (= 1:5.2+dfsg-6+b1) but it is not going to be installed or
                            qemu-system-s390x (= 1:5.2+dfsg-6+b1) or
                            qemu-system-x86-xen (= 1:5.2+dfsg-6+b1) but it is not installable
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

A little investigation shows:

Code: [Select]
root@dibl-patience:/# apt policy qemu-system-x86
qemu-system-x86:
  Installed: 1:5.2+dfsg-6
  Candidate: 1:5.2+dfsg-6+b1
  Version table:
     1:5.2+dfsg-6+b1 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
 *** 1:5.2+dfsg-6 100
        100 /var/lib/dpkg/status

But:

Code: [Select]
root@dibl-patience:/# apt install --reinstall qemu-system-x86
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 qemu-system-data : Depends: qemu-system-x86 (= 1:5.2+dfsg-6) but 1:5.2+dfsg-6+b1 is to be installed or
                             qemu-system-arm (= 1:5.2+dfsg-6) but it is not going to be installed or
                             qemu-system-mips (= 1:5.2+dfsg-6) but it is not going to be installed or
                             qemu-system-ppc (= 1:5.2+dfsg-6) but it is not going to be installed or
                             qemu-system-sparc (= 1:5.2+dfsg-6) but it is not going to be installed or
                             qemu-system-misc (= 1:5.2+dfsg-6) but it is not going to be installed or
                             qemu-system-s390x (= 1:5.2+dfsg-6) or
                             qemu-system-x86-xen (= 1:5.2+dfsg-6) but it is not installable
E: Unable to correct problems, you have held broken packages.

So, it looks like the upgrade of qemu-system-x86 violates the dependency of qemu-system-data.

Do I understand this correctly?  I didn't find anything about it in Debian bug tracker.  Anyone else?
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD2003FZEX in BTRFS


Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.117
    • Land of the Buckeye
Re: qemu dependency issue blocking d-u
« Reply #2 on: 2021/03/13, 12:49:36 »
Hah! So much for my search-foo!  Thank you hendrikL.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD2003FZEX in BTRFS

Offline dpanter

  • User
  • Posts: 21
Re: qemu dependency issue blocking d-u
« Reply #3 on: 2021/03/13, 13:39:34 »
Here's a dirty one-liner to grab a "quick" apt-listbugs check for all currently upgradable packages. Obviously apt update first or just throw that in there as well. :)

Code: [Select]
for p in `apt list --upgradable 2>/dev/null | awk -F'/' '{ print $1 }' | awk '!a[$0]++' | awk 'NR>1'` ; do apt-listbugs -q list $p ; done
<< insert signature here >>

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.117
    • Land of the Buckeye
Re: qemu dependency issue blocking d-u
« Reply #4 on: 2021/03/13, 13:54:27 »
Thanks @dpanter, that's some nice work -- way above my skill level.  Interesting that it does not report anything about this qemu-system-x86 problem.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD2003FZEX in BTRFS

Offline vayu

  • User
  • Posts: 223
Re: qemu dependency issue blocking d-u
« Reply #5 on: 2021/03/13, 22:43:35 »
So what's the result, put qemu-system-x86 on hold and wait till qemu-system-data comes in with the new version?

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.117
    • Land of the Buckeye
Re: qemu dependency issue blocking d-u
« Reply #6 on: 2021/03/14, 09:48:06 »
I think the only practical answer is ... patience. If it goes too long with no fix, I guess we can put qemu-system-x86 on hold to upgrade the system.

« Last Edit: 2021/03/14, 10:27:41 by dibl »
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD2003FZEX in BTRFS

Offline eriefisher

  • User
  • Posts: 67
Re: qemu dependency issue blocking d-u
« Reply #7 on: 2021/03/14, 15:57:15 »
I noticed that a couple days ago. I just let it go for a bit and figured something would show up but nothing so far. Soon. I just did a apt upgrade and everything else upgraded leaving qemu alone. I'm sure it will change in a day or two.

Edit: All fixed now.

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.117
    • Land of the Buckeye
Re: qemu dependency issue blocking d-u
« Reply #8 on: 2021/03/14, 17:58:43 »
Quote from: eriefisher
... I just did a apt upgrade and everything else upgraded leaving qemu alone.

Now THERE is a great suggestion!  Thanks.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD2003FZEX in BTRFS

Offline Pip

  • User
  • Posts: 97
Re: qemu dependency issue blocking d-u
« Reply #9 on: 2021/03/15, 09:24:28 »
It seems to be fixed now - apt full-upgrade not reporting any errors, with qemu packages being updated.

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.117
    • Land of the Buckeye
Re: qemu dependency issue blocking d-u
« Reply #10 on: 2021/03/15, 12:49:02 »
Yes, qemu-system-data has been updated, along with the other affected packages.

Code: [Select]
qemu-system-data:
  Installed: 1:5.2+dfsg-8
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD2003FZEX in BTRFS