seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2018/08/19, 02:32:15


Help

Recent Posts

Pages: [1] 2 3 ... 10
1
Upgrade Warnings (DE / EN) / Re: Kein update
« Last post by df8oe on Yesterday at 18:36:47 »
Kann ich leider (noch) nicht. Ich habe zwar eine Automatenmail von der Debian-Buglist zurückbekommen, kann aber meinen eingegebenen Bug noch nicht finden. Das ich gesehen hatte dass der eigentliche Bug "der den apt-Fehler nach sich zieht" schon gemeldet ist habe ich nur gemeldet dass die dependency so Sicherheitslücken nach sich ziehen kann.


LG
DF8OE
2
Upgrade Warnings (DE / EN) / Re: Kein update
« Last post by Kan on Yesterday at 17:13:05 »
3
Upgrade Warnings (DE / EN) / Re: Kein update
« Last post by absolut on Yesterday at 16:47:27 »
DF8OE, kannst du bitte den bugreport verlinken?

gruß
absolut
4
Upgrade Warnings (DE / EN) / Re: Kein update
« Last post by df8oe on Yesterday at 15:59:38 »
OK. Trotzdem full ack dass das keine Dependencies sein dürfen. Ich habe eben einen entsprechenden Bugreport gestartet.


LG
DF8OE
5
Upgrade Warnings (DE / EN) / Re: Kein update
« Last post by melmarker on Yesterday at 15:47:59 »
Nü, einfach nicht benutzen reicht auch aus - obwohl es zugegebenermaßen bequem ist :D

Code: [Select]
% LANG=C apt rdepends appstream     
appstream
Reverse Depends:
  Breaks: appstream-doc (<< 0.11.8)
  Depends: appstream-dbgsym (= 0.12.2-1)
  Breaks: libapt-pkg5.0 (<< 0.9.0-3~)
  Recommends: check-all-the-things
  Depends: plasma-discover (>= 0.8)
  Suggests: packagekit
  Depends: isenkram-cli
  Depends: gnome-software
  Breaks: libapt-pkg5.0 (<< 0.9.0-3~)
  Depends: apt-config-icons
  Suggests: appstream-doc
  Breaks: libapt-pkg5.0 (<< 0.9.0-3~)
  Recommends: apper
  Depends: plasma-discover (>= 0.8)
  Suggests: packagekit
  Depends: isenkram-cli
[b]  Depends: gnome-software[/b]
  Depends: appstream-index (>= 0.10.6-2)
  Recommends: apper
  Suggests: appstream-doc
[c/ode]

[code]
% LANG=C apt rdepends gnome-software
gnome-software
Reverse Depends:
  Depends: gnome-packagekit-session (>= 3.28.2-1)
  Depends: gnome-core (>= 3.22)
  Depends: gnome-core (>= 3.22)
  Depends: gnome-software-dbgsym (= 3.28.2-1)
 |Suggests: gnome-control-center
  Suggests: system-config-printer-common (>= 3.16.5-2)
  Suggests: system-config-printer (>= 3.16.5-2)
 |Recommends: packagekit-gtk3-module
 |Recommends: gstreamer1.0-packagekit
  Depends: gnome-core (>= 3.22)
  Replaces: gnome-software-plugin-snap (<< 3.22.3)
  Breaks: gnome-software-plugin-snap (<< 3.22.3)
  Depends: gnome-software-plugin-snap (= 3.28.2-1)
  Replaces: gnome-software-plugin-limba (<< 3.21.92)
  Breaks: gnome-software-plugin-limba (<< 3.21.92)
  Depends: gnome-software-plugin-limba (= 3.28.2-1)
  Depends: gnome-software-plugin-flatpak (= 3.28.2-1)
  Suggests: system-config-printer (>= 3.16.5-2)
 |Suggests: gnome-control-center
  Breaks: appstream (<< 3.22.5-1)
  Suggests: system-config-printer-common (>= 3.16.5-2)
  Breaks: gnome-software-plugin-limba (<< 3.21.92)
  Suggests: software-properties-gtk
 |Recommends: packagekit-gtk3-module
 |Recommends: gstreamer1.0-packagekit
  Depends: gnome-core (>= 3.22)
  Replaces: gnome-software-plugin-limba (<< 3.21.92)
  Breaks: appstream (<< 3.22.5-1)
  Depends: gnome-software-plugin-limba (= 3.22.5-1)
  Depends: gnome-software-plugin-flatpak (= 3.22.5-1)
  Depends: gnome-packagekit-session (>= 3.22.5-1)

Abgesehen davon, dass gnome und gnome-core metapakete sind, die eigentlich™ zu nix nutze sind und die man gehen lassen könnte - da wäre ein Haken bei: Wenn sich Paketierungen ändern, sorgen die Metapakete dafür, dass neue Sachen einfach aufgesammelt und installiert werden. Ikke würd die also einfach drin lassen und nicht benötigte Funktionen einfach ignorieren.
6
Upgrade Warnings (DE / EN) / Re: Kein update
« Last post by df8oe on Yesterday at 15:41:31 »
Ufff.....


Danke melmarker für diese echt gute Info. Das habe ich nicht gewusst, finde es absolut erschreckend und ein totales no-go.


Wenn es eine Abhängigkeit bleibt kann man die ausführbare Datei ja umbenannt lassen - dann schadet sie nicht  8)


LG
DF8OE
7
Upgrade Warnings (DE / EN) / Re: Kein update
« Last post by melmarker on Yesterday at 15:37:42 »
Man sollte den Debian-Gnomen auf die Finger hauen - appstream ist ne ganz feine Sache, um Dinge an apt vorbei direkt aus "vertrauenswürdigen" Quellen direkt aus dem Indernetzt zu installieren. Siehe auch apt show gnome-software.

Mit anderen Worten: Debian schafft sich grad selbst ab, so was sollte keine Dependency sein, Recommend ist mehr als genug. Irgendjemand™ sollte mal einen Bug-Report über beide Issues loslassen.

Und für unsere Freunde von KDE gilt das selbe, keine Schadenfreude: Plasma-Discover macht auch so einen Mist 8).
8
Upgrade Warnings (DE / EN) / Re: Kein update
« Last post by df8oe on Yesterday at 14:50:55 »
Ich schrieb ja: der Fehler ist noch da. Leider kann ich appstream nicht ohne Deinstallation von Gnome entfernen - also habe ich den "workaround" genommen und werde im Auge behalten, ob es bei gtk oder appstream irgendwas Neues gibt. Wenn ja, könnte es das Problem lösen.
9
Upgrade Warnings (DE / EN) / Re: Kein update
« Last post by ayla on Yesterday at 14:38:56 »
Danke, nach apt purge appstream lief mein D-U durch.Danach:
Code: [Select]
root@siducer:~# apt install appstream

Einmal funktionierte dann apt update, beim zweiten Mal schon wieder die bekannte Fehlermeldung
10
Upgrade Warnings (DE / EN) / Re: Kein update
« Last post by df8oe on Yesterday at 13:08:47 »
For those where complete gnome will be removed I do have a "dirty hack". Not good at all - but works and does not impact running system:


1) rename /usr/bin/appstreamcli to anyrhing else
2) now apt works flawlessly
3) hold in mind that you do have renamed appstreamcli!! You must rename it another time again to its original filename!


Actually (all u and du are passed by) the error persists, so I let it renamed.


Best regards
DF8OE
Pages: [1] 2 3 ... 10