Siduction Forum

Siduction Forum => Rollin', rollin', rolling => Rollin', rollin', rolling (DE) => Topic started by: Bequimão on 2011/08/21, 15:18:10

Title: [gelöst] LVM in testing mit aptosid-3.0-Kernel
Post by: Bequimão on 2011/08/21, 15:18:10
Hi,

Ich benutze hier Epidemic GNU/Linux 3.2, eine brasilianische KDE-Distro, die auf Debian testing basiert.
Darüber geschrieben mit weiterführenden Links habe ich hier: Linux-Forum.de: Epidemic GNU/Linux - Ein ansteckendes Erlebnis (http://www.linux-forum.de/epidemic-gnu-linux-ein-ansteckendes-erlebnis-1971381.html).
Zur Zeit bastele ich an einer deutschen Übersetzung.

Da der Kernel schon etwas veraltet ist (2.6.34), habe ich den aptosid-Kernel installiert. Funktioniert soweit ganz gut, nur wird das LVM nicht erkannt. Mit aptosid wird das LVM erkannt und kann gemountet werden.

Code: [Select]
root@ebox:/var/log# dpkg-reconfigure lvm2
 :: Setting up LVM Volume Groups  Reading all physical volumes.  This may take a while...
  Found volume group "lvm-gr1" using metadata type lvm2
  Could not determine kernel version used.
  0 logical volume(s) in volume group "lvm-gr1" now active
                                                                                                                                                                                           [EE]
update-initramfs: Generating /boot/initrd.img-3.0-3.slh.1-aptosid-686

root@ebox:/var/log# LANG=C apt-cache policy lvm2
lvm2:
  Installed: 2.02.84-3.1
  Candidate: 2.02.84-3.1
  Version table:
     2.02.84-3.1+c0.aptosid.1 0
        300 ftp://ftp.spline.de/pub/aptosid/debian/ sid/fix.main i386 Packages
 *** 2.02.84-3.1 0
        990 http://ftp.de.debian.org/debian/ testing/main i386 Packages
        300 http://ftp.de.debian.org/debian/ unstable/main i386 Packages
        100 /var/lib/dpkg/status

root@ebox:/var/log# LANG=C apt-get install lvm2/sid
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Selected version '2.02.84-3.1+c0.aptosid.1' (Debian:unstable [i386]) for 'lvm2'
The following packages were automatically installed and are no longer required:
  libtracker-client-0.8-0 gir1.2-gtk-2.0 libseed0 libgalago3 libpoppler5 libevince2 libmagickcore3 libmagick++3 libchamplain-0.4-0 libchamplain-gtk-0.4-0 libmagickwand3 libmagickcore3-extra
  libcheese-gtk18 openvpn-blacklist libpoppler-glib4 libdigest-sha1-perl
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
  lvm2
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/508 kB of archives.
After this operation, 1270 kB of additional disk space will be used.
Selecting previously deselected package lvm2.
(Reading database ... 214592 files and directories currently installed.)
Unpacking lvm2 (from .../lvm2_2.02.84-3.1+c0.aptosid.1_i386.deb) ...
Processing triggers for man-db ...
Setting up lvm2 (2.02.84-3.1+c0.aptosid.1) ...
 :: Setting up LVM Volume Groups  Reading all physical volumes.  This may take a while...
  Found volume group "lvm-gr1" using metadata type lvm2
  Could not determine kernel version used.
  0 logical volume(s) in volume group "lvm-gr1" now active
                                                                                                                                                                                           [EE]
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.0-3.slh.1-aptosid-686


Zusätzlich habe ich dkms und dmakms aus unstable bzw. sid installiert. Der alte Kernel ist deinstalliert. Alle Abhängigkeiten von lvm2 sind erfüllt. Irgendeine Idee, worin der Unterschied liegt?

Viele Grüße,
Bequimão
Title: RE: LVM funktioniert in testing mit aptosid-3.0-Kernel nicht
Post by: towo on 2011/08/21, 15:39:11
Du brauchst zusätzlich dmsetup, libdevmapper1.02.1 und liblvm2app2.2 von aptosid, sonst wird das Nyx.
Title: RE: LVM funktioniert in testing mit aptosid-3.0-Kernel nicht
Post by: Bequimão on 2011/08/21, 15:58:05
Danke für die schnelle Hilfe! Die 3 Pakete haben gefehlt. Es funktioniert jetzt.

Bequimão