Siduction Forum

BUGS => 2011-01 => Topic started by: planlos on 2012/01/03, 19:39:06

Title: Grafikproblem beim Bootvorgang
Post by: planlos on 2012/01/03, 19:39:06
Hallo zusammen,

erstmal Gratulation zum Release. Ist wirklich gut geworden - zumindest kann ich das für die Live-DVD behaupten, wie ein HD-Install aussieht kann ich derzeit nicht sagen. Das hat folgenden Grund:

Ich habe eine "relativ" neue AMD Grafikkarte (Radeon HD6850), die leider mit siduction nicht so funktioniert, wie ich mir das erhofft hatte. Wenn ich die Live-DVD normal starten möchte, endet das bereits nach wenigen Zeilen des Bootvorgangs in Pixelsalat. Das obere Drittel des Bildschirms wird quietsch-bunt, der Rest schwarz und dann geht nichts mehr. Nach einem Hardreset habe ich dann in Grub "Safe settings" gewählt und der Boot hat geklappt. Ich hatte gehofft, dass der Bootvorgang nach der HD-Installation nun automatisch funktionieren würde - leider ist dem nicht so. Ich habe den selben Pixelsalat wie beim Defaultboot der Live-DVD (KDE amd64).

Meine Fragen sind nun folgende:
1. Was muss ich in Grub eingeben um die Safe-Settings der Live-DVD zu simulieren?
2. Wie kann ich diesen Eintrag permanent machen?
3. Muss ich das überhaupt permanent machen oder darf ich hoffen, dass sich das Problem nach der Installation des fglrx-Treibers in Wohlgefallen auflöst?

Vielen Dank im voraus für eure Hilfe.

Schönen Abend noch
planlos
Title: Grafikproblem beim Bootvorgang
Post by: michaaa62 on 2012/01/03, 19:43:53
Im Bootmenü <F5> drücken,Safe Settings auswählen
Title: Grafikproblem beim Bootvorgang
Post by: towo on 2012/01/03, 19:44:46
1. radeon.modeset=0 als kernel-parameter
2. permanent müßte das nach /etc/defaul/grub und danach brauchts update-grub
3. ich würde versuchen, erstmal firmware-linux-nonfree zu installieren und dann /etc/X11/xorg.conf zu löschen oder umzubenennen.
4. fglrx ist auch eine Möglichkeit, solange Du nicht vor hast, Videos zu schauen.

Die xorg.conf muß aber für 3 oder 4 weg, da da vesa drin steht.
Title: Re: Grafikproblem beim Bootvorgang
Post by: towo on 2012/01/03, 19:45:29
Quote from: "michaaa62"
Im Bootmenü <F5> drücken,Safe Settings auswählen

In Grub gibts kein F5!
Title: Grafikproblem beim Bootvorgang
Post by: planlos on 2012/01/03, 20:06:06
Hi und vielen Dank für die schnellen Antworten.
Das mit radeon.modeset=0 hat funktioniert.
Ich werde nun das nonfree-Teil installieren und schauen wie es dann geht.
Eine Frage hätte ich noch @towo:
Du schreibst fglrx wäre auch eine Möglichkeit, solange ich nicht vor hätte, Videos zu schauen. <-warum?
Hat fglrx so eine schlechte 2D-Performance?
Wenn ja, was wäre die Alternative? radeon?

Gruß
planlos
Title: Grafikproblem beim Bootvorgang
Post by: towo on 2012/01/03, 20:11:18
Quote
Hat fglrx so eine schlechte 2D-Performance?

Nein, einen BUG in xv, somit chrashed X sobald man ein Video per Xv abspielen will. Dummerweise ist Xv Standard.